Jump to content
  • 0
baronaatista

[Oblivion] MenuQue and MO2?

Question

MO2 is giving me this error;

 

You have one or more script extender plugins which failed to load!
 
 If you want this notification to go away, here are some steps you can take:
  • Look for updates to the mod or the specific plugin included in the mod.
  • Disable the mod containing the plugin.
  • Hide or delete the plugin from the mod.
 
To refresh the script extender logs, you will need to run the game and/or editor again!
 
The failed plugins are:
  • OBSE_Kyoma_MenuQue_OLD version 0 (OBSE_Kyoma_MenuQue.dll, MenuQue - OBSE Plugin) reported as incompatible during query.
 
I installed the most recent version I could see available, v16b.  Not sure what gives.  I'm certain OBSE is installed correctly and working, and my MenuQue log seems to indicate everything is groovy? (a million thank-you's to the MO2 developers.  Wouldn't be considering modding Oblivion without that force-load workaround)
 

Query (compiled with 20)
Loading Submodule 'Data\obse\plugins\MenuQue\Submodule.Game.dll' ...
Attaching Submodule ...
Submodule loaded at 59FE0000
Load (CSMode = 0)
Initializing Submodule ...
OBSE Interface Map at <050C2AF8>
Loading INI
INI Path: G:\Games\GOG Galaxy\Games\Oblivion\Data\OBSE\Plugins\MenuQue.ini
Finished loading INI.
Registering Commands....
Registering command 'mqSetMessageBoxSource' w/ opcode 25D0
Registering command 'mqGetSelectedClass' w/ opcode 25D1
Registering command 'mqGetHighlightedClass' w/ opcode 25D2
Registering command 'Kyoma_Test' w/ opcode 25D3
Registering command 'mqGetEnchMenuBaseItem' w/ opcode 25D4
Registering command 'mqGetMapMarkers' w/ opcode 25D5
Registering command 'mqGetMenuChildFloatValue' w/ opcode 25D6
Registering command 'mqGetMenuChildStringValue' w/ opcode 25D7
Registering command 'mqSetMenuChildFloatValue' w/ opcode 25D8
Registering command 'mqSetMenuChildStringValue' w/ opcode 25D9
Registering command 'mqGetMenuChildHasTrait' w/ opcode 25DA
Registering command 'mqGetMenuChildName' w/ opcode 25DB
Registering command 'mqGetMenuChildCount' w/ opcode 25DC
Registering command 'mqCreateMenuFloatValue' w/ opcode 25DD
Registering command 'mqCreateMenuStringValue' w/ opcode 25DE
Registering command 'mqGetMenuActiveFloatValue' w/ opcode 25DF
Registering command 'mqGetMenuActiveStringValue' w/ opcode 25E0
Registering command 'mqSetMenuActiveFloatValue' w/ opcode 25E1
Registering command 'mqSetMenuActiveStringValue' w/ opcode 25E2
Registering command 'mqGetMenuActiveChildIndex' w/ opcode 25E3
Registering command 'InsertXML' w/ opcode 25E4
Registering command 'mqGetCurrentQuests' w/ opcode 25E5
Registering command 'mqGetCompletedQuests' w/ opcode 25E6
Registering command 'mqGetActiveQuest' w/ opcode 25E7
Registering command 'mqSetActiveQuest' w/ opcode 25E8
Registering command 'mqGetQuestCompleted' w/ opcode 25E9
Registering command 'mqUncompleteQuest' w/ opcode 25EA
Registering command 'mqGetActiveQuestTargets' w/ opcode 25EB
Registering command 'InsertXMLTemplate' w/ opcode 25EC
Registering command 'mqGetMenuGlobalStringValue' w/ opcode 25ED
Registering command 'mqSetMenuGlobalStringValue' w/ opcode 25EE
Registering command 'mqSetMenuGlobalFloatValue' w/ opcode 26B0
Registering command 'mqGetMenuGlobalFloatValue' w/ opcode 26B1
Registering command 'ShowGenericMenu' w/ opcode 26B2
Registering command 'ShowMagicPopupMenu' w/ opcode 26B3
Registering command 'ShowTrainingMenu' w/ opcode 26B4
Registering command 'GetGenericButtonPressed' w/ opcode 26B5
Registering command 'SetMenuEventHandler' w/ opcode 26B6
Registering command 'RemoveMenuEventHandler' w/ opcode 26B7
Registering command 'GetMenuEventType' w/ opcode 26B8
Registering command 'GetFontLoaded' w/ opcode 26B9
Registering command 'UpdateLocalMap' w/ opcode 26BA
Registering command 'GetLocalMapSeen' w/ opcode 26BB
Registering command 'GetWorldMapData' w/ opcode 26BC
Registering command 'IsTextEditInUse' w/ opcode 26BD
Registering command 'GetMousePos' w/ opcode 26BE
Registering command 'SetWorldMapData' w/ opcode 26BF
Registering command 'GetWorldMapDoor' w/ opcode 26C0
Registering command 'GetTextEditString' w/ opcode 26C1
Registering command 'ShowTextEditMenu' w/ opcode 26C2
Registering command 'SetTextEditString' w/ opcode 26C3
Registering command 'tile_GetFloat' w/ opcode 26C4
Registering command 'tile_GetString' w/ opcode 26C5
Registering command 'tile_HasTrait' w/ opcode 26C6
Registering command 'GetLoadedFonts' w/ opcode 26C7
Registering command 'tile_SetFloat' w/ opcode 26C8
Registering command 'tile_SetString' w/ opcode 26C9
Registering command 'tile_FadeFloat' w/ opcode 26CA
Registering command 'tile_GetInfo' w/ opcode 26CB
Registering command 'tile_GetName' w/ opcode 26CC
Registering command 'GetTextEditBox' w/ opcode 26CD
Registering command 'GetMouseImage' w/ opcode 26CE
Registering command 'SetMouseImage' w/ opcode 26CF
Registering command 'GetSkillCode' w/ opcode 27B0
Registering command 'IncrementPlayerSkillUseF' w/ opcode 27B1
Registering command 'TriggerPlayerSkillUseF' w/ opcode 27B2
Registering command 'ModPlayerSkillExpF' w/ opcode 27B3
Registering command 'GetPlayerSkillUseF' w/ opcode 27B4
Registering command 'GetPlayerSkillAdvancesF' w/ opcode 27B5
Registering command 'SetPlayerSkillAdvancesF' w/ opcode 27B6
Registering command 'GetRequiredSkillExpF' w/ opcode 27B7
Registering command 'GetSkillUseIncrementF' w/ opcode 27B8
Registering command 'SetSkillUseIncrementF' w/ opcode 27B9
Registering command 'GetSkillGoverningAttributeF' w/ opcode 27BA
Registering command 'SetSkillGoverningAttributeF' w/ opcode 27BB
Registering command 'GetSkillSpecializationF' w/ opcode 27BC
Registering command 'SetSkillSpecializationF' w/ opcode 27BD
Registering command 'GetAllSkills' w/ opcode 27BE
Registering command 'ShowLevelUpMenu' w/ opcode 27BF
Registering command 'SetTrainerSkillC' w/ opcode 27C0
Registering command 'GetRequiredSkillExpC' w/ opcode 27C1
Registering command 'GetSkillSpecializationC' w/ opcode 27C2
Registering command 'SetSkillSpecializationC' w/ opcode 27C3
Registering command 'GetTrainingMenuSkill' w/ opcode 27C4
Registering command 'GetTrainingMenuLevel' w/ opcode 27C5
Registering command 'GetTrainingMenuCost' w/ opcode 27C6
Registering command 'GetSkillForm' w/ opcode 27C7
Registering command 'GetAVSkillMasteryLevelC' w/ opcode 27C8
Registering command 'GetAVSkillMasteryLevelF' w/ opcode 27C9
Registering command 'tile_GetVar' w/ opcode 27CA
Checking AddActorValues...
Could not find DumpActorValueF command
Patched default faction rank text to None
UIMessage duration fixed with default length of 3 seconds
Patched item template names.
HUD Active Effects limit set to 8
GenericMenu preparement...
GenericMenu Good-To-Go!
Tracking the Big-Four-Giants
Prepare to launch our Super-Awesome-Tile-System...
Tile Parser........Done!
Tile Operators.....Done!
Tile Functions.....Done!
Tile Values........Done!
Super-Awesome-Tile-System is locked and loaded!
Submodule initialization completed successfully
Submodule initialized successfully.
Loading Fonts in Data\Fonts\Extra
String Literals...
&Kingthings_Regular;
&Kingthings_Shadowed;
&Tahoma_Bold_Small;
&Daedric_Font;
&Handwritten;
Finished loading fonts.
Expanding tile traits....
Code >> append
Code >> prepend
Code >> incl
Code >> cmp
Code >> tostring
Code >> length
Code >> active
Code >> &Scroll;
Code >> &TextEdit;
Code >> &FocusBox;
Code >> &DragRect;
Code >> &DragHorizontal;
Code >> &DragVertical;
Code >> focus
Code >> focussize
Code >> rotation (rot)
Code >> rotationx (rotx)
Code >> rotationy (roty)
Code >> rotationp (rotp)
Code >> ratio
Code >> animtime
Code >> locusx
Code >> locusy
Code >> locusdepth
Code >> locusrotation
Loading Strings in Data\Menus\Strings
Finished loading Strings.
Detaching Submodule ...

 

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Yessir.  It was your post about that the other day that turned me onto the fact that there is proper support now for Oblivion... 

Share this post


Link to post
Share on other sites
  • 0

That is good, another question. Is Mo2 installed in a directory not controlled by Windows UAC and out of the games directory?

 

Edit. When you set up the "Forced Load Libraries" did you put a check into the check box? It is easy to overlook.

 

Edit 2. Did you download the obse_loader.zip and overwrite the one that comes with the main archive?

Share this post


Link to post
Share on other sites
  • 0

Yeah, MO2 is not in the games directory and not controlled by UAC

 

Box is definitely checked

 

... Didn't replace the .exe from 'latest loader' package on the OBSE site.  I have now... it was my understanding that loader wasn't used anymore unless dealing with CS?

Share this post


Link to post
Share on other sites
  • 0

Using the 'latest loader' from the OBSE site didn't change anything.  MO2 still gives me that error, and the MenuQue log still appears fine... from what I can tell.

Share this post


Link to post
Share on other sites
  • 0

Well it was worth a try. From the limited search I have done it appears this has been going on for some time, so I don't think there is a solution out there. You can try asking on the MO2 Discord forums #issue-reports.

Share this post


Link to post
Share on other sites
  • 0

I did see a post on Nexus about it, just most of the information there appealed highly ambivalent.  Submitted an error report on the Discord, I'll post back here if I learn anything.  Thanks for taking the time GSD!

Share this post


Link to post
Share on other sites
  • 0

You haven't done anything wrong. This is a thing with MenuQue, not Mod Organizer, MO just catches it and tells you. Basically, MenuQue includes two files, MenuQue.dll, which contains the plugin "OBSE_Kyoma_MenuQue" and OBSE_Kyoma_MenuQue.dll, which contains "OBSE_Kyoma_MenuQue_OLD", the latter of which is incompatible and causes the error.

Why is it included? No idea. Is it necessary? Also no idea. Maybe? The new plugin might access it somehow, but I have no clue. I do know that it doesn't cause any issues with the game, though. OBSE sees that it's incompatible, writes that to the log and then ignores it, so no harm done. 

Share this post


Link to post
Share on other sites
  • 0

Well, I was going to edit my last post to provide a final explanation for this, but I guess not, so here's a double post I suppose.

 

OBSE_Kyoma_MenuQue.dll is actually just a dummy file added in v15 because of users not properly uninstalling older versions that used a different naming scheme. The file's only purpose is to replace really old installs, and it's safe to delete. The info was in the readme all along, lol.

 

v15

* Minor changes to layout of source files and docs.
* Now includes a dummy dll with the old filename (OBSE_Kyoma_MenuQue) to ensure the old dll doesn't accidentally get loaded.
Edited by Paynamia

Share this post


Link to post
Share on other sites
  • 0

No problem on the double post. It is that way to preserve the info so others may find it. Thanks for the update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By qwrtui1245
      Hi, 
      I'm modding SkyrimSE with MO2 by following this version of the step guide: https://stepmodifications.org/wiki/SkyrimSE:1.0.0#04-Foundation. I've followed everything until now but experience problems with the first mod I need to install without using Nexus. It's Skyrim SE particle patch for ENB and I downloaded 'SPECIAL EDITION > ALL-IN-ONE INSTALLATION > LATEST VERSION (GOOGLE DRIVE)'. It's installation went fine (Situation A) but when I have to enable the optional ESP 'Particle Patch for ENB SSE.esp' I get the message 'Plugin not found: Particle Patch for ENB SSE.esp' in my log (Situation B). 
      I've tried: reinstalling the mod, refreshing, enabling and disabling the mod, restarting MO2, re-downloading the file. It doesn't fix my problem. I've added the pictures of situation A and B. I hope there are people who can help me here. Thanks so much in advance!
      Situation A

      Situation B

       
    • By Newtant
      Hello!

      I've stumbled upon a weird issue that I haven't encountered or read about before. I'm running Windows 8.1 and a fresh install of Fallout New Vegas with no mods so far. I'm trying to get Mod Organizer and the 4GB exe to work together, but despite following all of the advice, tips and workarounds it's still not happening. Right now I can launch the 4GB exe through Mod Organizer. The game starts, I can load a save and 'play'. The problem is that all of the text has disappeared or is invisible. I can only navigate the main menu by memory, the ingame popups regarding the DLC is missing the text as well.

      This issue does not happen if I start the game on its own with the normal exe.
      This issue does not happen if I start the 4GB exe on its own.

      It only happens if I start the either the normal or the 4GB exe through Mod Organizer.

      NVSE is being loaded, it doesn't matter if I'm using NVSE stable or beta.
      I'm using NVAC, without it the game crashes before arriving at the main menu. NVAC seems to be working, the log is showing several handled errors. (Pastebin)
      Yes, I've added '-laaexe .\FalloutMO.exe' to the launch arguments, that helped me get around the access is denied error but produced this text error.
      I did try compatability modes, I've tried starting MO, the 4GB or both as administrator. No dice.

      I've arrived at a point where I really don't know what it could be or what I could try next. One thing I do know, however, is that I can't go back to the pre-MO modding, so I'm turning to you helpful people and hope that someone here has an idea.

      Thanks in advance!
       
      Pictures:
      New Vegas installation folder
      Mod Organizer executable settings
      Disappeared text main menu #1
      Disappeared text main menu #2
      Disappeared text ingame
       
      Edit:
       
      I deleted all of the fallout .inis as well in case some of my text/font settings were messed up, but that didn't work either.
    • By Dennai
      Is there a way to make GaryBash work with MO in Fallout 3? I tried to use it as executable, but MO wouldn't recognized the Wrye launcher as such. It surprised me, because MO had no problem recognizing the Wrye Bash launcher for Oblivion, but I don't have the same luck with Wrye Flash. When I browse the Moppy folder to try to find the Binary, Wrye Bash Debug is the only application the MO can see.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.