Jump to content
  • 0
aqwimage

An example of why pirated games are not supported by STEP.

Question

The original title set by this user was: "Mod Organizer 2 Textures not working" however as I've pinned this as an example of why cracked games are not a viable alternative for gamers, aside from the legal/moral issue, I'll edit this first post for posterity's sake.

 

This whole thread was conducted to provide verifiable proof of why cracked games are not just the game minus any DRM support. They can contain bad code that may play badly with all manner of things inside your game and, as shown here, mess with how other tools work with the game assets.

 

This user, in the end, relented and purchased the game legally, for which they should be commended. It is all too easy to fall into a laissez faire attitude and not make changes.

Anyone that reads this and thinks piracy is okay needs to re-evaluate that stance on a number of levels.

 

 

So let's get the questions you will ask out of the way (most of them i hope) 

 

1.) Mod organizer 2 is installed outside of game directory 

2.) I am using LATEST MO2 (2.1.1) 

3.) I ONLY have skyrim SE installed

4.) I ONLY have MO2 insalled and not original mod organizer 

5.) It happens when I enable .esp and even if I disable the .esp it will not work. I have to delete that MO2's profile and use default MO2 files to get it to work again

6.) YES I am running SKSE through MO2 

 

 

The texutres not working are nobel skyrim+ vivid All in one. 

Here are a few images 

https://imgur.com/a/pkKP5

 

EDIT 

 

It seems like I am not the only person with Textures issue however that guy had a LARGEEE amount of mods. Also something iforgot to add, the textures don't show any  red color conflicts if .esp are not enabled. (in the left DATA tab) 

Edited by GrantSP

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Ok it is working now with non cracked version. Please tell future users that if you use a cracked SSE copy then it will cause issues with textures (or atleast it might be one of the issues) 

Share this post


Link to post
Share on other sites
  • 0

The first thing that comes to mind is there are dirty edits in the plugin that are pointing to the incorrect textures.

 

Basically if the set of textures defined in MO2's Data tab, or in the "Conflicts" tab, is showing the correct files there is only one way that they will not show. That is if they are defined in the plugin.

Once MO2 is handed the set of files that are in the VFS there is no further input into the game that MO2 provides. This basically means I can't see how this is an issue caused by MO2.

Share this post


Link to post
Share on other sites
  • 0

So what can I do to fix this? I also want to let you know that the textures work WITH the .esp if I put the textures directly in the skyrim data foldor and then enable .esp from mo2. 

Share this post


Link to post
Share on other sites
  • 0

Okay. Clear the contents of your "logs" folder and then go to Settings and make sure the log level is at 'Debug'.

Enable only the mods you have in your screenshot but disable the Verdant plugin and then post the logs here. Be sure to use 'spoiler' tags or use a service like PasteBin.

Then enable that plugin and post the new USVFS log here so I can see what the VFS is doing when it is loaded.

 

From what you have just told me there could be an issue with the VFS code. We are already onto testing a few beta VFS DLLs in the Discord server so it may just be a case of you needing to use one of those.

Share this post


Link to post
Share on other sites
  • 0

Share this post


Link to post
Share on other sites
  • 0

Two questions. Where is the ModOrganizer.log, that's the one that tells us the settings of your installation and is this install of Skyrim a "non-Steam" one?

Share this post


Link to post
Share on other sites
  • 0

There is no modorganizer.log file there is a mo_interface.log file. Also I bought this game on G2A and it was activated with Steam after installing the games I move them to a separate hard drive (from my D drive to C and sometimes to my my external E drive) .  Like I bought Dead by daylight and moved it to my C drive with a separate folder. 

Share this post


Link to post
Share on other sites
  • 0

Can I have the mo_interface.log please? Just checking on the status of the game because the path is clearly different and I have seen a lot of crack'd games lately and I'm starting to wonder what the correlation is.

Share this post


Link to post
Share on other sites
  • 0

Alright no problem, if you want I can change the installation directly to steam\steamapps\common but I don't like to install games there (if i don't have to) so I move it. I have maving games in it's own individual directory so I can be more organized. 

 

SHOT I FORGOT I installed dawn of skyrim, just an heads up. 

 

https://www.mediafire.com/file/o22dbubvyt83p22/mo_interface.log

Share this post


Link to post
Share on other sites
  • 0

Can you try moving MO2 out of the sub-folder of the Skyrim install?

We've recently found that there are more issues when it is installed there.

 

Also there are some later editions in the Discord server that may help. Goto the #builds channel and install the latest version and the beta 5 of the USVFS DLLs.

Share this post


Link to post
Share on other sites
  • 0

I moved mo2 outside of the sub folder and i downloded the usvfs-0.3.1-beta5 and placed the dll in the mo2 main directory but textures still not working with .esp, it's just randomly not working. 

Share this post


Link to post
Share on other sites
  • 0

What settings are in the INI Tweak? If you disable that INI change does it still fail? Honestly I'm at a loss to see how/why a mod that changes grass textures would have any impact on buildings, the only thing else is wild edits in that plugin, but since the texture pack you linked to only changes vanilla assets without assigning new paths, even that shouldn't matter, so I have no clue.

 

As you can see in your screenshots MO2 is saying you have those textures in the VFS from that specific mod.

 

Are there any other mods that are also trying to change those textures? If so try MO's "hide file" feature.

Share this post


Link to post
Share on other sites
  • 0

Ok I think I am not explaning this correctly. Maybe I can make a video for you and you can watch that. Would that work? So basically when ever I enable a .esp sometimes it's A quality map that will make textures stop working other times it will be Skyrim Flora overhaul other times it will be another texture itself. To fix this issue, I just delete that current profile and start another one and it will work again but it's just random (or atleast from what I can see it is) 

 

 

SO DO YOU WANT ME TO MAKE A VIDEO SHOWING YOU WHAT'S GOING ON? 

Edited by aqwimage

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.