Jump to content
  • 0
nieda113

MO2 and Fallout4 profiles

Question

First MO worked fine until today.  I have  two profiles  . Profile 1 is:  Default ,     Profile 2 is: Player1

 

I started playing with profle default for a couple of days  and than installed a second profile  player1 because profile defaulthas  some screwd up mods.

 

I left profile one  as is and  installed the mods in properly in profile :player1

 

Here i played for a week  with no problems.

Today i thought i will ceck profile default and so disabled all mods,  to install those again.

 

I started the game , (no mods installed just some basic stuff) just to check and closed the game after a few minutes with no save.

 

I switched back to the second profile player1 and got the message  F4SE needs to be updated ( but the latest version is already installed) and a second notice that all mods were uninstalled although they were checked active in the used profile.

 

So why are the unchecked mods in the default profile show as missing when changing the profile to player1? 

Why is F4SE to update ( the newest version is installed 1.04)

 

Is it not save to use different profiles?

 

THX for reply

Edited by nieda113

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

As far as F4SE I do not know why that would do that.

 

Think of the left pane as a pool of mods to draw from. All profiles have access to them. Mods are not profile specific unless you install it a second time and rename it to reflect the profile, "Mod Bob profile2 player 1".

Share this post


Link to post
Share on other sites
  • 0

Hi thx for that rlpy.

So the default profile  mod has all mods checked in the left paine.

When i created a second profile and enabled it in MO no mod on the left paine was checked though.

 

What i did i enabled those mods by checking the left paine .

 

So u say to for example install the mods again with a different name.e.g. " valdacils sorting item"  to "player1valdacil sorting item" ?

I will end up having all mods installed double but with the player1 prefix , right? 

 

I will see all mods in default and player profile then.

Do i have to uncheck the default mods everytime i switch profile and only have enabled the mods for the specific profile

 

(anyways that explains why when i unchecked the mods in the default profile and enabled the same mods in the second profile i was missing all mods because the default profile takes precedence)

Edited by nieda113

Share this post


Link to post
Share on other sites
  • 0

We need to see your logs and your INIs to diagnose this further. What you are describing is not the way MO/MO2 works.

 

ALL mods are installed globally, ie. any profile can activate them in the left pane, however active mods are active ONLY in the profile they are activated in.

 

e.g. Profile1 has mods: 1, 2, 3, 4 & 5 installed with only 1 & 2 active

You switch to Profile2 and none of these mods will be active until you activate them, so you do so for all 1 - 5 mods.

Switching back to Profile1 will have ONLY mods 1 & 2 active again.

 

As for F4SE if you have a mod active in the new profile that requires a newer version of F4SE than that which is installed that mod may prompt you with a message like that. Your previous profile may have mods that do not require the latest version. I'm only speculating here as you haven't told us whether the message is in-game or from MO2. If MO2 is telling you this then it may just be a simple case of your mod not having the correct Nexus information stored in its meta file. Open the 'Information' dialogue and check the Nexus version.

Share this post


Link to post
Share on other sites
  • 0

Hi, i ll gave it a try today and i deinstalled all mods and created three different profiles. It seesm to work as it did weeks ago,, so i dont know what the problem was,, i guess the savegames  seemed to be related to the problems.. i deleted almost all and started a new game. I copied all initial saves from the default profile to the others and it worked.  THX for helping.

 

(maybe  i made a mistake when loading save games and not changing the player character name)

Share this post


Link to post
Share on other sites
  • 0

To the best of my knowledge, the save game for profiles is broken in MO2. It only reads from the MY Games saves folder.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.