Jump to content
  • 0
Dragora

MO2 complains about plugins not loaded

Question

Today I tried to install MO2.

Upon installation it downloaded a lot of plugins from Github.

Still it complains about a lot of plugins not loaded.

That is MOs own plugins.

 

I wish there was a portable archive download available

Edited by Dragora

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Looking over your post again and I believe it is because you've installed MO2 over the top of your MO installation haven't you? Those plugins are for MO, MO2 uses differently named files for the same processes.

You can have both MO and MO2 installed on the same machine and use them for different games, this is how I have it at the moment. Simply wipe your MO/MO2 install and reinstall either MO2 alone or both MO/MO2.

I use a simple folder structure on one of my drives like this:

D:\Games\ModOrganizer\<name of game>\ (where <name of game> is either Fallout3, FalloutNV, Oblivion or Skyrim. A different install for each game.)

D:\Games\ModOrganizer2\ (Same thing here for SSE and Nehrim, Fallout4 doesn't grab me.)

Share this post


Link to post
Share on other sites
  • 0

What is it asking for? I grabbed the latest compiled release and it just installed with no issue for me.

 

Did you use this release?

Share this post


Link to post
Share on other sites
  • 0

It basically said that a bunch of dll-files were not loaded. The ones it downloaded from github.

I used the latest exe on Nexus (2083b)

It installed fine. Complaining at startup.

Edited by Dragora

Share this post


Link to post
Share on other sites
  • 0

Other than complaining about those files, is it actually running properly? I ask because the next few lines of the log show they are being loaded.

You might try moving your MO installation out of the "GOG Games" folder. The space in the name may be the reason. There was another user that had a similar issue like this but as far as the code goes it shouldn't really be a problem.

Share this post


Link to post
Share on other sites
  • 0

Yes, it looks to be running as it should.

But this is from the problem window:

The following plugins could not be loaded. The reason may be missing dependencies (i.e. python) or an outdated version:

  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/bsaExtractor.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/checkFNIS.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/diagnoseBasic.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/gameFallout3.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/gameFalloutNV.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/gameOblivion.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/gameSkyrim.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/installerBAIN.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/installerBundle.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/installerFomod.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/installerManual.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/installerNCC.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/installerQuick.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/NMMImport.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/previewBase.dll
  • D:/Spill/GOG Galaxy/Games/Nehrim/ModOrganizer/plugins/proxyPython.dll

Remember it downloaded whatever it wanted to during installation

 

I tried to move it . That did not go well.

Got the same error.

 

I am beginning to think if this newer version  is too bugged. Will check the exe you pointed to earlier.

No, same thing. Should I upload the MO folder somewhere so that you can take a look at it?

Edited by Dragora

Share this post


Link to post
Share on other sites
  • 0

No, none of those plugins will have any impact on your Nehrim install.

Share this post


Link to post
Share on other sites
  • 0

That does not matter anymore. As you know I mentioned that it behaves very strangely with Nehrim and still have the glitch from the other thread once the game finally loads,

It's much more important how it works with SSE and FO4 with the missing plugins. They will contain many more mods than Nehrim

But that's quite a while in the future.

Share this post


Link to post
Share on other sites
  • 0

Yes, you are right. It was a stupid mistake to upgrade from Mo 1 to 2 without uninstalling first.

 

I installed it into SSE where MO never were installed before. All's fine now.

 

Thank you for your time and patience in these two matters, even if one was not possible to solve.

 

Edit: I can't find a way to mark your answer.

Edited by Dragora

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.