Jump to content
  • 0
mentaltyranny

After installing 2nd gpu, intro wagon flipping, get z-fighting, and pixilated shadows

Question

I have been installing STEP and STEP extended over the lat couple days.  I had no problems (other than finding Xenius mods) until after I completed 2.I. However, on this step I also installed a second Gigabyte - GeForce GTX 970 4GB WINDFORCE 3X Video Card to my Asus - Z97-A/USB 3.1 ATX LGA1150 Motherboard (yes, I just found out that the PCI-e x16 slots become x8/x8 with 2 gpus - rookie error). I enabled SLI (gsync has been on before AND after) and went to test my Skyrim setup, and BAM my cart flipped in the intro!

 

After a wild ride, I noticed that I see z-fighting in the mountains above Helgan and once the sun comes out, the character shadows from their heads to their clothes looks pixilated and crappy.  Now it could be that I just noticed the z-fighting and pixilated shadows because I became really aware after my cart flipped, but I am 90% sure that they were not present until I installed my second gpu.  After loading Skyrim Performance Monitor I noticed that the frame rate was jumping insanely high when the cart started shaking, despite v-sync...  What is going on?!

 

I did manage to fix some of it.  I stopped the cart flipping by disabling gsync, which is strange because it definitely worked fine before with the iPresentInterval, nvidia inspector, and ENBoost all enabling vsync as well before the second card.  Confirmed with SPM that fps stayed < 60. I reduced, but did not eliminate, the z-fighting by setting fSplitDistanceMult=2.0000  in SkyrimPrefs.ini; I was afraid to try fSplitDistanceMult=2.5000 because of texture clamping I read about in the STEP z-fighting guide.  I have no idea how to handle the pixilated shadows.

 

After much angst, I decided to pull out my second gpu later tonight and confirm that the z-fighting and pixilated shadows are gone, as well as cart flipping.  I am hoping that someone here has a brilliant idea that makes it unnecessary to do so.  I have considered installing BETHini, considering it was made by a STEP staffer, but I am afraid of messing up the inis I carefully edited and confirmed during the STEP mod process.  I am surprised that it isn't already in the guide somewhere, and I take the fact that it is not as a sign of trouble using it with STEP.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Okay, I finally removed the cart flipping with gsync ENABLED and using SLI.  I followed the post here, with the exception of, instead of 85, setting the FPS cap to 58.7 in nvidia inspector (which what I think he meant to say and just typed it in reverse as "set fps cap to 85") and ignoring setting -iFPSClamp=0 (iFPSClamp is not in my INIs anywhere at any setting, and looks like that is the default according to the INI guide wiki anyway).  Frame rate does go a little above 58, but never over 60.  Wild cart rides are no more!

 

As for the z-fighting and pixilated shadows, I am going to use bethINI.  However, considering that it makes INI edits based on mod configuration, I am not sure where in the STEP Core & Extended process to run bethINI... now? After completing STEP? Between 2 steps in the mod installation process somewhere? Any help, as always, is much appreciated.

Edited by mentaltyranny

Share this post


Link to post
Share on other sites
  • 0

BethINI is completely safe. It backs up your settings before you use it, so you can always go back.

 

If you are worried about it (which there is no need to be, IMO), just back up your INI's prior to using BethINI. The reason it is not in the Guide is simply that when the guide was released, the tool was still in development. Now it is mature, and will very likely replace the custom INI tweaks for next release.

 

As to your other issues: I really don't know much about multi-GPU setups, so I will leave that alone. Best of luck, and hopefully someone else knows a bit about the subject.

Share this post


Link to post
Share on other sites
  • 0

BethINI is perfectly safe to use and will be replacing the INI section in the next release...no "likely" about it. :^_^: The only thing to remember when running it is to verify your grass settings in the installer because it doesn't always pick the right settings there.

 

As for multi-card setups, I've never ran one but if I remember correctly, there seemed to be a couple hoops to jump through to get it all working correctly. If keeping it within 60FPS is one of the issues, just turn on the frame rate limiter in Inspector and gsync off. I'd recommend 59 FPS because it can fluctuate over 60 from time to time.

 

I also doubt that you need ENBoost with that card. I could run without it on my 4GB GTX 760. That is, if you're not playing at really high resolutions and not using 4K textures everywhere. Just running STEP at 1920x1080, I never had any issues with my 4GB card and not running ENBoost.

 

Shadows...try BethINI.

Share this post


Link to post
Share on other sites
  • 0

@mentaltyranny, go into the Nvidia control panel the game and set the "monitor technology" to "Fixed Refresh". It will help with wild fps fluctuations and stutter. No need for Gsync on a game that is locked to 60fps.

Share this post


Link to post
Share on other sites
  • 0

After restoring to "pre-second gpu" settings, and verifying that all three problems were still there, I pulled out the second card.  While I no longer had the cart flipping issue, I did have z-fighting and pixilated shadows.  Guessing that I just didn't notice before... So I decided to pop back in the second gpu and go with it.

 

Okay, I am having trouble turning off gsync. I can do it globally through the control panel, and that works fine.  But I play other games so I prefer to do in inspector.  Yet I can't figure out which combination of gsync in the Skyrim profile. Every gsync setting I mess with leads to CTD immediately upon game load.  I even turned off gsync through the control panel, looked and wrote down the settings in inspector, turned gsync back on, entered those gsync settings into Skyrim inspector profile, and CTD!  Any ideas?

 

Also, looking at BETHini, the installation instructions seem to be installing it post mod installation, is that correct?

Share this post


Link to post
Share on other sites
  • 0

I have a couple gsync monitors and I've never had a problem with it. Also the game shouldnt care what framebuffer thing is being utilized. The game does have problems with framerates higher than 60, but that is probably because the physics is only calculated every 1/60 of a second.

There are ways around this 'limit' in sse, not sure about oldrim.

 

Zfighting has always been there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.