Jump to content
  • 0

FPS and VSync


Shadriss
 Share

Question

So here's a weird one - not sure when this started happening, and I only noticed it yesterday or the day before. I was running around near Valtheim Towers when I noticed some screen tearing. Apart from this telling me that my game can obviously take more stuffs (60+! YAY!), it also told me something was off, since I should not be GETTING above 60 with vsync set on. Naturally, I checked to be sure it was on - it was. iPresentInterval was set to 1 (in both ini files, oddly enough) and vsync was set to on in the ENBlocal.ini. This should have prevented it, but during testing, I hit 70-90 inside Kynareths Temple in Whiterun, and over 700 while in the menu.

 

Apparently, the settings are not taking correctly.

 

Any advice here? I've gone back through he guide to make sure I didn't miss anything, and I haven't seen anything else to this point.

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Big negative. An FPS limiter would actually half-solve the problem, since it's the high FPS that caused me to notice the issue in the first place. *shrug*

 

Oddly enough, it seems to have fixed itself with no help from me... maybe the FPS cap too a weeks vacation and got back last night?

Link to comment
Share on other sites

  • 0

soupdragon: Disabling Vsync in Skyrim.ini and enabling it only through enblocal is incorrect, here is why

 

Disable Vysnc (iPresentInterval=0) in Skyrim.ini and make sure EnableVsync is set to true in enblocal.ini save both files and go into game, on the front it looks fine right, capped at 60 fps or lower while moving.

Stand still and open up a menu, you will now see that your fps skyrockets into the hundreds or higher, this is a case of Vsync not being enabled properly, so to fix this go back to Skyrim.ini and set iPresentInterval=1 and save

now go back into your game and the frames still look the same while moving right, no difference ? Wrong. Pause your game now, notice how the frames even in the menu are now locked at 60fps or bounce around at 58 - 59fps, this is Vsync in action, it maintains the frames per second to the actual refresh rate of your gaming tv/monitor so if your device can render quicker than 60fps this will increase to your maximum supported setting.

 

iPresentInterval (Skyrim.ini Vsync) and EnableVsync (ENB Vsync) do not do the same job, they are required by one another to work in unison in order to achieve the desired result when using an ENB.

 

 

Side note, if you use a lot of high res textures and your fps doesn't run at 60fps or close to it then you are likely to never notice this issue unless you actively look for it, I.E pausing the game and comparing fps while moving to fps while stationary and in a menu

Edited by Rebel47
Link to comment
Share on other sites

  • 0

Basing my reply off your initial post where you said that having it enabled in both ini's and enblocal it rendered the Vsync unable to work as advertised, I do wonder if this is a byproduct of having the line in both ini files, I have never personally experienced this but I only have it in Skyrim.ini, secondly do you happen to have Vsync enabled through your driver as this would likely conflict.

 

Your reply to Doubleyou mentioned a FPS cap, are you enabling this through enb as well, I find that I have never needed to enable Fps limit within enblocal.ini or the in game gui, I'm posting this information up because it may prove useful should this happen again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.