Jump to content
  • 0
Sign in to follow this  
Pawelekdabek

Error when generating LODs with Cathedral Landscapes installed

Question

Hi,

 

So i have tried to generate LODs with Cathedral Landscapes mod installed but i keep getting same error over and over. I tried redownloading this mod from Nexus but it did not help. Of course I can exchange this mod for any other texture mod but this one is really pretty.

 

Bugreport:https://pastebin.com/qQGaKLKV

Tamriel_log:https://pastebin.com/Vv3wQudP

 

I know that this one mod is a problem because i ran multiple generations to find what was causing my problem, and without this mod i could generate with no errors. I tried swapping this mod for Serpentials Landscape Mod and also no errors (but they are awfull for my taste).

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

I also ran generation with only essential mods and Debug=1

 

Bugreport:https://pastebin.com/3emQPfPv

Tamierl_log:https://pastebin.pl/view/f1b5551f (pastebin.pl bc it was too big for pastebin.com)

 

I was following step guide for 3D trees LODs so TreeFullFallback=0 and TreeLod=0 but i think it is okay as i was able to succesfully generate LODs with other texture mod.

Edited by Pawelekdabek

Share this post


Link to post
Share on other sites
  • 0

Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 

 

Did you clean Update.esm and the DLCs with the latest xEdit and autoclean method?

 

I have no error generating with Cathedral Landscapes installed.

 

There is an out of memory message in the bug report, so check if closing any unnecessary (background programs/services) helps.

Also leave the OS page file settings at default.

Test if closing the spawned LODGen command prompt window as soon as it spawn helps.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 

I was following S.T.E.P guide. I was generating LODs with other texture mods without any problem with this setting set to "0"

 

Did you clean Update.esm and the DLCs with the latest xEdit and autoclean method?

Yes, everything is cleaned, LOOT shows no warnings.

There is an out of memory message in the bug report, so check if closing any unnecessary (background programs/services) helps.

Also leave the OS page file settings at default.

Page file is unchanged. When i generate LODs i do not use my PC nor any program is running in the background.

 

I have no error generating with Cathedral Landscapes installed.

I will try to run it one more time with TreeFullFallback=1 and with PapyrusUtil SE, DynDOLOD Resources SE and Cathedral Landscapes only.

Share this post


Link to post
Share on other sites
  • 0

I was following S.T.E.P guide. I was generating LODs with other texture mods without any problem with this setting set to "0"

Do you know why to set it to 0 or are you just following instructions...

 

Page file is unchanged. When i generate LODs i do not use my PC nor any program is running in the background.

For example, the bug report shows Steam running. It is not required for generating LOD.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Do you know why to set it to 0 or are you just following instructions...

 

 

For example, the bug report shows Steam running. It is not required for generating LOD.

Have no choice but to break the log into 4 parts, pls check:

Part 1: https://pastebin.com/sN8RfEhG

Part 2: https://pastebin.com/vM8FNrkT

Part 3: https://pastebin.com/aw5pE39a

Part 4: https://pastebin.com/tfhFDS3n

Edited by massiveactive

Share this post


Link to post
Share on other sites
  • 0

Do you know why to set it to 0 or are you just following instructions...

It was described like it is higher visual quality option. I read manual for ultra trees and you wrote that it should be used only for testing not for gameplay. Why is it in S.T.E.P guide then? Since the guide is intended for newbies, this option should not be included in it.

 

However, i ran it with all mods, TreeFullFallback=1 without any errors. 

 

I have two more questions.

1. I am experiencing distant texture flickering. Can it be fixed with DynDOLOD

2. What does NearGridToLoad and FarGridToLoad does? Can i benefit form setting both options higher? I was reading manual but i do not really understand it.

Edited by Pawelekdabek

Share this post


Link to post
Share on other sites
  • 0

1. The question is not very specific what is flickering. Probably large reference bugs.  See FAQ Q: Game: Out of place objects / floating objects / flickering full models

 

2. The manual has this very nice graphic that shows how many cells around the player the loaded cells (uGridsToLoad), the NearGrid and the FarGrid are. How am I supposed to explain it any way different than I already did in the manual? These are the 2 areas/distances that DynDOLOD adds dynamic and animated LOD to. If you make them larger than those objects will shows even further at the cost of performance. If the visuals are actually any better depends on a number of factors. Just make a second LOD mod with different settings and then compare if the visual and performance impact are acceptable.

Edited by sheson
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

1. The question is not very specific what is flickering. Probably large reference bugs.  See FAQ Q: Game: Out of place objects / floating objects / flickering full models

I think my problem is called z-fighting.

Share this post


Link to post
Share on other sites
  • 0

I think my problem is called z-fighting.

Yes that it is what texture flickering between two similar shapes with different textures is called.

 

However, you have no explained or shown with a screenshot what it is that is actually flickering. See FAQ Q: Game: Out of place objects / floating objects / flickering full models

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

It was described like it is higher visual quality option. I read manual for ultra trees and you wrote that it should be used only for testing not for gameplay. Why is it in S.T.E.P guide then? Since the guide is intended for newbies, this option should not be included in it.

I've removed it as an option in the instructions. I can run Full LOD without issue, but that doesn't mean others can.

 

Keep in mind that the STEP SE Guide is still in beta. Please feel free to report any issues with it using our Bug Report topics.

Share this post


Link to post
Share on other sites
  • 0

Okay, so i did a video on this textures flickering. It was existing save but i tried also on new one and it is the same. LODs are newly generated.

That video seems to show the already mentioned large reference bugs.  See FAQ Q: Game: Out of place objects / floating objects / flickering full models. The last answer.

Edited by sheson
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Thank you, that did worked.

 

Last question. I am using HD Skyrim SE Textures and i have problem with horse stall building near Whiterun. It's LOD texture have red roof but full texture is yellow. Is it possible to somehow change it but also retain redroof lod of Whiterun buildings?

 

https://imgur.com/a/DwgVfD2

Share this post


Link to post
Share on other sites
  • 0

Thank you, that did worked.

 

Last question. I am using HD Skyrim SE Textures and i have problem with horse stall building near Whiterun. It's LOD texture have red roof but full texture is yellow. Is it possible to somehow change it but also retain redroof lod of Whiterun buildings?

 

https://imgur.com/a/DwgVfD2

You have installed a mod that replaces the single object LOD texture textures\lod\wrbuildingslod02.dds which seem to have made the thatch look red.

Remove/Hide the single object LOD texture so it uses the vanilla version again when generating the LOD texture atlas.

To update only the LOD texture atlas, use expert mode as explained in DynDOLOD_TexGen.html "Update Texture Atlas"

Edited by sheson
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.