Jump to content
  • 0
Claiomh

FNIS for Mod Organizer 2

Question

Hi everybody, I'm new to this whole modding thing, but I have been having a great deal of trouble with trying to get FNIS loaded. I went through the most straightforward youtube video I could find, did everything it said, but when I tried to run FNIS to check the GenerateFNISforUser for the first time, when I click Run it never populates the window that I would exit from. When I check the text log at the bottom for when I attempt to run the exe it gives me this 

04:27:00.147 [D] C:\Users\Claiomh Cogadh\AppData\Local\ModOrganizer\SkyrimSE\profiles\Default\initweaks.ini saved
04:27:00.153 [D] C:\Users\Claiomh Cogadh\AppData\Local\ModOrganizer\SkyrimSE\profiles\Default\lockedorder.txt saved
04:27:00.155 [D] Load Mechanism: Mod Organizer
04:27:00.157 [D] USVFS DLL Name: usvfs_x64.dll
04:27:00.261 [D] enable local saves: 0
04:27:00.275 [D] Updating VFS mappings...
04:27:00.588 [D] VFS mappings updated <linked 20 dirs, 5 files>
04:27:00.597 [D] Spawning proxyed process < "launch \"C:\\Program Files (x86)\\Steam\\steamapps\\common\\Skyrim Special Edition\\data\\tools\\GenerateFNIS_for_Users\" \"C:\\Program Files (x86)\\Steam\\steamapps\\commo...
04:27:00.598 [D] Creating process hooked: < "\"C:\\Modding\\MO2\\ModOrganizer.exe\" launch \"C:\\Program Files (x86)\\Steam\\steamapps\\common\\Skyrim Special Edition\\data\\tools\\GenerateFNIS_for_Users\" \"C:\\Progr...
04:27:00.616 [D] Waiting for spawned process completion : ModOrganizer.exe (14044)
04:27:00.867 [D] Waiting for process completion not successfull : 258
04:27:01.079 [D] C:\Users\Claiomh Cogadh\AppData\Local\ModOrganizer\SkyrimSE\profiles\Default\lockedorder.txt saved
 [D] 

Honestly, I have no clue what I'm looking at, but there's probably something in all that that gives me a clue as to what I'm doing wrong. I'm just trying to figure this all out, and FNIS has been just a giant Charlie Foxtrot for me. I've checked the threads, but it's been like trying to find a needle in a haystack for me to find out exactly why it isn't working when I try and do this. And yes, I read the thread about the making a FNIS output file, that did zero for me.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I think the first clue here is that you have Skyrim Special Edition installed in C:\Program Files (x86) so you're likely running into UAC and permissions issues. You can use Steam to move the Skyrim SE to another folder (like C:\Games) that is not protected by the operating system. I can't tell where Mod Organizer is installed in that snippet, but ensure Mod Organizer is not installed in the Steam or Skyrim SE folder because the virtual file system will not work correctly. You can install Mod Organizer pretty much anywhere you want (say C:\Games or C:\Tools) provided it is outside any UAC controlled folder (like C:\Program Files and C:\Program Files (x86) and outside the Steam and game folders.

 

Finally, when you download Mod Organizer you should unblock the file you downloaded (File Explorer, right click the zip or exe file you file downloaded, Properties, click Unblick, click OK). if you don't do this, Windows 10 may block the virtual file system and make it look as if Mod Organizer isn't working correctly. Also note that some overly aggressive antivirus software may also block Mod Organizer's virtual file system so you might consider adding the Mod Organizer folder to the exceptions list.

Share this post


Link to post
Share on other sites
  • 0

I moved the Skyrim files outside of my program files folder manually, changed the path for MO to look for Skyrim, deleted everything to to with FNIS, redownloaded and reinstalled FNIS, works fine now. My anti-virus was already documenting and making exceptions for Steam Skyrim and MO automatically. Thank you very much Greg.

Share this post


Link to post
Share on other sites
  • 0

Ok, I was wrong. I'm able to see the update FNIS behaviors window when I run the executable, but when I try to load the game after having run the generator all the characters are in the animation glitch where they're just standing like mannequins. Not sure why it's doing that when I've done everything the way the youtube video says.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Mopotter
      1. I've been using MO 2 for years for 3 of my games, Skyrim, Skyrim SE and FA4.  No problems and yesterday  I know I did something wrong because the top line of items is missing and Skyrim SE is the only game I can access.  But I don't know what I did or how to fix it.  I've  uninstalled and reinstalled with no change.   Hoping someone has done this and can explain how to fix it.  

    • By Ayohaych
      Hey all.
      Sorry if this has been asked but I couldn't find anything.
      I got a Steam Deck recently and was in the process of setting Skyrim SE up with mods.
      Right now it actually works, however I can't seem to figure out how to launch Skyrim SE Launcher? I need to change settings so it runs better.
      When I open Skyrim from Steam, or use bottles to run Skyrim SE Launcher, it launches MO2. From there I have to select SKSE and hit run and it launches.
      If I click the drop down and select Skyrim Special Edition Launcher, it says an instance of mod organizer is already running.
      Any ideas on how I can get around this to launch the launcher so I can change my settings?
      It seems there is _SkrimLauncher.exe file that must of been automatically created by MO2, however when I run that with Bottles, and make changes, it doesn't seem to have the changes when I run SKSE.
      Thanks for any help!
    • By koopastroopas
      I have always used Wrye with MO but now on a fresh install of everything(Skyrim SE) when I try to rebuild the Bashed Patch I get an error saying "file not found, it may have been moved, edited or deleted. I have no idea what that means since it doesn't even tell me what file is supposedly missing. Any ideas as to whats going on here?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.