Jump to content
  • 0

MO2 can't launch skyrim le



Hello and thanks for all reading this.


I was starting to use mo instead of nmm a month ago, but a fatal error happen after I connected an external video adapter. My labtop uses dual GPU provided by intel and Nvidia, everything was fine before the external adapter connected, no Optimus fix need and perfectly run with enb, mods and skse.


Then dooms come with my new 1070 ti. The game instantly crash if I try to launch via mo2, sometimes prompt "exception breakpoint" something like that. But things are alright when I launch skyrim through skse without mo2, either with enb or not . I've done lots of things to fix this problem, including correcting the d3d line in skyrimpref.ini, removing enb, deleting ini in mo2 profile and in my documents, but they didn't work. Force mo2 and skse run in delicated gpu in Nvidia control panel worked once for me and never worked after. And vanilla skyrim and launcher get crashed too if I try them via mo2.


Very intended to get helped. Can't go back to nmm since I used mo2 lol.

Edited by m18a2
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

In theory the skyrim.ini and skyrimprefs.ini files should be set to use the appropriate video adapter I think these are as follows:




sD3DDDevice="AMD Radeon R9 200 Series"


and skyrim.ini




You may have already done this, but open the INI editor in Mod Organizer and verify these settings match the settings in the INI files in the My Games\Skyrim folder. Also note that if you are using "instances" with Mod Organizer 2, your INI files are in \users\\AppData\Local\ModOrganizer instead.


If this doesn't solve the problem, stop by the Mod Organizer discord channel to see if the devs can figure out what's going on. You'll want to post in #issue-reports.

Link to comment
Share on other sites

  • 0

Thanks for replying

After checking almost every setting files, i found out the renderinfo.txt was the problem. If I let it auto detect the intel gpu, then launch the game with Nvidia gpu, everything is fine, but to detect the Nvidia one.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.