Jump to content
  • 0
torminater

Black Circles, z-fighting and texture shimmering

Question

NEW UPDATE:

I have tried the Skyrim Special Edition, and there seems to be no more z-fighting for me. As if that is linked to the fixes towards the shadow processing or has something to do with the new 64bit engine, I cannot say for sure. If you have further insight, please share below.

 

OLD post:

I am still working on my fix, as it does not solve all of the z-fighting and there is a performance drop of about 0-8 FPS. Further testing is therefore welcomed!
For the original little fix head over here !


For the guide (WIP) against z-fighting head over here !


Hey folks,
at the moment I'm fiddeling around with nvidia inspector, skyrim ini and prefs to get rid of black circles on mid-distant terrain, reduce z-fighting as much as possible and eliminate texture shimmering if possible.
I don't remember if z-fighting has been such a big problem for me before the last drivers update, but now it really gets on my case. It's only visible on very distant mountain sides but in a large area. The good thing is, if it's cloudy I don't notice it as much. The bad thing is, if it's sunny all of the great graphics cannot overshine the flashing mountains in the Background.
Texture shimmering is annoying but it's on the very end of my 2dolist.
What annoys me know the most is this black circles glitch. I just can't find the setting that causes me all that trouble. :wallbash:
It is very prominent and extremely disturbing. Reading through this forum I stumbled upon a lot of threads that were highly interesting and revealed that there are a whole lot of bright minds around.
I guess if STEP tries to make Skyrim an unforgettable experience, then it should include some details about very common bugs and glitches as those three I'm referring to. If anyone of you guys knows any tricks considering them I would be too glad to try them out!
I have had problems with artifacts probably caused by too much graphic mods and ini tweaks (no ugrids changes whatsoever...)
My rig is the following:
Crucial m4 SSD 128GB, 2.5"
Samsung EcoGreen F4 1500GB
Intel Core i7-2600K, 4x 3.40GHz
Kingston ValueRAM DIMM Kit 8GB
2 x Gainward GeForce GTX 570 Phantom, 1.25GB GDDR5 SLI
ASRock P67 Extreme4
Corsair Professional Series Gold AX750 750W
All drivers are absolutely up2date. By all means I should be able to run Skyrim without problems. So far that doesn't work out...
EDIT: Those Black Circles seem only to pop up in the lower half of the screen o_O but somewhat diagonal... maybe cuz of the Sun angle?
I found out how to remove them:
fShadowBiasScale=0.1500 revert to fShadowBiasScale=0.2500 in SkyrimPrefs.ini
There are still black stripes on some rocks and mountainsides. they disappear from the center the closer you come...

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I have to admit, guys, I am tired...I have a huge problems with mountain texture flickering - especially in the Whiterun - it is just so overwhelming...so I have tried guide and I have set all values as in the guide (NearDistance 25 as well), but I cannot say it was any better in the Whiterun (leaving dragonsreach and stopping at the stairs looking on the beautiful scenery).

 

I have tried Exalerion's settings and it...kinda works...in the Whiterun it is little bit better, but still really bad (especially when I am using enhanced camera and I have head bob turned on).

When I am outside or just somewhere outside the city it is really good, yet not perfect, not with these extreme settings...

 

 

Skyrim.ini

[Display]

fNearDistance=25.0000

 

SkyrimPrefs.ini
[TerrainManager]
fTreeLoadDistance=150000.0000
fBlockMaximumDistance=1000000.0000
fBlockLevel1Distance=280000.0000
fBlockLevel0Distance=140000.0000
fSplitDistanceMult=10.0000
 
For me these settings solve the Z-Fighting issue pretty much, it's still not noiseless but none of Skyrim's distant terrain will ever be noiseless..
fNearDistance does most of the work though. When I lower it the Z-Fighting gets more noticeable again. I just cranked the TerrainManager settings up even more for better looking mountains.
But also the number and size of your texturemods causes more Z-Fighting. When playing Vanilla Skyrim, I don't see any Z-Fighting.

 

Thinking about it...maybe replacing distant LOD textures...and as far as the LOD hi-res textures go, I am using

https://www.nexusmods.com/skyrim/mods/58818/

and the highest resolution version.

Share this post


Link to post
Share on other sites
  • 0

Skyrim Enhanced Camera will override the fNearDistance setting.

 

Try these settings:

[TerrainManager]
fBlockLevel0Distance=50000
fBlockLevel1Distance=72500
fBlockMaximumDistance=94000
fSplitDistanceMult=1.5

Share this post


Link to post
Share on other sites
  • 0

I will try and report back..

 

In the meantime, how override ? I hava set it to 25 and I can definitely see the texture clipping as Gopher has shown in his video on the topic. I can see, I will look into the .ini file and find its near distance setting as well.

 

...

Update: I have tried it, I have deactivated the override in the EC ini file, I have set your settings and it is not gone, but better...I do not mind clipping, I have no reason to be sticked to the textures..

Edited by dropadred

Share this post


Link to post
Share on other sites
  • 0

I have to admit, guys, I am tired...I have a huge problems with mountain texture flickering - especially in the Whiterun - it is just so overwhelming...so I have tried guide and I have set all values as in the guide (NearDistance 25 as well), but I cannot say it was any better in the Whiterun (leaving dragonsreach and stopping at the stairs looking on the beautiful scenery).

 

I have tried Exalerion's settings and it...kinda works...in the Whiterun it is little bit better, but still really bad (especially when I am using enhanced camera and I have head bob turned on).

When I am outside or just somewhere outside the city it is really good, yet not perfect, not with these extreme settings...

 

Thinking about it...maybe replacing distant LOD textures...and as far as the LOD hi-res textures go, I am using

https://www.nexusmods.com/skyrim/mods/58818/

and the highest resolution version.

hows your fps with fTreeLoadDistance=150000.0000 ? ive  always read that fTreeLoadDistance=40k is better for killing the stutering, so ive never tried higher.

Share this post


Link to post
Share on other sites
  • 0

Hello everyone!

 

Some interesting testing and remembering a couple things might shed some more light on this mysterious Z-Fighting issue within Skyrim with the mountain flicker at distance and water.

 

So I had this issue for awhile, recently reverted back to using my ENB with some changes to the enblocal.ini where I changed the following settings to improve performance on my system because I was only getting around 30 FPS with my heavily moded Skyrim of 267 fully working no problems MODS and on Ultra settings.

 

The following changes to improve my FPS -

UseDefferedRendering=false

 

Changing the above I got much improved FPS but noticed still some flickering, so I went into my AMD driver settings and under Gaming I clicked on my previous added exe of TESV.exe ( if you do not have one add it ) and changed "Surface Format Optimization - OFF" and set Anti-Aliasing Method to Supersampling, also checked my vsync was enabled and made sure OpenGL Triple Buffering was off and Morphological Filtering OFF.  Not sure about Nvidia users (sorry AMD user here).

 

Started back up SKyrim and Viola no flickering! Now for the reverse test using enblocal.ini I set the setting back for
UseDefferedRendering=true ..............AS soon as I enabled that in enblocal.ini my game was back to flickering! So this means because my driver settings are set for use application settings the changes done to enable DefferedRendering must have turned something back on, whether it's an ENB AA option controled by the ENB or some setting within the defferedRendering it was the culprit in giving the flickering again for me at least, however;  the driver settings set as shown above and false for differedrendering I got no flicker.

 

Tested further and ENB off and driver settings set to Optimize surface format with AA or FXAA enabled resulted in the flickering again.

 

Hope my info helps on this situation.

Share this post


Link to post
Share on other sites
  • 0

NEW UPDATE:

I have tried the Skyrim Special Edition, and there seems to be no more z-fighting or shadow striping for me. As if that is linked to the fixes towards the shadow processing or has something to do with the new 64bit engine, I cannot say for sure. If you have further insight, please share below.

 

I've not tried any mods yet. I have heard that clutter seems to flicker a lot now, if the Unofficial patches are installed, e.g. in Dragonsreach.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.