Jump to content
  • 0
Sign in to follow this  
Spacebadger

Heavy stutter when tree transitions from lod to full model

Question

So I'm getting pretty heavy stutter as trees transition from lod to full model. I am usin enboost and crashfix's useosallocators, and I have figured out that it does come from the trees, but I can't figure out how to fix it

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I am not sure what loading of full models has to do with DynDOLOD. Why do you believe it is only trees, it loads 5 or more entire cells that moment, terrain and trees are one of the first thing.

Share this post


Link to post
Share on other sites
  • 0

Should I try making a lod with no trees and see if it still stutters? I had believed the stutter to be caused by the tree transition because it was the only thing I saw when it stuttered

Edited by Spacebadger

Share this post


Link to post
Share on other sites
  • 0

You can easily test if tree LOD is causing anything by changing tree LOD distance to zero either in the SkyrimPrefs.INI [TerrainManager] fTreeLoadDistance=0 or using the DynDOLOD MCM Settings page.

 

If on the other hand the loading of full objects causes hitches, try default BethINIs and adjusting ReservedMemorySizeMb while in-game in ENB overlay directly in ReservedMemorySizeMb. Start with values 0, 32, 64 and increment in small steps. If you use crash fixes UseOSAllocators use the Custom Memory and check non of it is not hitting 100% in console.

Share this post


Link to post
Share on other sites
  • 0

Thanks man, I'll try it out and get back to you

Only bad thing about your program is the run time, probably spent a good dya running it, everything else looks fantastic

Share this post


Link to post
Share on other sites
  • 0

Still stutters without trees, but does not stutter whine dyndolod not installed. Should I increase the useosallocators custom memory? Enb reserve is at 512mb

Share this post


Link to post
Share on other sites
  • 0

Adjust ReservedMemorySizeMb in the ENB overlay while running around in the game.

Turn off all LOD with console command tll, that allows better seeing the moment new cells are loaded. You can adjust values live using the mouse controlling the spinner, while using WASD to move.

 

Use BethINIs.

 

Set CustomMemoryBlockTotalSizeMb so that memory report in console shows none of the buffers at 100%, but just slightly below it.

Alternatively test performance by using default heap memory adjusted with memory blocks log (UseOsAllocators=0), then a third test with AlignHeapAllocate=1

 

Lower overall demand of generated LODs by using low, medium presets. See the manual Performance section for more.

Edited by sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Mare
      Every second or so in game I get a strange stutter/hitching that only seems to happen when im moving or looking around, I can hold 60fps solidly and my computer isn't under pressure from the game and everything runs perfectly besides this stutter.
      Very light modlist right now with only dyndolod, obsidian weathers + enb, aswell as cbbe and the usual smim and unofficial patch.
      Running on a rtx2070.
      If anyone knows a solution for this you would be a lifesaver.
      Video example:
       
    • By lv4321
      Whenever I see an npc move or run and look at their sides, it looks very choppy and for some npc's some of their movements are so choppy that every few steps they take, they instantly lag back and forth....So far I have been using the casm mod with MO so far and nothing else....
       
      Specs:
      i5 4460
      r7 250x
      12gb of ram
       
       
    • By kechlion
      When in the open world just running around, I get some serious stuttering issues that appear to happen when a new cell loads. My FPS drops from rock solid 60 to as low as 20 on a cell load. I have double checked and I believe all of my settings are as recommended in the STEP Core guide. The mods I have installed are STEP Core with recommended texture qualities and additionally Ordinator, Wearable Lanterns, Rich Merchants, Grimy Plugin, SkyTweak, Weightless Ingrediants, 3DNPC, and Smart cast. My system specs are as follows: 
       
      i7-5930k
      Win 10 pro
      16GB Ram
      nVidia Titan X
      Mods and Skyrim installed on two Samsung 850 Pros in a Raid 0.
       
      I am running between the exit of Helgen caves and the Mill that's to the... west of it? Just running along the road. This is basically a new game.
       
      I have changed enblocal to do windowed borderless (and not) and I have attempted to increase and decrease ReservedMemorySizeMb with no appreciable results. I'm attaching a screenshot of performance monitor with 512MB reserved memory.
       
      My enblocal.ini is also attached.
       
      Any help is greatly appreciated. My primary goal is to run skyrim at a rock solid 60 fps at all times. Huge performance swings really grate on me.
       
      Thanks!
       
       
       

      enblocal.ini
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.