Jump to content
  • 0
Sign in to follow this  
lordrahl

FNIS Mod Organizer 2 will not work together.

Question

I have used mod organizer for old skyrim and now cannot live with out it. However with SkyrimSE and Mod Organizer 2 when trying to use FNIS it just will not work. I have looked here for answers, on reddit, and any where else i could find for answers and have come up dry. I get the "outside the bounds of the array" error or "cannot find part of the path" error etc.

     I have many errors with loot as well but atleast I can get that to work. My skyrim se is installed on my H: drive not under the default drive and yes it is through steam. I have tried the solutions to some of the errors from here and from other forums as stated but nothing has worked. Please, any help with this would be greatly appreciated! :confused:

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

FNIS 7.0 works perfectly well with MO2.

 

The errors you are getting makes me believe you haven't got the FNIS mod active in the left pane. At any rate without logs from you we will not be able to diagnose anything.

Share this post


Link to post
Share on other sites
  • 0

I second Grant answer. FNIS work with no issues on Mon for me.

 

Sent from my Huawei Mate 9

Share this post


Link to post
Share on other sites
  • 0

FNIS 7.0 works perfectly well with MO2.

 

The errors you are getting makes me believe you haven't got the FNIS mod active in the left pane. At any rate without logs from you we will not be able to diagnose anything.

 

I second Grant answer. FNIS work with no issues on Mon for me.

 

Sent from my Huawei Mate 9

Thanks for responding. It is clicked in the left pane and I have successfully used FNIS with Mod Organizer for a very  long time. But it has not worked for me at all with Mod Organizer 2 (it is the the 7.0 beta SE version). I have spent weeks trying to get this to work with no luck. I cannot find an error log for FNIS, but will send what ever you need me to send.

Share this post


Link to post
Share on other sites
  • 0

Here is the log from FNIS

 

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.DirectoryNotFoundException: Could not find a part of the path 'D:\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users\temporary_logs'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileSystemEnumerableIterator`1.CommonInit()
   at System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)
   at System.IO.DirectoryInfo.InternalGetDirectories(String searchPattern, SearchOption searchOption)
   at System.IO.DirectoryInfo.GetDirectories()
   at GenerateFNISforUsers.FNIScommon1.FNIScommon.List_Files(String dir)
   at GenerateFNISforUsers.FNIScommon1.FNIScommon.Display_Dirs(Boolean atStart)
   at GenerateFNISforUsers.FNIScommon1.FNIScommon.FinishSub()
   at GenerateFNISforUsers.GenerateFNISUsers.Main()
   at GenerateFNISforUsers.GenerateFNISUsers.Button1_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
GenerateFNISforUsers
    Assembly Version: 7.0.0.0
    Win32 Version: 7.0.0.0
    CodeBase: file:///D:/Steam/steamapps/common/Skyrim%20Special%20Edition/data/tools/GenerateFNIS_for_Users/GenerateFNISforUsers.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


 

Share this post


Link to post
Share on other sites
  • 0

Have you tried to manually create the folder D:\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users\temporary_logs\ and then run FINIS? 

Share this post


Link to post
Share on other sites
  • 0

Have you tried to manually create the folder D:\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users\temporary_logs\ and then run FINIS? 

Yes, still getting error 9  outside the bounds of the array. I am at my wits end.

Share this post


Link to post
Share on other sites
  • 0

Have you checked that you meet all the requirements for MO? .NET especially can be very troublesome at times.

Thank you for your response, I do meet the requirements.

Share this post


Link to post
Share on other sites
  • 0

If that is the case then perhaps Windows is messing with your install due to UAC issues. The error message shows it isn't applying the correct system files to this process so you may need to look at fixing that.

Try running everything as Admin, though I advise against this at it may cause issues later on. Or perhaps your H: drive is a NAS drive, or otherwise attached via software, and this is messing with MO's 'hooking' system.

Basically you will need to look at all the areas where your system deviates from the norm and investigate if that is causing an issue.

 

MO/MO2 is very finicky when it comes to software running in the background that may also try to make calls on the games, or game tools, running processes. Game overlays, AV software, firewalls, NAS drivers etc. all can be causes of issue.

Share this post


Link to post
Share on other sites
  • 0

Shouldn't the path be ?:\Mod Organizer\mods\FNIS Behavior SE V7 0 Beta\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe ?

Just wondering.  I have the latest build, and have no problems with FNIS.

Share this post


Link to post
Share on other sites
  • 0

If that is the case then perhaps Windows is messing with your install due to UAC issues. The error message shows it isn't applying the correct system files to this process so you may need to look at fixing that.

Try running everything as Admin, though I advise against this at it may cause issues later on. Or perhaps your H: drive is a NAS drive, or otherwise attached via software, and this is messing with MO's 'hooking' system.

Basically you will need to look at all the areas where your system deviates from the norm and investigate if that is causing an issue.

 

MO/MO2 is very finicky when it comes to software running in the background that may also try to make calls on the games, or game tools, running processes. Game overlays, AV software, firewalls, NAS drivers etc. all can be causes of issue.

 

Shouldn't the path be ?:\Mod Organizer\mods\FNIS Behavior SE V7 0 Beta\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe ?

Just wondering.  I have the latest build, and have no problems with FNIS.

Thanks , I believe you are correct that it is a system problem, and will definitely try to fix that issue. The path normally, and is now set the way you say but I was at a loss so I installed it into the data directory and tried running it through MO2 that way but that didn't work either. So now I have it installed back in MO2. I have exhausted my efforts and agree something is wrong with my system and not with MO2 or FNIS Thanks for all the help!

Edited by lordrahl

Share this post


Link to post
Share on other sites
  • 0

Without creating a new topic, I have problem with FNIS and MO2 as well.

My problem is different, the window doesn't even show up after I run FNIS from MO.

 

This is what I get when I "Run" FNIS from MO. The MO log file "usvfs-2017-04-30_21-18-37.log":

23:19:06.647 [E] failed to hook GetFileVersionInfoW: No Error
23:19:06.647 [E] failed to hook GetFileVersionInfoExW: No Error
23:19:06.647 [E] failed to hook GetFileVersionInfoSizeW: No Error
23:19:06.647 [E] failed to hook GetFileVersionInfoSizeExW: No Error
23:19:06.670 [I] (proxy) instance: mod_organizer_instance
23:19:06.670 [I] (proxy) exe: 
23:19:06.670 [I] (proxy) pid: 0
23:19:06.670 [W] (proxy) not all required settings set
23:19:06.672 <3224:920> [E] failed to inject into spawned process

I've double checked the mod is checked on the left pane and that the paths are correct.

MO is installed in the same drive (C:) as the mods and as Skyrim are.

 

What is strange is that if I run the FNIS executable, alone, it does work and the window open as it should.

Edited by sonnhy

Share this post


Link to post
Share on other sites
  • 0

Check to see that no AV software is stopping the execution of the FNIS exe from MO. Check the sub-forums for the thread about what software can interfere with it.

Share this post


Link to post
Share on other sites
  • 0

i have the same issue , i have manual installed FNIS in MO  ,the filles  are in steam/steamapp/etc etc .....when i try to launch it ,it dt work  ,just gimme a black window who will be there  for 1sc before she shutherlf down  ;but when i launch it manually (FNIS) it doeas work normaly,i have no AV software or else ,so i dont really know what i should do. i really whant FNIS on my skyrim ,i have played skyrim and skyrim special edition ,i've modded my skyrim special edtion   but it wasnt the official thing,now i have buy my self skrim SE and wanted to get a clean stable mod thing  and with a lot of mods but here i am waithing to get it right !

i hope people can help me and if not  snif snif,thanks for reading this,hope you all the best (sorry for nazy grammar ,im not english)

Share this post


Link to post
Share on other sites
  • 0

Without logs it is very hard to say what you are doing wrong. FNIS 7.0 works with MO2 perfectly well.

Install it, activate it in the left pane, ensure the executable is properly set and then run it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.