Jump to content
  • 0
Rescorla

4GB patch apparently didn't work

Question

I followed the guide and ran the 4GB patcher. I am on my first playthrough of FNV and typically only play for about 60-90 minutes per session. Started getting Out of Memory messages when I play for over 90 minutes. Checked task manager and the FNV executable is still running using 2GBs of memory. Pretty clear indication that the 4GB patcher didn't work.

 

This far into the game (I'm level 22) can I just download the 4GB executable file and start using that or should I rerun the 4GB patcher and try to fix it? Is there some way for me to verify the 4 GB patcher actually worked?

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Yes, set it to 0. Turn it off completely. It's does NOT work properly. It will cause more problems than it solves.

Share this post


Link to post
Share on other sites
  • 0

The easiest indicator that the 4Gb patch has worked is to call up the console and type:

GetNVSEVersion

Since the new patched game executable will now call NVSE automatically, this will show you that NVSE is running even though you start the game now by running the game, not the launcher or NVSE.

Share this post


Link to post
Share on other sites
  • 0

Just to add: NVSE Memory tweaks got ported over from Skyrim.  \Fallout\Data\NVSE\NVSE.ini and add the Memory tweaks.  There is an Alternative to the old 4GB Patch over at the Nexus.  Recently, like you, I had the same problem.  Purple Textures...running out of memory.  Did both of these and im right as Rain :)  Never had a problem w/ the old 4GB patch.  But if I were you I would def. try the NVSE tweak :) Check the Fear & Loathing Guide under NVSE.

Share this post


Link to post
Share on other sites
  • 0

The easiest indicator that the 4Gb patch has worked is to call up the console and type:

 

GetNVSEVersion
Since the new patched game executable will now call NVSE automatically, this will show you that NVSE is running even though you start the game now by running the game, not the launcher or NVSE.

I get a value of 5 when I run that command.

Share this post


Link to post
Share on other sites
  • 0

If you run the game from the default exe and you can still see the NVSE version this shows you it has been patched. Ordinarily you would need to run the game from the NVSE loader, this new patcher removes that necessity.

Share this post


Link to post
Share on other sites
  • 0

If you run the game from the default exe and you can still see the NVSE version this shows you it has been patched. Ordinarily you would need to run the game from the NVSE loader, this new patcher removes that necessity.

Something screwy is going on then. I reran the 4GB patcher again making sure I ran it as an administrator. Got a message the game had already been patched. Kept on getting "Out of Memory" errors. I downloaded the 4GB .exe and launched the game with it. Still running out of memory around 2GB.

Share this post


Link to post
Share on other sites
  • 0

What are you using to measure memory? Task Manager doesn't really show more than 2GB even if you are at the limit. 

Share this post


Link to post
Share on other sites
  • 0

I'm just using Task Manager.

 

Here is latest example of the problem. I'm on the quest to unearth the Legion spy at Camp McCarron. On fresh computer bootup and launch of the game I exit McCarron airport, go to the control tower, and then go back inside McCarron airport on my way to the monorail. Upon trying to go back inside the airport my game locked up due to being out of memory. I ran out of memory in less than 10 minutes of playing the game.

Share this post


Link to post
Share on other sites
  • 0

Do you have Heap Replacement turned on in the New Vegas Stutter Remover .ini file? If so, this will surely cause crashes and out of memory issues. It's broken. 

Share this post


Link to post
Share on other sites
  • 0

Do you have Heap Replacement turned on in the New Vegas Stutter Remover .ini file? If so, this will surely cause crashes and out of memory issues. It's broken. 

This is what the guide says:

 

bReplaceHeap = 1 <-- Needed for heap replacement, only for advanced users, detailed info in the readme. Modern systems will want to make use of this so it is recommended to enable this.

 

Are you saying I should set this to 0?

Share this post


Link to post
Share on other sites
  • 0

What have you set iHeapSize to? Default is only 250, trying a different number may help.

Share this post


Link to post
Share on other sites
  • 0

What have you set iHeapSize to? Default is only 250, trying a different number may help.

I have it set to 450 like the guide says.

Share this post


Link to post
Share on other sites
  • 0

Yes, set it to 0. Turn it off completely. It's does NOT work properly. It will cause more problems than it solves.

Changed it to 0 last night and stopped getting "Out of Memory" errors even after playing for over an hour. Hopefully that INI setting was the culprit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.