Jump to content
Sign in to follow this  
TakodaWahya

What do we do about LOOT and the new Global Priority numbering?

Recommended Posts

Hello there, hope you all are doing great.

 

Now on the issue itself:

 

The last version of Loot is 0.10.1 (build d8f8dc4)

 

Included in this version, comes a change in the range of numbers can be used under the Global Priority metadata value.

 

Before, the range was involving large numbers, as you can see in the following link:

 

https://loot.github.io/docs/contributing/Global-Priorities.html

 

... and those are the values used for the guides in the STEPs forum:

 

E.g. Neovalen instructs this in his guide (https://wiki.step-project.com/User:Neovalen/Skyrim_Revisited_-_Legendary_Edition):

 

"LOOT Metadata Update Required: (Updating Guide)

ELE_Legendary_Fs_Lite.esp - Enable Global Priority and set it to 990100"

 

Then Darth mathias instructs this in his (https://wiki.step-project.com/index.php?title=User:Darth_mathias/SRLE_Extended_Legacy_of_The_Dragonborn&oldid=81393):

 

"Loot Metadata Update Required:

Scarcity - Less loot mod.esp Set global priority 990900
Scarcity - 8x Loot Rarity.esp Set global priority 990901
Scarcity - 6x Merchant Item Rarity.esp Set global priority 990902"

 

... and also:

 

"Set global priority for RealisticWaterTwo.esp to 990200

Set global priority for ELE_Legendary_Fs_Lite.esp to 990400"

 

Now, with the last version, the value can be anything in the range -127 to 127 inclusive, as is explained in this link:

 

https://loot.readthedocs.io/en/latest/metadata/data_structures/plugin.html

 

Effectively, trying to rise the value over 127 or under -127 doesn't allow saving the changes in Loot.

 

Now, how we sort this from now on?, is this a bug or a intended modification?, what strange and weird sorcery can we expect?, I doubt is completely harmless, so my point is to receive information useful for any modder out there.

 

The stage is all yours...

 

Note: thanks beyond limits for the authors of this tool, btw, Sharlikran and wrinklyninja and anyone else involved!

Edited by Electronauta

Share this post


Link to post

i haven't looked at the new loot Global Priority metadata stuff yet but basically:

 

ELE_Legendary_Fs_Lite.esp - needs to load just before any CR mine or Neo's

 

 

Scarcity - Less loot mod.esp - Needs to load just after CR but before Bash Patch.
Scarcity - 8x Loot Rarity.esp - needs to load direct after Scarcity - Less loot mod.esp  but before Bash Patch.

Scarcity - 6x Merchant Item Rarity.esp  - needs to load direct after Scarcity - 8x Loot Rarity.esp but before Bash Patch.

 

RealisticWaterTwo.esp - not sure as that came from Dreadflopp.

  • Upvote 1

Share this post


Link to post

Thanks for the input, Darth_mathias, I will experiment a little and then test in-game to see how works, with the new values, if anything comes up, will drop a comment here. Have a nice day. :)

Share this post


Link to post

I ran into this as well, and found a download for LOOT v0.9.2 here, which allows you to add the high priority values that are currently in the STEP guide. Not sure if using an old version will cause any problems, but I'm in the middle of my very first build and thought it'd be worth a shot...

Share this post


Link to post

This is what I use and get load order as Darth's modwatch

 

RealisticWaterTwo.esp - Set global priority to 75

ELE_Legendary_Fs_Lite.esp - Set global priority to 76

Scarcity - Less loot mod.esp - Set global priority to 77

Scarcity - 8x Loot Rarity.esp - Set global priority to 78
Scarcity - 6x Merchant Item Rarity.esp  - Set global priority to 79

Share this post


Link to post

That is priceless darkside, and right on time: I just finished setting up my first LO following Darth's guide, so now Im patching fnis, wrye and so on, will replicate your values and see if works for me too, thanks! :)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Similar Content

    • By anomalous
      Recently I encountered an issue with missing main menu data on start up. After a laborious process of elimination, the problem was, amusingly, my conflict resolution patch. The symptoms were reproducible and unique to the patch.  The patch was based on the SRLE Template, modified over the last few days to resolve lingering issues with my particular build. TES5Edit offered no warnings or error messages, and there was nothing readily apparent to indicate an issue. I made some successful test runs throughout the editing process, but somewhere it simply went awry. Obliviously the mistake was mine, but unlike my previous mistakes, I could not ascertain what I had done wrong. So I have created a new modified SRLE Conflict Resolution Template that currently works without issue. However, I need to make additional edits to get all of my added mods to work right. Before I start this process again, I respectfully request some guidance. Is it possible to make too many edits? For a Patch to have too many masters? I generally avoid touching anything in the records that I don't understand in terms of function, but I was wondering if perhaps there are somethings that simply should not be touched. I will be starting the process again tomorrow, and I plan to take a more systematic approach with more integrated test runs. However, in the interim, if there is any helpful advice available, it would be greatly appreciated.   
    • By TDarkShadow
      Hello all.After going thoroughly with the guide, I have some kind of problem with the ENB files. Whenever I start up my Skyrim, I get a limegreen screen.I hear the game in the background playing and can hear the menu sounds.If I disable ENB through the ENB Manager, it's all fine.I tried googling but found no answer. I have an ATI AMD Radeon HD8970M graphic card with 2gb.
       
      Thanks if anyone can help me with this particular problem.
    • By GrantSP
      As I'm going through the Clear & Present Danger guide I noticed something that I'm sure would've been caught before if it was wide-spread, so I can only conclude it is peculiar to me.
       
      I've just cleaned all the esms for Fallout 3 and I was just going to check the process got everything by running LOOT.
       
      As you are aware MO has a stripped down version of 0.5 and the latest stable version was 0.6. I also have the beta version, 0.7.
       
      I usually just go with 0.6 and have it set on my MO toolbar. So I clicked it, ran it and looked at the report. Imagine my surprise when the DLC were all tagged as dirty and in need of cleaning. Maybe I had them in the wrong place, perhaps for some reason they didn't update the files in the Data folder and were hiding in the 'overwrite' folder? Maybe?
      On a whim I ran the MO version, 0.5. That report showed all the esms as clean. WTH. Okay lets try 0.7. Same thing, all the DLC files are correctly shown as cleaned and need no attention.
       
      To test this further I ran the 0.6 version from outside MO and again it showed them as dirty. I then ran the 0.7 version and it too correctly showed them clean.
       
      What's the story here? Has no one ever seen this happen with LOOT v0.6? I'm finding hard to believe this is just me.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.