Jump to content

Best way to reduce video load


Recommended Posts

I just got a bunch of new hardware.  That includes three 2560x1440 monitors.  I've been trying to play Skyrim on it, but it crashes after just a few minutes.  Running MSI Afterburner shows my video memory 6Gb per video card is just about maxed (5830 Mb used on both cards) the entire time I'm in game.  I can downsample to 1080, but I hear that reduces clarity.

 

So I'm trying to figure out the best way to reduce the video load while running SRLE.  Should I start with reducing the details via the Steam menu, or should I start with lower res textures and optimizing textures for lower memory?

Edited by Yippee38
Link to comment

The first thing I would do is reduce the things that I can live without that take up the most amount of VRAM. Usually it's: resolution, hardware AA (MSAA or DS), and texture resolution. Also, are you running on one monitor that is 2560x1440 or are you running it on all three monitors at 1440p? Because if you are running it on three 2560x1440 monitors at once then that will of course absolutely eat up your VRAM. Personally I would lower texture resolution before my game resolution. And yes, running at a resolution other than your monitor's native resolution will make the image look less crisp and more blurred. 

 

Edit: changed some confusing text.

Edited by Audley
Link to comment

The first thing I would do is reduce the things that I can live without that take up the most amount of VRAM. Usually it's: resolution, hardware AA (MSAA or DS), and texture resolution. Also, are you running on one monitor that is 2560x1440 or are you running it on all three monitors at 1440p? Because if you are running it on three 2560x1440 monitors at once then that will of course absolutely eat up your VRAM. Personally I would lower texture resolution before my game resolution. And yes, running at a resolution other than your monitor's native resolution will make the image look less crisp and more blurred. 

 

Edit: changed some confusing text.

All three monitors (7860x1440).

Link to comment

My first thought is that the crashing is not being caused by VRAM, but you can establish whether or not it is by simply disabling the texture packs Skyrim Realistic Overhaul, Vivid Landscapes, Flora Overhaul, DynDoLOD and any others you may have put in yourself. If it doesn't crash after playing for awhile (I'd visit each of the major cities and walk around in a dense forest a bit to test), then it actually probably is VRAM; but if it still crashes, then it's something else.

Link to comment

BTW, I realized this morning (despite getting very little sleep) that I wasn't very clear in my original post.  When I say I want to reduce "video load", I really mean, I want to reduce video ram usage.

 

Hishutup, I'm running two GTX 980 Ti's with 6Gb VRAM.

 

I just did a test, and in single monitor mode (2560x1440), I'm using 3363Gb of VRAM, max.  So, on three monitors, I'm using somewhere in the neighborhood of 10Gb VRAM.  So I would have to reduce memory usage by about 64%.  I'm wondering if installing all high res mods at 1k instead of 2k, and optimizing textures and DynDOLOD for lower texture sizes would even be enough.

 

I am getting acceptable framerates, especially with G-sync.  35fps looks as smooth as 60.

 

Using Flawless Widescreen to run Skyrim is really the only option for triple monitor.  It fixes so much.  However, it does break Face to Face Conversations.  I really enjoy that mod, but I'm willing to live without it.  I just have to decide if it would be worth it to try to get it stable on 3 screens.  (It is friggin' gorgeous on three screen though.)

Link to comment

If you are certain that your crash is actually caused by VRAM use, here's a few things you can check:

 

- Be sure you aren't using uncompressed textures (including normals), if you are; use the GIMP DDS plugin to get them compressed. You can also use DDSOpt too, but I prefer more control.

- Don't use any 4k textures

- Try running with DynDoLOD completely disabled vs low quality and compare VRAM use.

- Disable or tone down Flora Overhaul

 

 

As a note, even when I go nuts with stuff and end up using 100% of my VRAM, it never crashes on me; it just gets choppy because it keeps loading and unloading textures.

Edited by Electrocutor
Link to comment

If you are certain that your crash is actually caused by VRAM use, here's a few things you can check:

Any suggestions on how I can confirm or disprove my suspicions?  It seems about 95% stable on single screen.  I supposed it could  be related to Flawless Widescreen.  Maybe I'll test it without using that.

- Try running with DynDoLOD completely disabled vs low quality and compare VRAM use.

 

 

That's a great idea on a good way to test without having to install lower-res versions of 100 mods!  Thanks.

Link to comment

If you are certain that your crash is actually caused by VRAM use, here's a few things you can check:

 

- Be sure you aren't using uncompressed textures (including normals), if you are; use the GIMP DDS plugin to get them compressed. You can also use DDSOpt too, but I prefer more control.

- Don't use any 4k textures

- Try running with DynDoLOD completely disabled vs low quality and compare VRAM use.

- Disable or tone down Flora Overhaul

 

 

As a note, even when I go nuts with stuff and end up using 100% of my VRAM, it never crashes on me; it just gets choppy because it keeps loading and unloading textures.

Texture Optimization is a must I believe, if you haven't done it you should.  Another option that is easy to use is Texture Optimizer.

Link to comment

I haven't tried Texture Optimization yet.  Not enough time right now.  I do have a question though.  If I use that, do I have to re-run the DynDOLOD TexGen and WorldGen scripts?

 

I ran Memory Blocks Log and that's not the problem.

 

I ran Skyrim Performance Monitor, and this was the result:

SkyrimPerfMon.png

 

I actually ran it twice.  The first time was with the config exactly as I had been running it before.  The second time was with DynDOLOD completely disabled.  You can see (by looking at the orange GPU% line) exactly where it crashed.  It's got my video memory pegged the entire time I play.  I will try Texture Optimization hopefully tomorrow.

Link to comment

Bah!  You guys were, of course, correct.  It's got nothing to do with me running triple monitors.

 

I just disabled three screens, run through what I've been doing that's crashed, and it still crashed on 2560x1440.  On to normal troubleshooting.  <sigh>

Link to comment
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.