Jump to content
  • 0

Blocky shadows even with .INI settings at 4096


C4RN1F3XX
 Share

Question

Hey guys, 

 
I've found this guide yesterday after deciding to play Skyrim again, so i started following the instructions to install STEP:core.
At last I installed the mods in the 'Conflicting Graphics' section.

Then, while quickly testing if everything is running well, I noticed that my shadows are very blocky ingame.

I followed each step in the guide so far, i even double checked the steps, so I can't really tell what makes my shadows blocky.
Of course I did the INI tweaks as the guide says first and I did them inside of MO, but there has to be a setting which still makes the shadows blocky, even on a 4096 shadow map resolution.
Also, following these instructions didn't have any effect on my ingame shadows AT ALL. Strange enough. :/
I'll post my .INI settings in spoilers down below. Can anyone help me with this, since I'm not that experienced in modding and tweaking Bethesda games? If you have any questions which I need to answer in terms of finding a solution, feel free to ask.
 
Greetz,
 
CarnifeX

 

 

[spoiler=SkyrimPrefs.INI][General]

fBrightLightColorB=1.0000

fBrightLightColorG=1.0000

fBrightLightColorR=1.0000

iStoryManagerLoggingEvent=-1

bEnableStoryManagerLogging=0

[imagespace]

bDoDepthOfField=1

iRadialBlurLevel=2

[Display]

iBlurDeferredShadowMask=4

fInteriorShadowDistance=4000.0000

fShadowDistance=8000.0000

iShadowMapResolutionSecondary=4096

iShadowMapResolutionPrimary=4096

iShadowSplitCount=2

iMaxAnisotropy=0

fLeafAnimDampenDistEnd=4600.0000

fLeafAnimDampenDistStart=3600.0000

fTreesMidLODSwitchDist=8192.0000

fGamma=1.0000

fDecalLOD2=1500.0000

fDecalLOD1=1000.0000

fSpecularLODStartFade=800.0000

fShadowLODStartFade=200.0000

fLightLODStartFade=1800.0000

iTexMipMapMinimum=0

iTexMipMapSkip=0

iWaterMultiSamples=0

iMultiSample=0

iShadowMode=4

bTreesReceiveShadows=1

bDrawLandShadows=1

bFull Screen=0

iSize H=1080

iSize W=1920

fMeshLODFadePercentDefault=1.2000

fMeshLODFadeBoundDefault=256.0000

fMeshLODLevel1FadeTreeDistance=6144.0000

fMeshLODLevel2FadeTreeDistance=4096.0000

fMeshLODLevel2FadeDist=10000000.0000

fMeshLODLevel1FadeDist=10000000.0000

iScreenShotIndex=2

bShadowMaskZPrepass=0

bMainZPrepass=0

iMaxDecalsPerFrame=250

iMaxSkinDecalsPerFrame=100

bFloatPointRenderTarget=1

sD3DDevice="AMD Radeon R9 200 Series"

bFXAAEnabled=0

iShadowMapResolution=4096

fShadowBiasScale=1

iShadowMaskQuarter=4

iShadowFilter=3

iAdapter=0

iPresentInterval=1

bDeferredShadows=1

bShadowsOnGrass=1

bShadowMaskZPrepass=0

bTransparencyMultisampling=0

bDrawShadows=1

[Grass]

b30GrassVS=1

fGrassStartFadeDistance=7000.0000

fGrassMaxStartFadeDistance=7000.0000

fGrassMinStartFadeDistance=0.0000

[MAIN]

bGamepadEnable=1

bCrosshairEnabled=1

fHUDOpacity=1.0000

bSaveOnPause=1

bSaveOnTravel=1

bSaveOnWait=1

bSaveOnRest=1

fSkyCellRefFadeDistance=150000.0000

[GamePlay]

bShowFloatingQuestMarkers=1

bShowQuestMarkers=1

iDifficulty=2

[interface]

bDialogueSubtitles=0

bGeneralSubtitles=0

fMouseCursorSpeed=1.0000

bShowCompass=1

[Controls]

fGamepadHeadingSensitivity=1.0000

fMouseHeadingSensitivity=0.0180

bAlwaysRunByDefault=1

bInvertYValues=0

bGamePadRumble=1

bMouseAcceleration=1

bUseKinect=0

[Particles]

iMaxDesired=750

[saveGame]

fAutosaveEveryXMins=15.0000

[AudioMenu]

fAudioMasterVolume=1.0000

fVal7=1.0000

uID7=0

fVal6=1.0000

uID6=0

fVal5=1.0000

uID5=0

fVal4=1.0000

uID4=0

fVal3=1.0000

uID3=94881

fVal2=0.4000

uID2=466532

fVal1=1.0000

uID1=554685

fVal0=0.8000

uID0=1007612

[Clouds]

fCloudLevel2Distance=262144.0000

fCloudLevel1Distance=32768.0000

fCloudLevel0Distance=16384.0000

fCloudNearFadeDistance=9000.0000

[TerrainManager]

fTreeLoadDistance=75000.0000

fBlockMaximumDistance=250000.0000

fBlockLevel1Distance=70000.0000

fBlockLevel0Distance=35000.0000

fSplitDistanceMult=1.5000

bShowLODInEditor=0

[NavMesh]

fObstacleAlpha=0.5000

fCoverSideHighAlpha=0.8000

fCoverSideLowAlpha=0.6500

fEdgeFullAlpha=1.0000

fEdgeHighAlpha=0.7500

fEdgeLowAlpha=0.5000

fTriangleFullAlpha=0.7000

fTriangleHighAlpha=0.3500

fTriangleLowAlpha=0.2000

fLedgeBoxHalfHeight=25.0000

fEdgeDistFromVert=10.0000

fEdgeThickness=10.0000

fPointSize=2.5000

[Trees]

bRenderSkinnedTrees=1

uiMaxSkinnedTreesToRender=200

[Decals]

uMaxDecals=1000

bDecals=1

bSkinnedDecals=1

uMaxSkinDecals=100

uMaxSkinDecalsPerActor=60

[LOD]

fLODFadeOutMultObjects=8.0000

fLODFadeOutMultItems=8.2000

fLODFadeOutMultActors=8.0000

fLODFadeOutMultSkyCell=1.0000

[Launcher]

bEnableFileSelection=1

bShowAllResolutions=0

uLastAspectRatio=3

[blurShaderHDR]

bDoHighDynamicRange=1

[blurShader]

bUseBlurShader=0

[Water]

iWaterReflectHeight=1024

iWaterReflectWidth=1024

bUseWaterDisplacements=1

bUseWaterRefractions=1

bUseWaterReflections=1

bUseWaterDepth=1

 

 

 

 

 

[spoiler=Skyrim.INI][General]
sLanguage=GERMAN

uExterior Cell Buffer=36
sIntroSequence=
fFlickeringLightDistance=8192

[Display]
fShadowLODMaxStartFade=1000.0
fSpecularLODMaxStartFade=2000.0
fLightLODMaxStartFade=3500.0
iShadowMapResolutionPrimary=4096
bAllowScreenshot=0
fSunShadowUpdateTime=0.25
fSunUpdateThreshold=1.5
iPresentInterval=1

[Audio]
fMusicDuckingSeconds=6.0
fMusicUnDuckingSeconds=8.0
fMenuModeFadeOutTime=3.0
fMenuModeFadeInTime=1.0

[Grass]
bAllowCreateGrass=1
bAllowLoadGrass=0
fGrassFadeRange=10000
iMaxGrassTypesPerTexure=7
iMinGrassSize=40

[Water]
bReflectLODLand=1
bReflectLODObjects=1
bReflectLODTrees=1

[GeneralWarnings]
SGeneralMasterMismatchWarning=One or more plugins could not find the correct versions of the master files they depend on. Errors may occur during load or game play. Check the "Warnings.txt" file for more information.

[Archive]
sResourceArchiveList=Skyrim - Misc.bsa, Skyrim - Shaders.bsa, Skyrim - Textures.bsa, Skyrim - Interface.bsa, Skyrim - Animations.bsa, Skyrim - Meshes.bsa, Skyrim - Sounds.bsa
sResourceArchiveList2=Skyrim - Voices.bsa, Skyrim - VoicesExtra.bsa
bInvalidateOlderFiles=0
SInvalidationFile=ArchiveInvalidation.txt

[Camera]
fMouseWheelZoomSpeed=10

[Combat]
fMagnetismStrafeHeadingMult=0.0
fMagnetismLookingMult=0.0
f1PArrowTiltUpAngle=0.7
f3PArrowTiltUpAngle=0.7
f1PBoltTiltUpAngle=0.7

[interface]
bShowTutorials=0

[MapMenu]
fMapWorldYawRange=400
fMapWorldMinPitch=0
fMapWorldMaxPitch=90

[Papyrus]
fPostLoadUpdateTimeMS=500.0
bEnableLogging=0
bEnableTrace=0
bLoadDebugInformation=0
[Water]
bReflectLODObjects=1
bReflectLODLand=1
bReflectSky=1
bReflectLODTrees=1

 

Edited by C4RN1F3XX
Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

The larger the Shadow distance and game FOV, the more blocky the shadows will be. I run with 4096 shadow resolution, ShadowBlur at 3, FOV at 65 and a shadow distance of 8000. Looks ok, but it will never look great/good with Bethesda's Gamebryo engine.

Going above FOV at 65 with 1080p resolution will make your shadows blocky in certain viewing angles but a FOV at 80 or above will make them blocky no matter viewing angle.

 

These shadow questions have been aswered before, many times over both here on the STEP forum and around the net.

Link to comment
Share on other sites

  • 0

Sadly not..

I forgot to say that this screenshot was taken with this value being 10. :/

 

I tried out this tweak right here:

 

https://www.overclock.net/t/1171258/skyrim-ini-tweak-for-amazing-looking-shadows

 

There you can see what the result should look like, but mine still looks like that screenshot i posted :( I am doing something wrong but can't find the mistake

 

My prefs.INI as it is now, no changes afterwards, i highlighted every setting which is changed through the tweak following the link above. I didn't change shadow render distances though, but i don't think that this is the reason for my shadows being pixelated:

 

[spoiler=skyrimPrefs.ini][General]
fBrightLightColorB=1.0000
fBrightLightColorG=1.0000
fBrightLightColorR=1.0000
iStoryManagerLoggingEvent=-1
bEnableStoryManagerLogging=0
[imagespace]
bDoDepthOfField=1
iRadialBlurLevel=2
[Display]
iBlurDeferredShadowMask=3
fInteriorShadowDistance=4000.0000
fShadowDistance=8000.0000
iShadowMapResolutionSecondary=4096
iShadowMapResolutionPrimary=4096
iShadowSplitCount=4
iMaxAnisotropy=0
fLeafAnimDampenDistEnd=4600.0000
fLeafAnimDampenDistStart=3600.0000
fTreesMidLODSwitchDist=8192.0000
fGamma=1.0000
fDecalLOD2=1500.0000
fDecalLOD1=1000.0000
fSpecularLODStartFade=800.0000
fShadowLODStartFade=500.0000
fLightLODStartFade=1800.0000
iTexMipMapMinimum=0
iTexMipMapSkip=0
iWaterMultiSamples=0
iMultiSample=0
iShadowMode=4
bTreesReceiveShadows=1
bDrawLandShadows=1
bFull Screen=0
iSize H=1080
iSize W=1920
fMeshLODFadePercentDefault=1.2000
fMeshLODFadeBoundDefault=256.0000
fMeshLODLevel1FadeTreeDistance=6144.0000
fMeshLODLevel2FadeTreeDistance=4096.0000
fMeshLODLevel2FadeDist=10000000.0000
fMeshLODLevel1FadeDist=10000000.0000
iScreenShotIndex=2
bShadowMaskZPrepass=0
bMainZPrepass=0
iMaxDecalsPerFrame=250
iMaxSkinDecalsPerFrame=100
bFloatPointRenderTarget=1
sD3DDevice="AMD Radeon R9 200 Series"
bFXAAEnabled=0
iShadowMapResolution=4096
fShadowBiasScale=0.1500
iShadowMaskQuarter=4
iShadowFilter=4
iAdapter=0
iPresentInterval=1
bDeferredShadows=1
bShadowsOnGrass=1
bShadowMaskZPrepass=0
bTransparencyMultisampling=0
bDrawShadows=1
[Grass]
b30GrassVS=1
fGrassStartFadeDistance=7000.0000
fGrassMaxStartFadeDistance=7000.0000
fGrassMinStartFadeDistance=0.0000
[MAIN]
bGamepadEnable=1
bCrosshairEnabled=1
fHUDOpacity=1.0000
bSaveOnPause=1
bSaveOnTravel=1
bSaveOnWait=1
bSaveOnRest=1
fSkyCellRefFadeDistance=150000.0000
[GamePlay]
bShowFloatingQuestMarkers=1
bShowQuestMarkers=1
iDifficulty=2
[interface]
bDialogueSubtitles=0
bGeneralSubtitles=0
fMouseCursorSpeed=1.0000
bShowCompass=1
[Controls]
fGamepadHeadingSensitivity=1.0000
fMouseHeadingSensitivity=0.0180
bAlwaysRunByDefault=1
bInvertYValues=0
bGamePadRumble=1
bMouseAcceleration=1
bUseKinect=0
[Particles]
iMaxDesired=750
[saveGame]
fAutosaveEveryXMins=15.0000
[AudioMenu]
fAudioMasterVolume=1.0000
fVal7=1.0000
uID7=0
fVal6=1.0000
uID6=0
fVal5=1.0000
uID5=0
fVal4=1.0000
uID4=0
fVal3=1.0000
uID3=94881
fVal2=0.4000
uID2=466532
fVal1=1.0000
uID1=554685
fVal0=0.8000
uID0=1007612
[Clouds]
fCloudLevel2Distance=262144.0000
fCloudLevel1Distance=32768.0000
fCloudLevel0Distance=16384.0000
fCloudNearFadeDistance=9000.0000
[TerrainManager]
fTreeLoadDistance=75000.0000
fBlockMaximumDistance=250000.0000
fBlockLevel1Distance=70000.0000
fBlockLevel0Distance=35000.0000
fSplitDistanceMult=1.5000
bShowLODInEditor=0
[NavMesh]
fObstacleAlpha=0.5000
fCoverSideHighAlpha=0.8000
fCoverSideLowAlpha=0.6500
fEdgeFullAlpha=1.0000
fEdgeHighAlpha=0.7500
fEdgeLowAlpha=0.5000
fTriangleFullAlpha=0.7000
fTriangleHighAlpha=0.3500
fTriangleLowAlpha=0.2000
fLedgeBoxHalfHeight=25.0000
fEdgeDistFromVert=10.0000
fEdgeThickness=10.0000
fPointSize=2.5000
[Trees]
bRenderSkinnedTrees=1
uiMaxSkinnedTreesToRender=200
[Decals]
uMaxDecals=1000
bDecals=1
bSkinnedDecals=1
uMaxSkinDecals=100
uMaxSkinDecalsPerActor=60
[LOD]
fLODFadeOutMultObjects=8.0000
fLODFadeOutMultItems=8.2000
fLODFadeOutMultActors=8.0000
fLODFadeOutMultSkyCell=1.0000
[Launcher]
bEnableFileSelection=1
bShowAllResolutions=0
uLastAspectRatio=3
[blurShaderHDR]
bDoHighDynamicRange=1
[blurShader]
bUseBlurShader=0
[Water]
iWaterReflectHeight=1024
iWaterReflectWidth=1024
bUseWaterDisplacements=1
bUseWaterRefractions=1
bUseWaterReflections=1
bUseWaterDepth=1

 

 

 

UPDATE: Oh dude how wrong i am.. Lowering shadow distance fixed it for me. man, skyrim shadows suck. xD

Edited by C4RN1F3XX
Link to comment
Share on other sites

  • 0

Going above FOV at 65 with 1080p resolution will make your shadows blocky in certain viewing angles but a FOV at 80 or above will make them blocky no matter viewing angle.

Not true, in my experience. I use 1080p with an FOV of 81, and it's all smooth sailing for me. Mayhaps an ENB would mitigate the problem you speak of? I've not noticed any blockiness in quite a long time.

Link to comment
Share on other sites

  • 0

Are you changing the INIs through MO or from the files in your docs folder?

Inside MO of course, but I now understood how Skyrim shadows work and can adapt to it.

Before posting this thread I didn't know about the engine's own mechanic to balance shadow quality vs distance, now I do.. thanks guys. :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.