Jump to content
  • 0
Sign in to follow this  
kevtg26

Weird MO and Dawnguard animation issue

Question

Got a weird issue where I think MO is a factor. How much of a factor I can't say because I'm not sure exactly how MO is supposed to work. I'm hoping someone here can help me with this. I have a STEP install that was working before all this happened and was about to try and reinstall to fix this but I want to make sure that will work before I go through all that trouble. There's a little bit of a story here so bear with me. Here's the deal.

 

A week or so ago the animations for any creature connected to Dawnguard got borked. Bristlebacks, Rieklings, Durzogs from Skyrim Immersive Creatures (they use the Boar race added by Dawnguard) all lost their movement, combat and death animations. The only animation they could display was their standing idle. THey could still move and chase me around, but they looked like they were skating around and couldn't attack. I had been screwing around with my installed mods and saw that this could happen if you change mods that hit NPCs. However, none of the known fixes (cell resets, Reanimator, disable / enable) worked. At this point, I reckoned I had screwed up my save so I decided to start a new game. Except the new game still had the same issues. Dawnguard critters had no animation other than idle.

 

Now I was beginning to wonder how badly I had borked my game. As a test, I started a new game from the vanilla launcher in Steam. No mods and no 3rd party software involved. I spawned a bristleback right there in Helgen and, lo and behold, all of his animations were fine. He could move, attack and fall over dead just as he was supposed to. Now I just figured I had mod issue.

 

What does all of this have to do with MO? This is where things get funny. I have a profile in MO where the ONLY things that are activated are Skrim.esm and the DLC esms. Again, almost as vanilla as you can get. I thought I'd start a new game under that one and test it it before I started screwing with the 150'ish mods I I've got loaded. When I spawned a bristleback in Helgen under that profile... no animations. All the poor guy could do was his idle. Again, the only things active where the Skyrim and DLC esms. Looking at the save in MO and looking at the save in Wrye Bash fired from within MO confirmed that they were the only mods active.

 

This gets us to the part I don't understand. Since the animations worked when I loaded the game from steam I decided that I would try to load the save I created from my vanilla MO profile in the game launched from the vanilla launcher. Take MO out of the equation. When I did that, I got a crap ton of "missing esp" warnings, none of which I had activated on that save. According to MO, all that is active on that save are 4 esms - the same 4 esms that are active if I launch the game from steam. But if I launch the game from steam, Skyrim suddenly seems to think that all the mods from my Mac Daddy profile are associated with that save. Same thing happens with Wrye Bash. If I launch Bash from within MO, it says that only 4 esms are associated with that save. If I launch bash from outside MO, it says there are about 200 esms and esps attached to the exact same save.

 

Is that something that is supposed to happen? What exactly does MO do when you shift profiles? Should a save report the same active mods whether or not I'm getting to it from MO? I think whatever is causing inactive mods to be associated with my save is also what is causing my animation issues. However, I can't tell without understanding how MO works it magic. Can anyone help with this?

Edited by kevtg26

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Sayoregg
      I am using MO2. I installed DynDOLOD in a separate directory than my game and not in program files or anything. In MO2 I added -sse to the arguments for both programs (I'm using the x64 versions of them if that's relevant). Without the arguments the programs give a totally different error so I'm guessing that it isn't the issue. When I do try to run the programs (Both DynDOLOD and texgen), I'm getting this error log. Gonna use TexGen's as an example.
                     [00:00:00.063]    TexGen based on xEdit x64 (DAB7081D) starting session 2021-04-15 10:01:59
                     [00:00:00.073]    Game Mode: SSE
                     [00:00:00.078]    Game Name: Skyrim Special Edition
                     [00:00:00.084]    Using Skyrim Special Edition Data Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\
                     [00:00:00.089]    Using Backup Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\SSEEdit Backups\
                     [00:00:00.095]    Using Scripts Path: D:\Programs (D)\DyndoLOD\Edit Scripts\
                     [00:00:00.101]    Using Cache Path: D:\Programs (D)\DyndoLOD\Edit Scripts\DynDOLOD\cache\
                     [00:00:00.107]    Using Temp Path: C:\Users\Sayor\AppData\Local\Temp\SSEEdit\
                     [00:00:00.114]    Using ini: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Skyrim.ini
                     [00:00:00.124]    Using save path: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Saves\
                     [00:00:00.132]    Using plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.140]    Using settings file: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\DynDOLOD_settings.ini
                     [00:00:00.157]    Using language: English
                     [00:00:00.167]    Using general string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.176]    Using translatable string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.192]    Using VMAD string encoding: 65001 (UTF-8)
                     [00:00:00.202]    Loading active plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.218]    Fatal: Error loading plugin list: <EDirectoryNotFoundException: The specified path was not found>
      I have checked the path it is trying to load "Plugins.txt" from and there wasn't any file called like that there, only a "DynDOLOD_settings.ini". I asked one guy in a discord server for help because I knew he used DynDOLOD. His Plugins.txt file is completely empty, and DynDOLOD worked for him, so I created an empty Plugins.txt file there, yet the programs still give the same error.
    • By Dragoonman
      Firstly, I'll go ahead and explain that I have just over 200 mods in my Skyrim build. I use mod organizer and have followed S.T.E.P as well as several online videos from the likes of Gopher explaining how to install some of the more difficult mods such as perkus maximus. I know how to create merge patches, bash patches, and have cleaned all of my mods (with the exception of Hunterborn and Guard Dialogue Overhaul as their mod pages said not to) with TES5edit.

      However, though my build is stable when exploring interior spaces in Skyrim, I have crashes randomly when exploring the outdoors.

      Sometimes Skyrim will CTD open entering combat while outside. Other times it will CTD when just walking or running around. And sometimes I will talk to an NPC outside and Skyrim will CTD. The only thing I know that the CTDs have in common is that I'm outside when they happen.

      I've run Skyrim Performance Monitor and stay under the 3.1 gb crash limit, so I'm thinking it had to be some sort of script error or perhaps conflicting mods.

      Here is my mod load order.
       
      Here are my PC specs.
       
      I've already edited my SKSE.ini to look like this:
       
       
      I have speedhack enabled on my ENB.
      If someone could take a look at it and tell me if they see some conflicting mods or perhaps a faulty load order, that would be incredible.
       
      My modlist is for me to enjoy a difficult and yet rewarding skyrim which hopefully can look beautiful at the same time. I've seen a few people show off their mod builds which contain even more mods than my own, so hopefully I'm not simply overlooking something silly like a limit.

      I figure it would either be a mod dealing with spawning or combat outdoors, but I haven't really been able to find evidence to back my theory up. Perhaps I installed the patches for my mods in an incorrect order?
       
      The way I have my mods organized is the order in which I install them, so the patches for things like Perkus Maximus, EBD, ASIS, and Dual Sheath Redux are installed in the order that you see them.
       
      I've been trying to make this build stable for over a month now and have done everything short of going through the mods one at a time and disabling them which would take an eternity based on the fact that I would have to repatch everything everytime I disabled a mod. The game is perfectly stable without any of the patches installed and the mods requiring them disabled so far as I could tell, but after the patches are installed things seem to go downhill.
      Any of you experienced modders out there have any ideas? I would prefer to keep all of the mods I currently have, but if I have to chunk some of them in favor of actually being able to play I'll do it, though Perkus Maximus and ASIS are must haves for me.
       
      Thank you in advance! I hope I can get this working before Fallout 4 absorbs all of my interests and consumes me. Please let me know if I need to include any further information.
       
    • By LiquidAurum
      Hi,
      Below is my modlist. I crash to desktop everytime I load a saved game. However, there is one save that loads for a while, but after a while that crashes to desktop as well. Now I assumed at first it's because that was interior, but that doesn't seem to be the case either, as the interior's do load successfully but CTD after a while. I ran loot and did find some conflicting .esp's. and were disabled (ClimatesOfTamriel-Dungeons Hazardous/Hardcore and COT-Interiors-Cold/Warm). Now even after those are unchecked it still CTD. Could htis be a lack of VRAM issue? I don't see how it could be as I've ran this exact ENB befofre (granted almost a year ago). If you guys need the order of my plugins/mods please let me know. 
      Thank you all in advance. 
       
       
      https://drive.google.com/file/d/0B401Ci0KQvVrX29XeU9RdWVZY28/view
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.