Jump to content
  • 0
DiamondMind

Should I be updating to MO 1.3.x?

Question

Mod Organizer has been popping up a message about updating to a newer version. I've searched around and it's unclear wheather or not it is still in beta. I'm running Windows 8.1. Should I update to a newer version of MO, and if so, how?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

The v1.3.x are beta versions. Only update to them if you're wanting to test things out and help troubleshoot. STEP only supports the stable releases. Guess I need to put something in the mod page about this.

Share this post


Link to post
Share on other sites
  • 0

You haven't mentioned the version you are running right now.

I don't think MO reminds you about beta updates though.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

What Tech said. They probably see the message of the day when Tannin has an announcement to make.

Share this post


Link to post
Share on other sites
  • 0

I'm, on 1.2.18. Should I update to 1.3, and if so, which one?

 

The v1.3.x are beta versions. Only update to them if you're wanting to test things out and help troubleshoot. STEP only supports the stable releases. Guess I need to put something in the mod page about this.

 

What Tech said. They probably see the message of the day when Tannin has an announcement to make.

 

Well, I just got the message of the day, and if MO v1.3.x is still considered in beta testing, it should be stated directly and clearly, considering MO has a good number of non-English native speaking users.

 

The idea that MO v1.3.x is only implied in the third section of the MO message of the day I've just received:

 

I've just uploaded Mod Organizer version 1.3.2 but I haven't marked it as the "latest version" yet so no one downloads this unwittingly.

 

That's enough for me to understand that I should no consider v1.3.2 a "stable release," but it could state this much more directly.

Share this post


Link to post
Share on other sites
  • 0

I've just left a post in the MO thread stating as much.

Although all the 1.3.x series are fully functional, until the main page description changes to show 1.2.18 as NOT the "Latest version", everyone should consider it as the 'stable' release, not any of the 1.3.x series.

Share this post


Link to post
Share on other sites
  • 0

I didnt consider 1.3.2 as beta because i had been doing betas (1.3.0 and 1.3.1) on this forum. It was only after release it turned out there were many issues left. But if only 2 or 3 ppl test things stay unnoticed so i dont have another choice but to make releases public at some point

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.