Jump to content
  • 0
gg12345

How to change the data path for skyrim

Question

When I try to run DynDOLOD through vortex I get an error stating that it cannot find the resources files. I believe I have installed them correctly, additionally it is opening in the correct mode (SSE). I believe the issue is that it is searching in the wrong path. Currently it is looking in the normal Steam\steamapps\common\Skyrim Special Edition\Data path, however, to prevent sse from updating to the anniversary edition I created a backup elsewhere in my program files folder. I currently run skyrim entirely through that backup folder, mods and all, and thus I need to change the path that DynDOLOD is searching in for the data folder. Any chance someone knows how to do this?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Pretty sure you can specify your custom path like this:

-D:"C:\Path\To\Data"

You will need to add this as an argument to the DynDOLOD program and TexGen I do believe.

Share this post


Link to post
Share on other sites
  • 0

Same as above but path must end with a backslash:

-D:"C:\Path\To\Data\"

This works with any xEdit-based tool (xEdit, xLODGen, TexGen, DynDOLOD).

Share this post


Link to post
Share on other sites
  • 0
35 minutes ago, DoubleYou said:

Pretty sure you can specify your custom path like this:


-D:"C:\Path\To\Data"

You will need to add this as an argument to the DynDOLOD program and TexGen I do believe.

 

I tried doing this in vortex but it did not work, here is what I did: image.thumb.png.89d76f0ee0ded0b0b67fe51ac103f4e6.png I tried different configurations of the -sse and the file path, all of them either gave the same error or failed at an earlier point if the -sse was removed. It is also very possible that I am just misunderstanding how to add an argument, I am somewhat new to this. I also tried again adding a backslash to the end of the path which also did not work

 

Edited by gg12345

Share this post


Link to post
Share on other sites
  • 0

Do you have a space between -D: and "C:\Program Files ...". It looks like you may have a space character. There should be no space.

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, Mousetick said:

Do you have a space between -D: and "C:\Program Files ...". It looks like you may have a space character. There should be no space.

good catch! DynDOLOD finally ran correctly, thanks everyone!

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, gg12345 said:

When I try to run DynDOLOD through vortex I get an error stating that it cannot find the resources files. I believe I have installed them correctly, additionally it is opening in the correct mode (SSE). I believe the issue is that it is searching in the wrong path. Currently it is looking in the normal Steam\steamapps\common\Skyrim Special Edition\Data path, however, to prevent sse from updating to the anniversary edition I created a backup elsewhere in my program files folder. I currently run skyrim entirely through that backup folder, mods and all, and thus I need to change the path that DynDOLOD is searching in for the data folder. Any chance someone knows how to do this?

If the game folder was moved the best option is to run the games launcher once to update the Windows registry entry with the new path, since every tool use that to automatically find the game folder. The launcher can be executed directly without Steam running.

The game shouldn't be installed into special Windows folders like Program Files x86 to avoid problems with UAC etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.