Jump to content
  • 0
OregonPete

CTDs when going to new lands

Question

Hi Sheson

 

I'm having a very strange problem. Until recently, everything was running just fine, but in the past month or so I've had this issue that I can't get into any new lands using DynDOLOD without causing a CTD. This means mods such as going to Kirkmore in the "Haafstad and Border to High Rock" mod, Wyrmstooth, Falskaar, and Beyond Reach. Interestingly, I can get to Solstheim, but I haven't tried the Dawnguard "Falmer Valley" since I'm not that far along in the quests yet. If, for whatever reason, I do make it to a new land (if even just briefly), the system CTDs shortly after, and if I attempt to load any saves created in that land, the system CTDs immediately. 

 

I'm using MO2, and I also have Open Cities and therefore use the two-step process when running DynDOLOD. I also have a huge load order with more than 400 plugins and over 500 mods. I also use the Ultra Trees setup so I'm using TreeFullFallBack=0. I've tried all the steps you've posted, including all the advice you gave Alastor in the "ctd, ils and impossible to load game when i using DynDOLOD" thread. I also deactivated DynDOLOD and tried getting into the new lands. That works, so it seems the cause needs to be with DynDOLOD somehow (very possibly through an error on my end). 

 

What I've done so far is the following (without success, I'm afraid):

 

  • Upgraded from DynDOLOD SSE 2.59 to 2.69
  • Uninstalled BS Bruma, Haafstad (i.e Kirkmore), Nyhus, Falskaar, Gray Cowl of Nocturnal, Beyond Reach, and Mirai, leaving "only" Wyrmstooth, Clockwork, Temple of Black Rock, and Secret of Dragon Head for test purposes. So far, Clockwork seems to work fine (as does Solstheim), but Wyrmstooth CTDs, as did both Falskaar and Beyond Reach in the end. I haven't tried Black Rock or Dragon Head yet. It seems those mods don't really use DynDOLOD much, though.
  • Started a completely new game and reran TexGen and DynDOLOD
  • Ran the count_loaded_refs_in_load_order script but only had a little over 300k references, and this with DynDOLOD installed
  • Ran DynDOLOD with Temporary=1, and again with Temporary=0, just in case
  • Ran DynDOLOD with TreeFullFallBack=0 and with TreeFullFallBack=1 (looks pretty horrible with TFFB=1, btw)
  • Checked everything for missing NIFs
  • Checked for Errors with SSEEdit
  • Installed the Net Script Framework, but couldn't see anything in the crash dumps (then again, not really sure how to read those, either)

 

It's very possible I missed something obvious, and I'd be glad to post any logs or dumps if it will help. Any advice is greatly appreciated.

 

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
FAQ: Game: ILS or CTD

 

A: More LOD uses more memory and this can cause infinite loading screen (ILS) or crash to desktop (CTD) if the game is not setup correctly. This should generally not be a problem with Skyrim Special Edition or Skyrim VR, but for Skyrim double check heap memory usage (block 1) with Memory Blocks Log from https://www.nexusmods.com/skyrim/mods/50471/ and adjust SKSE or SSME memory settings. Or use the alternative OSAllocator from crash fixes with pre-loader. Remove satefy-load if it is used. Setup ENBoost correctly. Set ExpandSystemMemoryX64=false in enblocal.ini. 

 

A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 

 

A: If heap memory is not the cause of CTD see ..DynDOLOD\Docs\DynDOLOD-README.txt for checking if a missing or invalid nif model used for dynamic LOD is the cause. 

 

A: Large load orders with many plugins might surpass the reference handle cap. SSE Engine fixes prints a warning. See https://www.reddit.com/r/skyrimmods/comments/ag4wm7/psa_the_reference_handle_cap_or_diagnosing_one_of/ Setting Temporary=1 in ..DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_[GameMode].ini may help in these situations, however converting large new land plugins to ESM is the preferred solution. 

 

 

 

If you didn't see a NIF name in Crash Fixes crash log, then it's probably not a corrupt mesh. Even so, still enable debug in the json/txt and then check the papyrus log for which NIF dynamic LOD enabled last.

 

If that doesn't reveal anything, see if hiding the meshes folder from the DynDOLOD output changes anything. I suspect not, but you never know.

 

Then hide the SKSE folder, ignore the expected error messages about data not being found in the json/txt files, just test if it CTDs or not.

 

If it still CTDs, test if it still crashes with only the DynDOLOD.esm

 

Report back on these tests.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By CultureBomb
      I'm following the STEP 2.0.0 guide and I just finished setting up ENB. The game worked perfectly prior to installing ENB but now the game crashes when ENB tries to compile shaders when running for the first time. I'm yet to run DynDOLOD and TexGen. Installing the ENB Light 0.98 Alpha 2 update file produced an error stating that the vanilla torch file was missing from the FOMOD installer stating that the mod might not work properly. Attached are my crash logs.
      System Specs:
      CPU: Ryzen 5 5600X
      GPU: RTX 3070
      RAM: 16GB
      crash-2022-09-01-00-18-58.log crash-2022-09-01-00-19-33.log crash-2022-09-01-00-33-34.log crash-2022-09-01-00-47-08.log crash-2022-09-01-00-51-22.log crash-2022-09-01-01-32-53.log
    • By beeleth
      Hello, I need some help with an issue in my game. The game kept crashing whenever I entered High Hrothgar. This is from the crash log:
      It mentions ENB there so I tried changing ENB to no avail. Google search also doesn't really get me anywhere since the people that got this issue had offending mods that I don't have. I use VERVE ENB with the recommended enbhost (v292), following this guide https://www.sinitargaming.com/skyrim_graphics.html#google_vignette.
      Everything was fine with a few occasional CTD but nothing too concerning. Only now I got a constant CTD. If anybody knows how to read crash logs, please help me. If I need to post my load order too, do tell. I don't have time to post it now but will do if requested later.
    • By Arcfell
      I've modded Skyrim following the STEP guide back in March. I've played multiple characters/saved games since.
      I currently have a Character with 4 saves that for the most part crash to desktop(log attached) on loading the save:
      One is a quick save This is in Bleak Falls Sanctum I've managed to load the quick save once which promptly CTD when I tried to save again (still in Bleak Falls Sanctum) This only happened once and I cannot replicate this. The other three are auto saves One in Bleak Falls Sanctum The other 2 in Bleak Falls Barrow
        I have some very early (level 1) saves on the above character that still work, however I'd prefer if the above could be recovered. This crash is isolated to these saves, as all other Characters/Saves still work. No new mod installs or updates have occurred since the first STEP installation in March I've ran LOOT and tried sorting plugins Any help recovering these saves would be appreciated.
      crash-2022-05-18-12-23-25.log
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.