Jump to content
  • 0
Sign in to follow this  
DrewsBrew

Mod Organizer/Campfire DevKit Tutorial Issues

Question

Hello,

First, I'm new here, so sorry if this isn't the right forum for this, my bad.  Anyway, I use mod organizer and am trying to do the Campfire DevKit tutorials, but I'm having a problem; mainly, I don't seem to be able to attach Campfire scripts to objects in the creation kit.  In following the 'Hello, Chair' tutorial, I can't get past 'The Placeable Object' step in the tutorial because it asks me to attach a script to a chair.  I can attach the editor ID just fine, as well as everything else in the tutorial up until that point.  Interestingly enough, if I can find another object that already has the script I need ( CampPlaceableObject) attached, and click on the script, all of the sudden MO recognizes that script and will allow me to attach it to other objects.  I can get through the tutorial that way, but when I get in game and try to create the object from the tutorial (a placeable chair), the chair has no name (even though I am sure I gave it on in the CK) and it doesn't show up in my inventory when I make it either.

 

I have tried practically everything, including completely uninstalling and reinstalling Skyrim and the CK.  I've searched on google to see if anyone else has had this problem, and as a last resort even contacted Chesko.  I came here on the suggestion of GamerPoets, so I'm really hoping someone here can help me out.  Thanks in advance to anyone who takes the time to at least read this, more so to those who respond.  I have screen recording software and can make a video if that will help.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I'll be honest and say upfront I have never used the CK from inside MO that referenced scripts from another mod but...

 

I believe the issue is MO is NOT seeing any script that is installed via MO, ie. the scripts are contained in a mod within MO's structure.

Following the tutorial as you did I too was unable to place the 'placeable object', because that script was unavailable to the CK to work with. So, I copied ALL the compiled and source scripts into the actual game's Script folder and then hid those from the DevKit inside MO and tried again.

Voilá! Now all those scripts are accessible and can be used in the CK.

 

I have no idea if all the authors in the past, such as @Chesko, just had those in their game install anyway and just assumed MO would be similar, but there you go. I am confident you can continue now.

Would be very interested to hear from other authors that use the CK inside MO.

Share this post


Link to post
Share on other sites
  • 0

Thanks so much for your help Grant!  It worked perfectly.  I don't quite know what you meant by "...and then hid those from the DevKit inside MO", but what I did was copy all the scripts from inside the DevKit files into my scripts folder in game (the source folder as well) went through the tutorial, got through it with no problems,  Then I just deleted the DevKit scripts from the game folder, loaded the game, everything works fine.  I don't know if it is fine to just leave the DevKit scripts in the game folder or not.  Still, though, I'm just glad I can actually do the tutorials now.  Thanks again for your help!

Edited by DrewsBrew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.