Jump to content
  • 0

CTD on Save Load. New Game



Current Load Order: https://pastebin.com/6Wtiz0eS


I have been tweaking my load order for some time but recently I began to have crashes in save game loads. These games are brand new games that are still in the Live Another Life prison cell. I will often configure MCM menu's and make a save, go back in later to load and CTD. What's more infuriating though is that it's not always reproducible and will sometimes load fine. 


I have SKSE configured for memory patch as well as enboost enabled even though it sorta sounds like a memory issue.


I originally was using Wrye Bash but completely reinstalled everything and switched over to MO. now 90% through reconstructing my load order and this crash is back. Been pouring over forum threads to see if a specific mod has it.


Not an easy thing to track down, but if anyone heard about something similar they saw on one of the mod forums, ect. let me know




Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Bumping this topic.


While re-installing my load order via MO I began to create incremental profiles to determine the CTD issue. Unfortunately when I got up FNIS I began getting crashes either on load or 5 seconds after load. According to FNIS FAQ


("Load CTD") After I ran the generator, Skyrim aborts (CTD) when loading a save file. An FNIS bug?
No. Skyrim's memory Management is buggy, and the more you add to Skyrim, the greater the likelyhood that you see CTDs, especially on save load. I personally have NO load CTD with 1500 animations, about 0.5 with 3000 animations, and about 3-6 CTD with 4000 animations before the game is loaded. Interestingly, once Skyrim starts sucessfully, an immediate re-load of the same file will almost always succeed, even with 4000+ animations. So there is an apparent dependency between memory usage and CTD frequency. Here my advice when you have an unacceptable CTD rate:

  • Install SKSE 1.7.0 Alpha or later. This will install "sheson's memory patch", which will not totally cure Skyrim, but geatly reduce CTD likelyhood. Make sure you have a Data/SKSE/skse.ini file with the following lines:
  • [Memory]DefaultHeapInitialAllocMB=768ScrapHeapSizeMB=512
  • Make a "clean save". Skyrim's problems to deal with updates of scripted mods is another big CTD cause.
  • At least temporarily reduce the number of FNIS based mods. Pinup Poser, for example, is a great mod. But I can't understand why user keep a pose mod active all the time when they suffer from frequent CTDs.


I have the memory patch as well as enboost activated and now I have to question, what is a normal CTD range now? Without FNIS I get no crashes in 5 loads. With it I can get 1 crash every 3 loads roughly. I also do not remember getting this many CTD's with earlier versions of FNIS. I am still inclined to think it is a conflict or something as a result. This is the current load order I had at the time



Will begin digging through animation mods I have installed but they are all vanilla replacer's

Edited by TehKaoZ
Link to comment
Share on other sites

  • 0

When you say animations are you referring to animations listed when running FNIS or animations installed in your mod list, I have mods which add animations and FNIS tells me I have over 2500 animations and I don't think I've had a single CTD in relation to those animations, my own stupidity has caused me to crash every now and then though.

Link to comment
Share on other sites

  • 0

My memory block log gets to about 150 in the first block so It doesn't seem like it's anywhere near even the normal limit. DynDoLod is not currently installed in my current profile either.





I had it to 4096 for a bit but it caused the game to be considerably more unstable. It seems like 5,120 or 6144 are the sweet spots. I had been running those settings for months without incident before the instability issues occurred.


With FNIS I tried nothing no skeleton and I tried using XP32 Extended. Either seem to give me the same ctd amount.


Vanilla FNIS


FNIS Behavior V6.2   1/23/2016 6:10:43 PM
Skyrim: - D:\Steam\steamapps\common\Skyrim\ (Steam)

Skeleton(hkx) female: Default (99 bones)   male: Default (99 bones)
Patch: "SKELETON Arm Fix"

Reading FNISBase V6.2 ...

All Anim Lists scanned. Generating Behavior Files ...
0_master usage: 1.1 %   ( 0 paired, 0 kill, 0 alternate animations)
Alternate Animation mods: 0 sets: 0 total groups: 0 added file slots: 0 alternate files: 0

Creature Pack not installed

 47 animations for 1 mods successfully included (character)


------------XP32 Extended FNIS


FNIS Behavior V6.2   1/23/2016 6:12:27 PM
Skyrim: - D:\Steam\steamapps\common\Skyrim\ (Steam)

Skeleton(hkx) female: XPMS2HDT (115 bones)   male: XPMS2HDT (115 bones)
Patch: "SKELETON Arm Fix"

Reading FNISBase V6.2 ...
Reading XPMSE V6.1  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 152 alternate animations) ...

All Anim Lists scanned. Generating Behavior Files ...
0_master usage: 4.8 %   ( 0 paired, 0 kill, 80 alternate animations)
Alternate Animation mods: 1 sets: 16 total groups: 24 added file slots: 156 alternate files: 152

Creature Pack not installed

 199 animations for 2 mods successfully included (character)


Current Profile Load Order: https://pastebin.com/7c0BrMav


I have considered simply moving forward with rebuilding my load order and using the standard xp32 skeleton and no FNIS. But it's just odd since I had used FNIS for years and never had instability until recently.

Edited by TehKaoZ
Link to comment
Share on other sites

  • 0

I just run mine and I noticed with my mods installed.


I don't see these lines in your list anywhere, not sure if it's a bug or what.

No GENDER directory male
No GENDER directory female
mt_behavior usage: 25.4 %   ( 26 furniture, 31 offset, 0 chair, 87 alternate animations)


The options I chose are

Patch: "GENDER Specific Animations"
Patch: "SKELETON Arm Fix"

My total animations installed in my game at present


2824 animations for 9 mods successfully included (character)



I would consider redownloading FNIS or maybe trying one of the 2 updates Fore has posted to see if that helps.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.