Jump to content
  • 0
Flobur

Empty mod with fomod installer

Question

Hello,

 

I'm french, and at the moment I am translating a nexus mod for Skyrim.

This mod comes with a fomod installer because there is a lot of options (do you have dawnguard? dragonborn? do you want this option? or another? and so on).

At some point I wanted to translate the fomod's ModuleConfig.xml file too.

Then, I tried to install the partially translated mod with Mod Organizer, a window opens, the fomod installer works... but when the installation is finished, MO tells me the mod is empty.

I tried with the original non modified mod, it worked... did it?

 

It worked for the 7z archive downloaded from nexus.

But then I extracted all the files, and repacked them into another archive, with the exact same structure. Just extract and repack everything.

And for this new archive, it did not work.

So apparently the problem does not come from my translation, but from MO.

After that, I deactivated the internal fomod installer in MO settings, and then the mod got installed correctly.

 

It is not the first time I install or translate mods with fomod installer, but it is the first time I face this problem.

 

Structure of the mod: 16 versions of the main esp file, 4 versions of the bsa archive, 4 versions of the patch for Requiem (juste esp file), 8 versions of the patch for SkyRe (idem) and 1 patch for SPERG (esp + bsa); all of this in different folders, so 33 folders.

 

Anyone has an idea where the problem comes from?

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

After looking at the layout of the mod and quickly experimenting, I have a hunch... Did you extract the files to the "Enchanting Awakened-42796-1-61" folder then right click "Enchanting Awakened-42796-1-61" and select 7-Zip/Add to archive? If you do this, 7-Zip creates a folder structure like this:

 

  • Enchanting Awakened-42796-1-61
    • -- Docs --
    • -- Imgs --
    • 00 Required Files - DB and DG
    • ...

If you then install this mod, the installer looks for and finds an FOMOD folder with a ModuleConfig.xml file so everything seems to be fine. But, when it goes to install the files it can't find the /00 Required Files - DB and DG folder because it's actually Enchanting Awakened-42796-1-61/00 Required Files - DB and DG.

 

What you have to do is to go into the Enchanting Awakened-42796-1-61 folder, press Ctrl+A to highlight everything, and then select 7-Zip/Add to archive so the folder structure is retained.

Share this post


Link to post
Share on other sites
  • 0

Can you provide the files in question for us to examine?

Share this post


Link to post
Share on other sites
  • 0

If you translated the file paths and did not do so for the folder structure as well, that would explain this.

Share this post


Link to post
Share on other sites
  • 0

Well, what I translated is: the esp files whitout changing the name or the name of the folders, and the "description" contents in the "ModuleConfig.xml" file, nothing else.

But the more relevant thing is that the problem occurs with the original, unmodified mod too.

 

Not exactly true: with the 7z file donwloaded from nexus, no problem.

But if I extract the content and repack with the exact same structure, then the problem occurs with this new archive.

Right click on the mod => extract here => right click on the new folder => repack with 7zip => load this new archive with MO => fomod works => empty mod installed.

 

That's why I don't think the problem comes from my translation (there are maybe some other problems, but that's another story ;)) but from MO itself.

Edited by Flobur

Share this post


Link to post
Share on other sites
  • 0

Can you provide a link to the mod in question?

Share this post


Link to post
Share on other sites
  • 0

Further to what @Greg just said, if we can see the actual file it would make it easier. More eyes on it mean more chance of spotting something.

Since the original mod follows a very standard format of fomod, it is probably something very minor and easily missed.

Share this post


Link to post
Share on other sites
  • 0

Well Greg, it seems you are right. :^_^:

I just tried with the original mod, and with my translated version, and it worked!

I don't have a lot of experience in managing mods with fomod, I mean put my hands in it to see how it works, so thanks for the help  ::): 

 

GrantSP: sorry, I put a link to the original mod, but I have still not uploaded the translated version, so I could not provide a link for this one.

Thank you anyway for your time.

Share this post


Link to post
Share on other sites
  • 0

Not a problem. Glad you got it all sorted. Kudos @Greg.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.