Jump to content
  • 0
Sign in to follow this  
singdavion

The STEP guide needs to inform us what each patch will add.

Question

I went along with the guide assuming that the Step Patch will add some of the mods listed. But as it turns out, the combined HF patch only covers 3 of the mods that were on the list.

 

This isn't good. The guide can't strictly assume people are doing the core install. Please fix this and if someone can tell me which mods provided patches. It's very disheartning to get through all those mods and then find out that you are going to have to go back and check stuff because you weren't informed of what certain things would or wouldn't add.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Wow ... why are you assuming to understand what the STEP Patches do at the very beginning of the guide unless you have read through their doc?

  1. We created the guide for users to install STEP:Core, so that is the blatant requirement.
  2. The guide details how to install either STEP:Core or STEP:Extended with detailed instructions from start to finish.
  3. If you fail to install all of STEP:Core or STEP:Extended, then obviously you are deviating from expectations, and it is on YOU to look ahead and investigate the requirements of the STEP Patches, which are well documented.
  4. Each mod down the list also includes links to detailed instructions for every mod that does not have 'simple' instructions.
  5. Each mod page lists any particular dependencies and LOOT instructions, and assumes that users are following the guide start to finish. 
  6. The STEP Patches are described in great detail if you follow the links and read.

What is the "Combined HF patch" ... if you mean "STEP Combined PluginHF.esp", then it is described in the STEP Patches pages. Perhaps EssArrBee could upgrade the instructions to include more explicit detail, but if you do not understand something, then post about it so that we can correct it rather than continue on with your 'assumptions'. I agree that more explicit description is needed for "STEP Combined PluginHF.esp", especially since "STEP Combined Plugin.esp" is explicitly detailed.

 

If you are having trouble, it's because you did not actually read through and follow the guide start to finish. We make it relatively simple for newbies to mod Skyrim, and those that do not follow the guide strictly ought to know what they are doing, else they are going to run into trouble.

 

Follow the guide ... read. Otherwise, just scrap STEP and try modding your own game yourself (and get even more frustrated). We have brought all of the info necessary to mod Skyrim all in one place, so you only have yourself to blame if you fail to follow the instructions.

Share this post


Link to post
Share on other sites
  • 0

Well, I'm assuming that you didn't install everything in either STEP Core or STEP Extended. What you can go is install either/both those patches and put them at the end of the load order, right above the Bashed Patch. If either patch has a red triangle next to it in the right pane of MO, then you can't use it. If you do not have the red triangle then you can use the patch. The reason I don't make more sets of patches is the nightmare of maintaining those.

Share this post


Link to post
Share on other sites
  • 0

I assure you that I've read every single word thus far.

I suppose this is the easiest example.

 

https://wiki.step-project.com/Even_Better_Quest_Objectives#Recommendations

 

"The Paarthurnax Dilemma (Unnecessary if using the STEP Patches)"

 

Yup, I am using the Step patches, the patch I'm using isn't covering the Paarthurnax Dilemma.

Woops. No I'm not convinced by your reply. This is easily fixed anyway.


Well, I'm assuming that you didn't install everything in either STEP Core or STEP Extended. What you can go is install either/both those patches and put them at the end of the load order, right above the Bashed Patch. If either patch has a red triangle next to it in the right pane of MO, then you can't use it. If you do not have the red triangle then you can use the patch. The reason I don't make more sets of patches is the nightmare of maintaining those.

I'll give it a try. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.