Jump to content
  • 0
Sign in to follow this  
natranr

I need some help stabilizing my mods

Question

To start out, here's my system:

 

Z87 Haswell Core i5 4670K @4.4GHz

Radeon R9 270X 2GB

8GB DDR3 1333

Windows 7 64 bit.

 

Now, the issue I have right now is, when starting a new game, Lokir just dies and vanishes, then the game crashes. It could be from any number of things.

 

The thing is, I have Automatic Variants, Dual Sheath Redux, Real Shelter and a Bash Patch. I have no idea which order to make those patches in. Also using SUM for the Reproccers.

 

Now I'm sure you know how SUM and Bash patches work, but maybe you are not familiar with Real Shelter's RSpatch.esp. The patch esp uses a script in TES5EDIT that takes in account every ESM, ESP and any ENB you have. So I assume that needs to be last, but what about the reproccers and Bash Patch?

 

I'll go ahead and attach the needed files below.

 

Also, ENB was crashing, but I think it was MSI Afterburner getting in the way.

 

 

 

 

archives.txt

loadorder.txt

lockedorder.txt

modlist.txt

plugins.txt

skyrim.ini

skyrimprefs.ini

enblocal.ini

enbseries.ini

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I think you can run them in any order but as a rule of thumb do Bashed patch first.

Let Sum take care of the order and last the RS patch.

Share this post


Link to post
Share on other sites
  • 0

I think you can run them in any order but as a rule of thumb do Bashed patch first.

Let Sum take care of the order and last the RS patch.

Now I remember when making bash patches, that you select the entire list and click mark mergable, but on the wiki for it, it just says to do that to one mod. So when adding/removing mods from my list, do I just rebuild the bash patch?

Share this post


Link to post
Share on other sites
  • 0

Ok, so ENB is still causing the game to CTD. I don't have FRAPS or Afterburner running, so I don't know what's causing it. It loads up seemingly fine, gets to the screen with the Akatosh symbol minus the meny items and the ENB text shows, then it crashes. Runs fine with I disable ENB.

 

I was using ENB 262, with RealVision, but I think that might be the issue. I'm going to try with the more recent version with just ENBoost.

Share this post


Link to post
Share on other sites
  • 0

To answer the question from your other thread. What is causing the crash is most likely a missing master. Setup TES5Edit if you haven't already and run it. Let it go until it either throws up an error or says background loader finished or similar.

Share this post


Link to post
Share on other sites
  • 0

Ok Hish that isn't a cure all, it fixes most in game CTDs but this is a different beast from what I can gather. I suggest they try loading it up in TES5Edit. Even if they were encountering issues in game due to that it shouldn't affect them getting into the main menu (from what I understand of how the memory blocks works). If they're getting to the main menu only for it to crash right afterwards then it's almost always a missing master or other load order related issue. Still it is weird that it only happens with ENB enabled so it could be something else from either of our ideas.

 

@OP Have you been able to say load a save or create a new one with ENB disabled? Also could you post a screenshot of your base Skyrim Directory (where you are placing the ENB files) please?

Share this post


Link to post
Share on other sites
  • 0

Phazer11, you have to start somewhere and I looked at what was said again and it seems like it he is on the loading screen or partially in game. "loads up seemingly fine, gets to the screen with the Akatosh symbol minus the meny items and the ENB text shows, then it crashes"

 

Its always the simplest thing that messes everyone up

 

Awhile back I was talking to keith and mentioned that sometimes the Expandmemoryx64 when enabled may cause issues on startup. Its issues are common when the memory tweaks are adjusted. 

Share this post


Link to post
Share on other sites
  • 0

First off we need more information about when it's happening. Whether they can get to make a new game without ENB enabled i.e. maybe it's a delayed CTD when there is no ENB.

Hishutup you're right they need to start somewhere and I believe that to be loading everything up in TES5Edit and making sure that loads fine. I myself in many many mod lists before and after sheson's memory patch have never encountered an issue like the one you and keith talk about. Granted it is seemingly an ENB related issue so you might be right however I suggest running TES5Edit first to make sure nothing kinky is going on. I apologize if I came off as a little "salty".

Share this post


Link to post
Share on other sites
  • 0

Its all good mate.

The strangest place for a freeze or CTD is in the loading process from starting the game -> being in game.

It can be just anything that modifies code. *shrugs*

Share this post


Link to post
Share on other sites
  • 0

Well to start off, MO isn't reporting any missing masters, and TES5EDIT doesn't report any errors.
 
Here is my Skyrim folder.
 
https://i.imgur.com/F32BaiI.png
https://i.imgur.com/AWmTyiy.png
 
Now Wrye Bash reports some ESPs as Masters have been rearranged.
 
Now to clarify, the game loads fine with the ENB files removed, and loads fine with ENB but no mods enabled. So it's a mod that is getting in the way of ENB. I'll post my mod list again as MO has rearranged the left pane several times now.

 

Edit:I ran the memory blocks log and pasted it below in a spoiler tag.

 

 

logging of blocks enabled

logging max values only
Timer disabled
Block1 Block2
512MB 512MB
85 8
85 8
85 9
85 10
85 11
85 12
85 13
85 14
85 15
85 16
85 17
85 18
85 19
85 20
85 21
85 22
85 23
85 24
85 25
85 26
85 27
85 28
85 29
85 30
85 31
85 32
85 33
85 34
85 35
85 36
85 37
85 38
85 39
85 40
85 41
85 42
85 43
85 44
85 45
85 46
85 47
85 48
85 49
85 50
85 51
85 52
85 53
85 54
85 55
85 56
85 57
85 58
85 59
85 60
85 61
85 62
85 63
85 64
85 65
85 66
85 67
85 68
85 69
85 70
85 71
85 72
85 73
85 74
85 75
85 76
85 77
85 78
85 79
85 80
85 81
85 82
85 83
85 84
85 85
85 86
85 87
85 88
85 89
85 90
85 91
85 92
85 93
85 94
85 95
85 96
85 97
85 98
85 99
85 100
85 101
85 102
85 103
85 104
85 105
85 106
85 107
85 108
85 109
85 110
85 111
85 112
85 113
85 114
85 115
85 116
85 117
85 118
85 119
85 120
85 121
85 122
85 123
85 124
85 125
85 126
85 127
85 128
85 129
85 130
85 131
85 132
85 133
85 134
85 135
85 136
 

 

 

 

Edit 2: Ok, so it was the Expandmemoryx64 option. It doesn't crash any more with all my mods enabled. Now what do I lose by disabling that? 

 

Edit 3: Ok, now actually getting into the game, it runs pretty bad with ENB on and off. I'll have to tweak the settings later after work.

plugins.txt

modlist.txt

lockedorder.txt

loadorder.txt

Edited by natranr

Share this post


Link to post
Share on other sites
  • 0

Ok, like I said phazer11, its is the small things that screw everyone up. 

The memory block log is yet again the answer to our issue.

you have 512MB 512MB which will do some funny business with the Expandsystemmemoryx64 because I think it does some memory defrag or something interesting, it can cause issues with different memory sizes. I dont know exactly what it does but change the skse.ini scrap heap value back to 256 and you can leave the ExpandSystemMemoryX64 option enabled.

The performance is probably because you  are maxing the VRAM constantly and it has to swap a lot.

 

I forget how much you have but I found a good rule to be use 1k texture overhauls and 2k specifics when you have 2GB VRAM. If you have 3GB or greater you can use pretty much 2k and 4k respectively 

 

EDIT: you said you have 2GB... I need to read...

Share this post


Link to post
Share on other sites
  • 0

I actually had the memory settings in the SKSE.ini at 768 or what ever. So Should I set both to 256? Wouldn't that negate the memory patch?

 

Now for overhauls versus Specifics, Would Book of Silence be considered specifics or an overhaul?

 

Anyways, I'll look into downgrading those texture tonight after work.

 

This is what I had the SKSE.ini at:

 

 

[General]

ClearInvalidRegistrations=1
 
[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=768
 
[Display]
iTintTextureResolution=2048

 
So I'll set the scrap heap to 256, and can I just leave the Default Heap at 768? or would it work better at 512?
 
Yeah, setting the scrap heap to 256 fixed it.
Edited by natranr

Share this post


Link to post
Share on other sites
  • 0

Book of silence only has one option to download, so keep it as it is.

If you have the option of hq or medium, take the medium

 

use this

[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

It should work for just about everyone.

Share this post


Link to post
Share on other sites
  • 0

So I re-installed the conflicting graphics and landscape texture mods and used the baseline options. Performance is much better now with less hiccups. I will probably go down the list and re-install the rest of the texture mods and bring those down as well.

 

Now, I noticed lanterns from Lanterns of Skyrim are purple. Are the textures from the BSA not being loaded?

 

Also, could you recommend a ENB preset that looks good and doesn't take up to much performance? With my current ENB (Grim and Somber Azura) I got like 18-25 in cities and up to 30 in the wilderness. 

Edited by natranr

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.