Jump to content
  • 0
Sign in to follow this  
Docterfreeze

Mod organizer not installing any mods, tool button not working

Question

So i got a couple problems, I just started the "fear and loathing" FNV step guide and MO is already being dumb.

 

First problem, when I click the tool button, the downward pointing arrow on the icon moves slightly, then nothing happens.

 

Second problem, whenever I try to install a mod it gives me an error saying "None of the available installer plugins were able to handle that archive"

 

The archive is not corrupt

 

I've tried it with and without winrar

 

I've tried downloading with manager and downloading manually

 

None of that fixed it.

 

Can anyone help with this?

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

It may be a good idea to make a restore point before doing this.

 

First some required reading How to set the path in Microsoft Windows if you need it.

 

  1. Create a new plain text file on the desktop, call it “path backup.txtâ€.
  2. Open windows file explorer and navigate to the falloutNV folder. When there click in the address box and highlight the text and copy it. Paste this into “path Backup.txt. Mine looks like this:
    1. D:\Steam\SteamApps\common\Fallout New Vegas
  3. Click the start button and type “advanced system settings†without quotes in the edit box. You should see an entry in the control panel section. Click on it and it will open the advanced properties tab in the system properties window.
  4. At the bottom click on the Environment Variables button. Another window will open.
  5. In the bottom section, use the scrollbar until you see the word “Path†on the left side.
  6. Click on the path to highlight it and select the edit button below it. The edit system variable window will open.
  7. When it opens it should have “Variable value†highlighted. Right click there and select copy then hit cancel.
  8. I am doing this so you can see what the whole thing looks like and to make a backup if anything goes wrong.
  9. Paste this into your “path backup.txt†twice each on a new line and save it. Mine looks like this:
    1. C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Python27\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files (x86)\Windows Live\Shared
  10. On the second line add a semicolon and copy your fallout directory after it. The whole thing will look like this:
    1. C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Python27\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files (x86)\Windows Live\Shared;D:\Steam\SteamApps\common\Fallout New Vegas
  11. Save the “path backup.txt†file again.
  12. So all we need to do is add a semicolon with your FNV path to the variable.
  13. Back to the environment window and click the path and hit edit. When that opens hit your “END†key to go to the end of the text string. Add a semicolon and your fallout path. Like this:
    1. ;D:\Steam\SteamApps\common\Fallout New Vegas
  14. Hit OK three times and reboot your computer.

Share this post


Link to post
Share on other sites
  • 0

It would first help if you told us what archive it was and what version of MO you are using.

Share this post


Link to post
Share on other sites
  • 0

All archives wont install, but the one I want to install is NVAC. my version is 1.2.14. I just got MO yesterday

Edited by Docterfreeze

Share this post


Link to post
Share on other sites
  • 0

Reinstall mo with a fresh installer

This fixed the two problems, but a new one has arisen. I can't launch the 4GB launcher, even with the argument provided in the guide.

Share this post


Link to post
Share on other sites
  • 0

This fixed the two problems, but a new one has arisen. I can't launch the 4GB launcher, even with the argument provided in the guide.

If you are comfortable editing Windows system variables add the Fallout folder path to the Windows path in the environment variables section. Don't forget to restart Windows after you do. This has fixed the 4GB launched for me. I now run the 4GB launcher without the arguments after doing this.

Share this post


Link to post
Share on other sites
  • 0

If you are comfortable editing Windows system variables add the Fallout folder path to the Windows path in the environment variables section. Don't forget to restart Windows after you do. This has fixed the 4GB launched for me. I now run the 4GB launcher without the arguments after doing this.

Can i get a step by step on how to do that?

Share this post


Link to post
Share on other sites
  • 0

 

It may be a good idea to make a restore point before doing this.

 

First some required reading How to set the path in Microsoft Windows if you need it.

 

  1. Create a new plain text file on the desktop, call it “path backup.txtâ€.
  2. Open windows file explorer and navigate to the falloutNV folder. When there click in the address box and highlight the text and copy it. Paste this into “path Backup.txt. Mine looks like this:
    1. D:\Steam\SteamApps\common\Fallout New Vegas
  3. Click the start button and type “advanced system settings†without quotes in the edit box. You should see an entry in the control panel section. Click on it and it will open the advanced properties tab in the system properties window.
  4. At the bottom click on the Environment Variables button. Another window will open.
  5. In the bottom section, use the scrollbar until you see the word “Path†on the left side.
  6. Click on the path to highlight it and select the edit button below it. The edit system variable window will open.
  7. When it opens it should have “Variable value†highlighted. Right click there and select copy then hit cancel.
  8. I am doing this so you can see what the whole thing looks like and to make a backup if anything goes wrong.
  9. Paste this into your “path backup.txt†twice each on a new line and save it. Mine looks like this:
    1. C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Python27\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files (x86)\Windows Live\Shared
  10. On the second line add a semicolon and copy your fallout directory after it. The whole thing will look like this:
    1. C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Python27\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files (x86)\Windows Live\Shared;D:\Steam\SteamApps\common\Fallout New Vegas
  11. Save the “path backup.txt†file again.
  12. So all we need to do is add a semicolon with your FNV path to the variable.
  13. Back to the environment window and click the path and hit edit. When that opens hit your “END†key to go to the end of the text string. Add a semicolon and your fallout path. Like this:
    1. ;D:\Steam\SteamApps\common\Fallout New Vegas
  14. Hit OK three times and reboot your computer.

 

Clear instructions, worked perfectly. Thanks computer wizard!

Share this post


Link to post
Share on other sites
  • 0

I am glad it helped. I was hesitant to suggest this not knowing how computer savvy you are, but it does seem to help with the 4GB launcher problems we are seeing.

Share this post


Link to post
Share on other sites
  • 0

Doesn't seem to help unfortunately....now I get an error message stating "The instruction at 0x6abb8a9f referenced memory at 0x6abb8a9f. The memory could not be read...I know for certain it had nothing to do with the aforementioned instructions above since it was doing that before I attempted any of it. I've reinstalled my OS three times now and would rather not burn out my SSD....hopefully it's something stupid obvious that I'm missing.

Share this post


Link to post
Share on other sites
  • 0

When you did the path statement did you remove the arguments from the MO 4GB shortcut? Delete any arguments in the shortcut EX: -laaexe .FalloutMO.exe

Share this post


Link to post
Share on other sites
  • 0

Hello.  Sorry if this is not the place.. Using MO.  Love it.  Works for Skyrim across the board.  Dropped FNV4GB in my Steam common apps, Fallout New Vegas directory.  Same location as NVSE loader.  MO can see Fallout.exe, Fallout Launcher.exe, and NVSE Launcher.exe, but doesn't see fnv4gb.exe      When I look under modify executables in MO it does not give me the option of adding an executable.  Not sure if I am just missing the option to include another executable or if that functionality is not available, and MO should detect the .exe on it's own.

 

Does the above fix (Per you, Thane.  Nice to meet you btw) relate to this problem?  It seems that you folks are discussing a problem where the aforementioned 4gb launcher is available in MO but is not working.

Share this post


Link to post
Share on other sites
  • 0

MO will not detect that, you have to set it up yourself.

 

From the wiki, Guide:Mod Organizer - Third Party programs:

 

General application setup
  1. Click the gears Gear_MO.png button. This opens the Modify Executables window.
  2. In the Title field, type in what you want to call the application. This fills in the Title field.
  3. All the way to the right of the Binary field is a button with an ellipsis with a subtext of "Browse filesystem." Click it. This opens a window where we can browse to the program we want to run.
  4. Navigate to the folder where the program is installed and select the application. This fills in the Binary field.
    • If the program's files are located at the same location as the executable (e.g., TESV.exe is in the Skyrim directory, whereas Reproccer.jar is not in the Java directory), steps 5 and 6 may be skipped, as they would be redundant.
  5. All the way to the right of the Start in field is a button with an ellipsis. Click it. This opens a window where we can browse to the folder where the program we want to run is located.
  6. Navigate to the folder where the program is located and select it. This fills in the Start in field.
  7. Do you need the application to call another file, or input a custom setting? Use the Arguments field for any such needs.
  8. Do you need to overwrite the Steam AppID? Almost undoubtedly not, but if you do, you can check that option and type in the appropriate AppID in the field provided.
  9. Do you desire to close MO when you start the program? Only if you are launching the game, most likely. If you do, check the Close MO when started option.
  10. Click the Add button. This will add the application to your executables list.
  11. Click Close to close the dialog.

Note: Typical application setup does not require steps 5 through 9.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.