Jump to content
  • 0
Sign in to follow this  
Halde

I can't use the download function after (hopefully) a succesful update to 1.2.1 of MO

Question

Hi all!

 

Well the very long title basically says it all. When I attempt to download a mod, I get this message from Mod Organizer:

 

failed to download
https://fs-7.nexusmods.com/FS/Libs/Common/Managers/Downloads?Download&nid=100&fid=1000105927&ngn=12|2|3: could not open output fiile: C:/Users/<User>(ignore the text between these "()" I just wanted to stay anonymous)/Desktop/ModOrganizer/downloads/Hypothermia - DLC - IA Patchs Mergerd-53232-.7z.unfinished
 
I just picked a random mod, to see if I would be able to download with Mod Organizer(which is one the reasons that I updated in the first place, the other being able to update Mod Organizer through the integrated "Update"). 
What I did when I updated was:

The workflow is as follows:

  • Delete the following in your current ModOrganizer directory:
    • All files EXCEPT ModOrganizer.ini, nxmhandlers.ini, and categories.dat
    • All directories EXCEPT downloads, mods, overwrite, and profiles
  • Now download the latest archive(s) (There may be important optionals you need to install, so read the instructions.)
  • Copy the contents of the latest archive(s) into your ModOrganizer folder, overwriting all.

(Taken from https://wiki.step-project.com/Guide:Mod_Organizer_Advanced#Updating_Mod_Organizer)

 

Except I didn't delete first, I just directely overwrote everything in the folder with the 1.2.1 version of Mod Organizer(the !Beta! one) that I downloaded from the Nexus page. 

 

On another note. After this update, will I have to redo the FNIS and Skyproc patches? Because if I have to, at least the Skyproc Patcher is messing with me.

 

~Sincerely

 

Halde

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

So I've just went through the Mod Organizer "start up" logs(the notes at the bottom when you open Mod Organizer). I think two of these multiple errors might have something to do with it "localization file NMMImport_da-DK not found"While I suspect this is not the cause, just because Nexus(albeit it's NMM and not Nexus site) is mentioned I thought I'd post it. "QFileSystemWatcher: failed to add paths: C:/Users//Desktop/ModOrganizer/downloads"I suspect this is the one that is causing it. Now surprise surprise, I'm no Wiz at modding, pathing or computing in general. So if this is the cause, how to fix it? ~Sincerely  Halde

 The first message only tells you that MO doesn't have a Danish translation. I assume that's your system language hence MO tries to load it. No problem here, it uses English as a fallback. The second message probably has the same cause as the download problem, neither is the reason for the other.Both error messages tell you that MO can not open the directory C:/Users//Desktop/ModOrganizer/downloadsThat directory doesn't exist or MO isn't allowed to access it. Please double check that there isn't a typo in that path like a wrong letter in the user name or maybe your MO path on disk has a space between "Mod" and "Organizer"?

 

One more thing, though I doubt it would cause a problem: Does your username by any chance contain any funny letters not found in the english alphabet, like an Ã˜ ?

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

I always copy the new and betas of MO over my working install of MO. I have never had a problem doing it this way. As long as you do not overwrite the three files you mentioned you are good to go.

 

 

On another note. After this update, will I have to redo the FNIS and Skyproc patches? Because if I have to, at least the Skyproc Patcher is messing with me.

The update will not affect this. That is more a add or delete mod situation.

Share this post


Link to post
Share on other sites
  • 0

MO can't open the file it's trying to write to. This is most likely because the output directory doesn't exist or because MO has no write permission to the directory.

 

If MO was simply missing the "downloads" directory it would have created it, more likely something is wrong with the path "C:/Users//Desktop/ModOrganizer" (btw. / or doesn't matter)

Share this post


Link to post
Share on other sites
  • 0

Thanks all!

 

I will look into this in a bit, and reply back if magic happens or not.

 

~Sincerely

 

Halde

Edited by Halde

Share this post


Link to post
Share on other sites
  • 0

So I've just went through the Mod Organizer "start up" logs(the notes at the bottom when you open Mod Organizer). I think two of these multiple errors might have something to do with it

 

"localization file NMMImport_da-DK not found"

While I suspect this is not the cause, just because Nexus(albeit it's NMM and not Nexus site) is mentioned I thought I'd post it.

 

"QFileSystemWatcher: failed to add paths: C:/Users/<User>/Desktop/ModOrganizer/downloads"

I suspect this is the one that is causing it. 

Now surprise surprise, I'm no Wiz at modding, pathing or computing in general. So if this is the cause, how to fix it?

 

~Sincerely 

 

Halde

Edited by Halde

Share this post


Link to post
Share on other sites
  • 0

Thank you @Tannin! 

I can't believe that little space was so troublesome!

It's working fully now!

And thank you all for being so responsive!

 

~Sincerely

 

Halde

Edited by Halde

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.