Jump to content
  • 0
Sign in to follow this  
MisterSkilly

BOSS doesn't recognise MO mods anymore

Question

Hello!Today I felt like (after installing 2-3 new mods) running BOSS again. I ran it, and suddenly all of my mods got disabled (the ESPs in MO) and the log only found the DLCs and one or two mod I have put in the main skyrim folder. Now, that wouldn't be that big of an issue as I could easily recheck all mods, but the problem is BOSS sorted the ESPs by name. So now I don't have my original load order anymore, and thus crashing immediately.I've already redownloaded BOSS 2.2.0, but no luck. I've tried BOSS GUI.exe and BOSS.exe (through MO) but none of them work.This is what I get when I run BOSS.Help is really appreciated, since I'm really a noob when it comes to manually sort my load order (especially with around 100 mods to sort)Thanks! :)

Edited by MisterSkilly

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Try this for me:

1. Cut ModOrganizer.ini to your desktop (removing the ini and backing up at the same time)

2. Run Mod Organizer. MO settings will be reset.

3. Set up BOSS to run through MO and then run it.

4. Are the results different? Report back.

Share this post


Link to post
Share on other sites
  • 0

Never run BOSS outside of MO as it will not see the mods in your virtual directory. It will only see mod in your actuall Skyrim Data folder and there should be none if you are using MO correctly. I have had similar things happen, but not because of BOSS. In my case MO lost my mod load order for a profile. If this happens to you all mods in the left-pane will be unsorted and alphabetical. Unless you had a backup of your profile directory located in "{where ever you installed MO}/profiles" you will have to resort  and check all your mods for that profile. I maintain multiple profiles, they are for example built around Skyrim Revisited - Legendary Edition  (SR-LE) to which I may install additional mods while maintaining of pure SR-LE profile. If something goes wrong I can use that as a starting point. If not, you will have to recheck and sort all mods in the left-pane and doing so will active all the ESPs in your right-pane which you will see if you have plugins tab selected. Once done, running BOSS should sort you ESPs correctly.

 

Edit: Spelling/grammer fixes

Edited by DanimalTwo

Share this post


Link to post
Share on other sites
  • 0

Time to move to LOOT before a new play-through is my advice. I am using LOOT now, and while I don't like losing personal insight into mod ordering because of its black-box nature; I must say it's working wonderfully.

 

I have 190+ mods, with Frostfall, various armor/weapon compilations, SkyRe and Reproccer and other complications...so far in my test runs before actual play-through, there's been no issues.

 

Note: I did have to reorder some masters for 3 or so esp's via TES5Edit, but arguably that might not have been a real problem if I hadn't.

Edited by Kuldebar

Share this post


Link to post
Share on other sites
  • 0

Thanks! I'll try LOOT now, editing later if it worked.@DanimalTwo, as I mentioned multiple times in my original post, I'm running BOSS through MO, exactly like I've been running it before (when it worked..)Thanks againEDIT: Wow, LOOT sees the same files as BOSS. But I'm running them through MO (selecting LOOT.exe/BOSS.exe from the drop down list next to > Start)! And the mods (left panel) and ESPs (right panel) are enabled?!EDIT2: I guess that's an issue with MO/my setup, as why would BOSS and LOOT not see the plugins? And I'm still kinda frustrated that something alphabetically sorted my ESPs.

Edited by MisterSkilly

Share this post


Link to post
Share on other sites
  • 0
MisterSkilly, on 03 May 2014 - 1:08 PM, said:MisterSkilly, on 03 May 2014 - 1:08 PM, said:

EDIT: Wow, LOOT sees the same files as BOSS. But I'm running them through MO (selecting LOOT.exe/BOSS.exe from the drop down list next to > Start)! And the mods (left panel) and ESPs (right panel) are enabled?!

Wut? Is that a question? :O_o:

 

Yes, once you add LOOT to MO (just as you did BOSS, which I still have but no longer use)...LOOT will run, MO closes but LOOT will use your MO Profile Mod lists.

 

LOOT actually scans ESP file header info...so it's actually determining load order based on the actual records being edited (don't ask me how). So, unlike BOSS, which was based on crown sourced data sampling input, LOOT is mostly self contained with some notable exceptions hard-wired into it via a master list function.

Edited by Kuldebar

Share this post


Link to post
Share on other sites
  • 0

Uhm sorry, I don't quite understand that :(My MO profile should see the mods activated, as it crashes on savegame-load. Now, why doesn't LOOT see it? Do I have to force MO to write my mods on "MO Profile Mod lists"?Thanks again!

Share this post


Link to post
Share on other sites
  • 0

Uhm sorry, I don't quite understand that :(My MO profile should see the mods activated, as it crashes on savegame-load. Now, why doesn't LOOT see it? Do I have to force MO to write my mods on "MO Profile Mod lists"?Thanks again!

Well, you install LOOT, and just as you made a shortcut in MO to run BOSS, do the same for LOOT. Then run LOOT from within MO, it will see whatever is currently your active profile.

 

What's not happening?

Share this post


Link to post
Share on other sites
  • 0

Well, you install LOOT, and just as you made a shortcut in MO to run BOSS, do the same for LOOT. Then run LOOT from within MO, it will see whatever is currently your active profile.

 

What's not happening?

Oh, sorry, am I really that bad expressing what I'm doing? :D I'm running LOOT and BOSS through(within) MO, but it only sees the file in the real directory!And if that's a problem (for whatever reason, since it worked before) I don't have BOSS and LOOT in the skyrim folder..

 

EDIT: If you could chat in skype or something, nielswarriorcats is my name :)

Edited by MisterSkilly

Share this post


Link to post
Share on other sites
  • 0
MisterSkilly, on 03 May 2014 - 1:49 PM, said:

I'm running LOOT and BOSS through(within) MO, but it only sees the file in the real directory! And if that's a problem (for whatever reason, since it worked before) I don't have BOSS and LOOT in the skyrim folder..

 

Hmm, that's weird. When I run LOOT from within Mod Organzer, MO will close completely and the LOOT window will pop up. And LOOT "sees" all my MO installed mods, there must be something in your MO installation or settings that's different then mine. For the record, I don't have BOSS or LOOT in my Skyrim directory either.

 

Posted Image

Share this post


Link to post
Share on other sites
  • 0

It sounds like you did not correctly install or are not running your utilities though MO. This is the button that looks like a pair of cogs. This is where you setup your utilities. When running your utilities you should be selecting that utility from the pulll down menu in the right-pane to the left of the RUN button. If you are not doing this, you are running your utilities outside of MO and will only see your actual Data folder and not MO virtual directory. BOSS and LOOT do not need to be installed in your Skyrim folder, but MO needs to be set to correctly use them. This is where you use the cogs button to set them up.

From you image you have nothing selected from your pull down menu on the right-pane next to your run menu. You need to use pull down menu to select the app you want to run and then select the run button.

Share this post


Link to post
Share on other sites
  • 0

When I run BOSS or any other utility (except Skyrim, Skyrim Launcher and SKSE) MO locks itself up. I think this does look correct, right?I'll try reinstalling MO tomorrow, but my bed is calling now.Good night everyone! :) And thanks for your help!

Share this post


Link to post
Share on other sites
  • 0

Yes looks correct. Is MO set to run as administrator? By the way my wife is German too and most of my family.

Share this post


Link to post
Share on other sites
  • 0

You do realize you have the "Default profile" selected in the last image and "Skyrim Redone" in the first?

 

Edit: Spelling correction.

Edited by DanimalTwo

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.