Jump to content
  • 0
Sign in to follow this  
banky409

CTD Issue in specific cell

Question

I havent found anything through googling so im hoping someone here might be able to help me figure this out.  Everytime i enter solitudeexterior03 cell id 0000929D my game freezes and then ctd's.  I know its being caused by dyndolod.esp because it doesnt happen if i uncheck the esp and just leave all the textures from texgen and dnydolod active on the left pane of mo.  my most recent test had only Lanterns of Skyrim, ELFX and Dyndolod affecting that cell, and i still crash.  I have tried removing the cell from the dyndolod.esp with xedit and i still crash.  the only way that i dont crash in that cell is to not have the esp active.  I have absolutely no idea what else i can do.  As far as i know that is the only cell that does this as ive tested every live another life alternate start and run around the immediate surrounding areas of each starting location to test for crashes or abnormalities.  it doesnt matter how i enter the cell, if i coc to it, travel to solitude via carriage, or walk up from the docks, i crash as soon as i enter that cell but only if the dyndolod.esp is active. any help would be greatly appreciated. and as a side note, i dont think its an issue with anything else in my load order as i just recently got to around 100 hours on my last character with no other issues at all the entire playthrough.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

FAQ: Skyrim: ILS or CTD

A: If heap memory is not the cause of CTD see Docs\ DynDOLOD-README.txt for checking if a missing or invalid nif model used for dynamic LOD is the cause.

Share this post


Link to post
Share on other sites
  • 0

I've followed the instruction in the readme and have tested removing 3 nifs thus far and am still recieving the ctd, all 3 nifs that have been last in the log are out of dyndolod resources.  as best as i can tell, i screwed something up durring installation but i dont know what or how.

 

edit: im not sure this is relevant but i assume it could be, when i installed the resources mod i only selected high hrothgar window glow, desync birds of prey, dlc2 vvardenfell 3d plume, leaving the whiterun and solitude exteriors unchecked because of how many other mods i have that edit those areas.  was this wrong? should i reinstall with those checked?

Edited by banky409

Share this post


Link to post
Share on other sites
  • 0

The problem is unrelated to the installed options from DynDOLOD Resources.

 

Install crash fixes. It will have a pop-up message in case a missing/corrupt nif is the problem. It will note the form IDs of the reference and base record for easy lookup in xEdit.

Share this post


Link to post
Share on other sites
  • 0

i have crash fixes in stalled, on 2 occasions, neither related to this cell, i recieved a pop up with an error about a missing or incorrect nif, i dont remember exactly what it said as it was a while ago, but i resolved those issues and havent had them since.  with this issue, i recieve no pop up from crash logs, though i do get a log in the crashlog folder, but i dont understand what any of the data means, and what research ive done trying to figure it out has yielded nothing.  ive seen similar, though not identical outputs posted on the crash fixes forums, but could not find any that were given an answer, should i try posting the crashlog data there for help?

Share this post


Link to post
Share on other sites
  • 0

How certain are you about that exact cell? Could it be a neighboring one too? How quick after entering that cell is the CTD?

 

Turn on yellow line cellboarders with tb in console.

 

Try this:

 

In the persistent cell 0000D74 find the record with EditorID Tamriel_Firstborn_%18_24 and remove it. Test if this changes anything.

If not, find record with EditorID Tamriel_Minion_%18_24 (it is possible there isn't one) and remove it.

 

Let me know what happened for next steps.

Share this post


Link to post
Share on other sites
  • 0

I would say that I am 99% positive it is that specific cell.  If i coc solitudedocks01 and wander around the docks without heading up i wont crash, ever.  i can swim across to the otherside of the warehouse and go up the solitude skyway and head into solitude from there with now crash, then walk out the main gate and once im down the end of the path almost to the fast travel cart i will crash.  if i coc solitudeexterior03 i crash within a few seconds after the loading screen is done.  if i use cart travel to solitude, again i crash a few seconds after the loading screen is done.  and if i walk up the stairs from the docks, i crash either by roughly the time i get to katlas farm if i dont have solitude expansion installed, or if i do have solitude expansion i crash slightly before katlas farm.  and im not sure what wilderness cell is coming into solitude along the path from dragons bridge, but i also started from there (from dragonsbridge) and walked the entire road, upon getting roughly to the fast travel cart, i crash.  i think i have been pretty vigilant in my ingame testing to be confident it is that cell, though i cant say with absolute certainty as im not inside the game code (as cool as that would be).  i will try these steps and let you know what happens.

 

 

update: ill put my foot in my mouth really quick, for the first time ever i crashed along the road from dragonsbridge to solitude, decided to do the test after removing the first item from there, and i crashed within seconds after leaving the dragon bridge cell.  tried again from the docks, and crashed within second of leaving the docks01 cell.  so i guess im not positive that it is solitudeexterior03, but that its some cell between there and dragons bridge (though that was the only time that i have ever crashed nearing solitude from that direction prior to getting to exterior03

Edited by banky409

Share this post


Link to post
Share on other sites
  • 0

I have removed both of those items and am still crashing, though now ive tested twice and crash after leaving dragons bridge as well.  so my certainty that it was solitudeexterior03 is now completely out the window.

Share this post


Link to post
Share on other sites
  • 0

i guess im back to the drawing board on figuring out what cell it was, i dont know why it didnt crash from there before, other than improper testing on my end apparently.  if i can narrow down the cell with absolute certainty and then still cannot solve the issue, ill come back at that point

 

and also, thank you very much for the help Sheson, sorry for my lack of proper testing before posting, and if i were to ever have a firstborn, they would definitely be yours lol

Edited by banky409

Share this post


Link to post
Share on other sites
  • 0

Don't worry about it. As long as the problem is repeatable there are good ways to troubleshoot.

 

The idea is to remove everything from the worldspace tree and only keep the problematic record(s). Always keep a backup from the last step to go back to in case the problem went away.

Start by removing entire worldspaces that should have nothing to do with the problem. So everything but Tamriel.

Then remove the entire persistent cell, but keep all temporary cells.

Then either remove 50% of the persistent cell, again if problem goes away, go back to backup and remove the other 50% that still has the problem and so on.

If the problem is in the temporary cells, then remove everything but the area (can be about 21x21 cells - FarGrid size) you have the problem in and then do the 50:50 approach as well.

This goes relatively fast as long as the error is reproducible.

Share this post


Link to post
Share on other sites
  • 0

ok, thats what ive been looking for since this issue started, i troubleshooted and tried to figure it out the best i could, but im entirely inexperienced with fixing issues (though very experienced with creating them haha) i was never really sure exactly what steps to take particularly since i have no idea why its happening lol.  ill work on doing this today and see if i can narrow down at the very least the specific cell, and hopefully maybe even the specific record.  and luckily the error is very easy to reproduce since it happens 100% of the time lol.  thanks for the help, if or when i narrow down whats happening i may post back here to see what i can do about it going forward and hopefully its something that doesnt require manual editing in xedit every time i generate dyndolod lol.  but if it does at least ill know what and how at that point lol.  thanks again for the help Sheson.

Share this post


Link to post
Share on other sites
  • 0

So, im stumped now.  I have followed your instructions on troubleshooting this, so i removed everything under worldspace other than tamriel.  then removed the entire persitent tree, upon testing the crash went away.  so i backed up and did the 50% removal, i started by removing everything that was highlighted after loading into xedit, so the only records left in the persistent tree were the firstborn and minion % records.  tested and still crashed.  this is where things have me confused now.  i removed roughly half of the remaining records loaded into game, no crash.  Just to be as thorough as possible, i went back to the last backup, and removed the other half (ensuring that the first half was now all that would be active), and ive double and tripple checked now, with either half removed the crashing stops.  i made to sure to mark which record was the last removed for the first set, and the first removed for the second set so that i didnt mess up with a roughly half guess.  So from here, im not exactly sure how to continue, since having either half removed stops the crash.

Edited by banky409

Share this post


Link to post
Share on other sites
  • 0

Yes that seems indeed somewhat odd, but I am sorry, I forgot to mention something: The connection between the Tamriel_ShesonObject/Tamriel_Firstborn*/Tamriel_Minion* Activators with the other references.

 

The other references (*_DynDOLOD_LOD) only get activated when their firstborns/minions activators are still there, which in return require the Tamriel_ShesonObject DynDOLOD_MasterActivator. So it could be, that one half removed the an activator required to enable a reference causing trouble and then later you removed the *_DynDOLOD_LOD reference that is causing the trouble.

 

So, just keep all Tamriel_ShesonObject/Tamriel_Firstborn*/Tamriel_Minion* activators and only remove records including overwrites that do not start with Tamriel_* in their EditorID. Hopefully then results make more sense.

Share this post


Link to post
Share on other sites
  • 0

I just want to try and clarify this as best as possible.  I was going to try and add a picture of what im seeing in xedit but im a forum noob and yea, so im just going to type it out.  this is obviously not the entire entry, just the point where conflict records meet dyndolod unique records.

 

Form ID                 Editor ID                                 NAME

1E095C15                                                  KA_NorTempleExteriorRibFree07Snow [sTAT: 1E0A584D]

2100171E     Tamriel_ShesonObject         DynDOLOD_MasterActivator "ThouShaltBowToSheson" [ACTI:21000901]

21001720     Tamriel_Minion_44_%32      DynDOLOD_MinionActivator "ThouShaltBowToSheson" [ACTI:21000903]

21001721     Tamriel_Fristborn_44_%32  Tamriel_FirstbornActivator "ThouShaltBowToSheson" [ACTI:2100171F]

 

If im understanding correctly, do not remove any record from Tamriel_ShesonObject down, only removing the objects from the first entry i listed and all above it?

 

sorry just made an edit if youre already lokoing at this, originally listed the third entry wrong, its Tamriel_firstbornActivator - so i think i answered my own question, i should be leaving the first born activators and removing the dyndolod_minionactivators?

Edited by banky409

Share this post


Link to post
Share on other sites
  • 0

nvm, im a scrub and apparently didnt look closely scrolling all the way down....sorry ><.  im really new at this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.