Jump to content

Fix for First Person Performance Issue


Recommended Posts

After a recent update from skryim many people have been reporting issues with their performance in first person camera, a problem I had been experiencing myself. The problem is that, even in areas where the player is getting good performance with good framerates, a sort of stutterer or jitters can occur when doing a camera pan in first person view. In my case, all the jitters would instantly disappear if I switched to third person view, even if no other aspect of my performance changed at all. I looked all over the internet and for the most part nobody seems to have any idea what causes it or how to fix it. I haven't been able to fix the problem myself, but with a few driver tweaks, a skyrim.ini tweak, and a tool called "FPS limiter" I have been able to dramatically reduce the problem.


The problem seems to have been linked to two things; one is mouse acceleration, and another is vertical sync. Bethesda games in general have been notorious for mouse input lag, and it is mouse input lag that is cuasing the problem. The primary cultprit seems to be an ini setting that forces vertical sync in skyrim. This is a graphical setting that makes your graphics card wait for you monitor to refresh before displaying an image to the screen. This prevents visual artifacts, called "tearing" that can occur if the GPU sends the picture to the screen to early. This also prevent different bugs that can happen in skyrim with physics and particles. Disabling this setting would fix the mouse input lag for many people, unfortunately this setting is tied to so many variables in the game (such as weather, and NPC schedules, and the physics engine) that disabling this setting is not an option.



If you are having problems like I described, i recommend starting with this simple edit to your skyrrimPrefs.ini file. If you are using steam, these files should be located C:\Users\*username*\Documents\My Games\Skyrim folder.


Load up your SkyrimPref.ini file, and look for the following entry:


Set that entry to zero. Save and close skyrimPrefs.


This enntry, mouse acceleration, causes your mouse to move at different speeds depending on how much you correct with your hand. It can cause mouse movement to feel somewhat erratic and irregular. STEP recommends disabling it for that reason, and it can contribute to the stutter problem.


Now that you have finished this, go into your driver control panel. For ATI users this is the "Catalyst Control Center" for Nvidia users this is the "Nvidia Control Panel".


ATI users, go into "Advanced View" if prompted, and navigate to the tab called "3D application settings" under "Gaming". Scroll down to where it says "Wait for Vertical Refresh" and move the cursor all the way to the right so that beneath it says "Always On".


Posted Image


For Nvidia users, open up you "Nvidia Control Panel". Navigate to your 3D setttings, and then click on "Manage 3D settings". Scroll down to the vertical sync option, and set it from "use application settings" to enabled.


Posted Image


Some people have reported that forcing vertical sync in their drivers has helped their input lag. Enabling vertical sync in your drivers can shave a couple of FPS off your game, because your graphics card might have to wait a little while for the screen to refresh. However, the vertical sync in your graphics driver seems to be better than the one used by skyrim and might actually improve visual quality and reduce the instance of "tearing" in addition to lowering mouse input lag.


A note on triple buffering:


Many guides on the internet will recommend enabling triple buffering if you have vsync enabled. This can increase performance with vertical sync and further prevent further visual artifacts. Triple buffering also increase VRAM usage, which in a game like skryim especially can reduce performance, and it can also be linked to mouse input lag which is the problem you are trying to solve. You can experiment with it on and off, but I recommend disabling it for Skyrim if you have first person stutter problems.


Next you will need to go to skyrim.nexus and download a third party software called "FPS Limiter":



Download the program to your downloads file in windows, and then use a program like winrar and peazip to unpack the file into your data folders. You Skyrim data folder should be located in C:\Program Files (x86)\Steam\SteamApps\common\skyrim


*NOTE: For enb user and FXAA post process injector users. This will overwrite a file called d3d9.dll. This file adds directx 9 effects to skyrim, like enb effects and frame rate limit effects. A this point there is no way to use both; either unistall ENB/FXAA injector or don't use FPS limiter.


One of the files you will have copied to your skyrim director is a file called "antilag.cfg". Use notepad to open this file. Make the following changes to the file, then click save:






The FPSlimit parameter sets the maximum number of FPS your game will render. 60 is the most you can do with vsync enabled anyway. Setting it to zero will remove the fps limit, but what I have found is that when that number is set to zero the game will alternate between setting your FPS limit to 30 in areas where you don't get at least 60fps, and to 60 in areas where you do. This can cause massive framerate shifts which are very noticable. If you like you can set this number to 30, which will cause frames in skyrim to be rather consistent if you are regularly getting at least 30 fps, but for my personal taste I found setting it at sixty and letting my framerates naturally fluctuate felt the best.


The money item here is the "RenderAheadLimit" parameter. This parameter controls how many frames your graphics card keeps in its buffer before displaying to the screen. A higher number can increase performance and make frame drops less dramatic, but it can also cause mouse input lag problems. Setting this number to one nearly eliminates any sort of input lag but at the cost of a lot of performance. Setting the number to two you should notice no loss in framerates and a dramatic reduction in mouse input lag. I noticed at numbers greater than two some of my mouse input lag started to creep back, but framerate drops became less noticeable. You might try experimenting with different number there and see what works best for you.


Some people have reported issues with using FPS Limiter in their game. If you experience a dramatic loss in FPS (like down to less than 10), lag when accessing your menus, visual artifacting or a bug where you arrows don't immediately appear after firing them, these problems could be related to the mod. Makes sure to back up you data file before using this mod. Deleting antilag.cfg and d3d9.dll files should remove the mod from your game. 


Finally, for ATI users, you might consider setting your 3D profile settings to a custom skyrim profile. For instructions on how to do this, read this post on the skyrim.nexus forums.





But that didn't work, what else can I try?

  • Many people have had success with running the game in windows mode. You can use this free application to force skyrim into windowed mode and make it look better than the default windowed mode: https://skyrim.nexusmods.com/mods/4
  • Setting you FOV to higher numbers can make the effect somewhat less noticeable. In skyrim, click '`' to bring up the command prompt, and type "fov 85". If you don't like it, simply reload you save file without saving.
  • At the loss of a lot of visual quality, setting shadows to low and reducing view distance on objects has dramatically improved the problem in my case. This can be done as a last resort.
  • Also, this tool in general increases performance using a variety of techniques to reduce the game resolution without you noticing. If you are struggling for performance this can increase your FPS and reduce lag: https://skyrim.nexusmods.com/mods/15123
  • Some people have claimed to have success by making the following ini tweaks to the skyrim.ini files. These changes are NOT recommended, but might be worth a try:




DO NOT USE THESE MODS. As of patch 1.4 these mods are no longer necessary. I repeat, do NOT use these mods as they can mess up your system and don't work anymore.



This mod used to help people, but patch 1.4 improved performance in Skyrim, and now nearly everyone has reported better performance without this mod.


4GB Address Patch:

As of patch 1.4 Bethesda has fixed the very issue this mod fixes. Some people have reported problems using this in their game. It isn't necessary any longer.



This issue continues to be an ongoing problem, and my guide only helps, but does not eliminate that problem. If you stumble upon a better solution please share it with us.


Hopefully though you found something to help you here. Good luck!





Removed recommendation to disable vsync via skyrim ini tweak

Added Recommendation for FPS limiter

Under optional fixes, added papyrus edits

Fixed formatting issues, spelling, grammer, and reordered some things.



Published guide

Link to comment
Share on other sites

Unless I'm mistaken, aren't those INI settings already in STEP? Also, if you're still using SkyBoost or the 4GB patch this far along, you've probably got bigger issues when it comes to modding your game (time for a re-install!).


I mostly wanted to post to remind you: red looks hideous! Stop it :P

Link to comment
Share on other sites

I should have posted this in the ini section. I apologize, didn't see the sub forum.


I recommend NOT using those mods. If its ugly good, I want people to read that part.


Disabling vsync is ok if you enable vsync using another profile. The problem with disabling vsync in skyrim is it cause glitches if you exceed 60fps, not that there is anything special about how skyrim implements its vsync.

Link to comment
Share on other sites

Disabling vsync is ok if you enable vsync using another profile. The problem with disabling vsync in skyrim is it cause glitches if you exceed 60fps' date=' not that there is anything special about how skyrim implements its vsync.[/quote']

No it's not.


There are a number of issues that cannot be fixed by limiting the fps or by using external vsync.



Link to comment
Share on other sites

I should have posted this in the ini section. I apologize, didn't see the sub forum.


I recommend NOT using those mods. If its ugly good, I want people to read that part.


Disabling vsync is ok if you enable vsync using another profile. The problem with disabling vsync in skyrim is it cause glitches if you exceed 60fps, not that there is anything special about how skyrim implements its vsync.

Use bright orange or a bright red, dark red is terrible.  Please be sparing with it, one line only and no full caps.  Please read the posting guidelines.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.