Jump to content
  • 0

MO with Linux?



Hi everyone,


I have tried searching the forums for an answer, but I couldn't find anything, so here goes:


I have tried to install MO on my linux pc with PlayonLinux (POL), but it doesn't "recognize" the game and DLC files. Firstly I installed Steam with POL, then manually installed SKSE into the POL-Skyrim folder. Then setup SKSE to start as an .exe, so Skyrim will always start with SKSE loader. So far so good.

But then when I installed MO problems started.

First I installed into it's own folder in the POL-Skyrim setup. After starting it up, it did immediately recognize SKSE. but when I tried to start skyrim, it said no game files and dlc were installed.

Second, I installed MO through POL into it's own "virtual drive" and pointed it to the Skyrim install. Again it recognized SKSE immediately, and again it said no game files and dlc were installed.

btw, both Skyrim and MO were setup as 32-bit.


So, I am kinda stuck at the moment. My questions are: Does anyone know how to set up MO with Linux? Is this even possible?


Thanks in advance :)


- Moo.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

What are your settings in the MO environment?

Where are you pointing MO to look to find the "installed" mods?


MO will need, I assume, to be allocated a certain amount of space to run and use inside the POL environment, this will need to include enough room to install the mods that it manages. Are there settings in POL to set the disk space for each tool installed?

Link to comment
Share on other sites

  • 0

Thank you GrantSP and Tannin for the replies.


I did manage to get MO installed without (obvious) missing dependancies AND this time it does recognize the game files and DLC. Woot... progress. I installed MO into the Steam folder on the POL virtual drive.

However I can't start Skyrim with the SKSE_loader through MO. I can however install mods now with MO.

Downloading from Nexus doesn't work. Or rather, it starts to download, but then gives a download error. But this could potentially be solved by manually downloading mods from Nexus and then installing through MO.


I set up Wine to emulate Windows 7; both Skyrim and MO are installed on a 32-bit virtual drive with POL; It uses Wine version 1.7.33 (x86).


Despite Tannin's "warning", I will keep tinkering with it, to see if there is a way to get MO to work in POL/ Wine. I shall report back with progress or failure.


- Moo

Link to comment
Share on other sites

  • 0

I realize this is an old post, but this will help with google search hits. I think I have gotten this working. Here are the steps I took from the very initial install:


1. Create new 32 bit virtual drive in POL

2. Assign Wine version 2.4 (if you don't have it, you'll need to manage your Wine versions and add it)

3. In the POL configuration window, select the virtual drive, and click the Miscellaneous tab

4. Choose "Run a .exe ..."

5. Select the steam client exe you've already downloaded.

6. Login to steam, and install Skyrim from there (wait for this to complete)

7. Download ModOrganizer install exe from nexus mods and do steps 3-5 again

8. I don't remember if it created a shortcut, but if not, do so under configuration > your vrt drive > General > "Make a new..."

9. I had to bypass the tutorial by closing out and restarting. It gets stuck because I couldn't get the "Download with NMM" to work. I download archives manually and then add them into MO.

10. Before restarting, manually install SKSE and Sky UI (MO won't do these)

11. After restarting, you should see a drop down next to run button that has defaulted to SKSE. There is also a "Skryim" and "Skyrim Launcher" link. Click Edit at the top to change the SKSE one.

12. Set the path and working directory for SKSE

13. Launch by selecting SKSE and then hitting run.


Here's what I have loaded so far that appears to be working:


Sky UI

Campfire + Frostfall

Alternate Start




I haven't actually started playing yet, other than to just accept the default Nord in Alternate Start and then verify that the MCM menus that should be there are. So far so good.


Some considerations:

On a brand new steam install of Skyrim like I did here, you should probably run the skyrim launcher from POL first to set your video settings. Note that you will get a crash error in POL, but the launcher still loads just fine.

Also, the more mods you have loaded, the longer it will take SKSE to start up, and it will appear to do nothing until then. Be patient.

When editing mod load order, once you start dragging with the left mouse button, you can't let go, even by letting go of the left mouse button. Get it to where you want, and then right click.

One last thing, with all the official DLC loaded in Skyrim (either DG or DB is the culprit), the game will freeze if you try to quit to desktop. I work around this by Ctrl-Alt-F1 to a console, and run this command:


ps -ef |grep TESV|grep -v grep|awk '{print $2}'|xargs kill


Ctrl-Alt-F7 to get back




Other than that, this appears to work. Happy modding.

Edited by fischer98
Link to comment
Share on other sites

  • 0

Thanks for info fischer98, helped with research.


So far I got:


MO and Skyrim under Wine 2.11-staging work out of the box. As in so far so good.


MO has minor glitch when moving stuff in the list. Mouse out and back in for quick refresh.


To get full functionality with MO nexus installer (NCC?) you will need .NET 4+ and 2010 distributable. POL scripts are kind of broken. Run POL dotnet 4.0 installer. It is sufficient. If you try to run POL dotnet 4.5 you will suffer.


To get FNIS to work copy tools folder to actual Skyrim install Data folder. Should remove "File not found" error.


To get skyproc to work get jre-8u5-windows-i586. Do NOT use latest. It will fail. It installs on 2.11-staging without any problems. May not be true for earlier versions. Pre wine 2.0 partially fails with errors and a PITA workaround is needed.


Files dumped in overwrite folder make bad things happen if you move them using MO or wine file manager. When Overwrite is created, create new mod and move it using Linux file manager inside wine bottle to be safe. Delete it every time you generate new files.


Still working on wrye bash and ENB solutions. From the look of it use of ENBs is problematic but possible.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.