Jump to content
  • 0

Quests dialogue options not appearing



So, been playing some STEP recently. First off - great job, guide is getting more followable with every iteration. Only thing that had me a bit confused this time was the DynDOLOD things I discussed in that thread.

Anyway, after playing for a few hours (well, like 50), I started noticing that certain quests wouldn't show up. As in - the quest giver doesn't have the dialogue option that starts the quest (or not being able to enter dialogue at all in the cases where that's their only dialogue option).

At first I thought it was just minor "radiant"-ish quests (these are the ones I remember off the top of my head):

¤ Carlotta & Mikael
¤ Amren's family sword


In Amren's case, I saw him discussing with his wife, then when he walked off, he commented about mercenary work, but didn't offer the quest (could still train one-handed etc though).

Both the above cases solved themselves after a while (like, leaving, doing a few other quests etc.)

However, I also had the same problem with "Book of Love" from the temple of Mara in Riften (couldn't open dialogue with Dinya at all, at any time of day). I tried on many occasions on two different characters, but no success.

Being somewhat used to Bethesda games, I thought -ah well-, and force started the quest using command "setstage t02 10". Quest started as expected and the objective showed up in the log (not on the map or in world though, curiously), however upon reaching the NPC in Ivarstead, she also lacked the appropriate conversation options. Moving the quest on further had the same results with all other NPC's involved.

I run a complete STEP install (just removed the bow sounds and dead body collision), and the only mods that come to mind that would modify this are USKP, Choice is yours and Better Quest Objectives. Looking around, I find some people reporting similar issues, for example here (not a STEP user though, I believe):


Any idea what I can do to find the cause or fix this?

Again, love the guide and the work put down.

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I have added a very small number of quests (none having anything to do with quests or dialogue and most actually getting merged into the bashed patch). These mods were added after the bug started happening though, so I wouldn't attribute it to them.

I've played in the region of 1000 hours of Skyrim over the years, at least half of them with STEP in various versions and this is the first time it's happened (but it happened on several characters, so there's something for sure...).

Is there any way to see what installed mod touches those specific dialogue options? Or should I just do a clean reinstall and save myself the trouble? :P

Link to comment
Share on other sites

  • 0

I checked, doesn't seem to be anything changing the initial dialogue topic (some of the ones later down the line of conversation had some edits, but the first ones are just Skyrim.esm). I also can't see any condition that must be satisfied to see the dialogue topic (that said, I'm not that used to digging in these things). Dinya Balu (quest giver) herself wasn't modified in any way by any plugin. Dialogue topic screenshot below:


Link to comment
Share on other sites

  • 0

Validated game files and deleted all old save files. Last character I started I started from the Helgen save of the one before, dunno if that's why it mysteriously happened on both characters. Anyway, seems to work fine now. Thx for the guidance.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.