Jump to content
rhodsey

Just finished SRLE +REGS + PerMA - Need a little advice

Recommended Posts

Hello all

 

I've just finally finished getting a stable(ish) load order for SRLE +REGS + Perma. Unfortunately REGS isn't as up to date as SRLE when it comes to merging/load order so took a while.  Then the Perma Pack is just a list of mods.  Managed to get it installed following the video guide on the Perma Patches Page (very similar to the post that popped up here a few days ago).

 

I've essentially just ran SRLE as configured with just using Medium for DYNDOLOD than high to save a bit of VRAM.  I've got a GTX 970 and most of the time I'm hitting my set limit of 34fps (apart from in JK's Whiterun wher it's around the 20 mark but this is known about from what I can see)

 

Regs is as is apart from the gameplay altering mods and I followed the guide on the ETAC forums for merging the ETAC patches.

 

On top of that all I've added is the ESF companions mod and a few companion mods (arissa etc).  Also added smart cast but I think thats it.

 

I can provide a copy of my load order if someone can let me know a simple way of getting it out of MO in a format I can paste to you without writing it out by hand?

 

Couple of questions

 

I actually finished SrLE just before Neo updated Vividian to Beta 7.  However I've gone back and amended it retroactively so I'm pretty much up to date with the guide as of 03/05.  And while outside the torches give off a nice natural glow I'm finding indoors while candles give off a warm yellow natural glow torches seem to be giving off a very red light making even the palet of Nords look like a Redguard.  Is there a setting I need to tweak or something I've missed (I deleted the "light" records from the ELE ESP as advised).

 

Also while my load is stable(ish) and will boot up and play for 30-40 minutes at a time sometimes wth no issues eventually it will crash for no obvious reason.  usually caused by travelling in the open world or moving between instances.  I tend to find if it crashes travelling through a door if I load the save I'm making ebfore I do then it will go into it fine.  Only ont he 3rd or for move between instances does it crash again which leads me to think that maybe its some sort of script error and its building up over time then clearing the buffer when I reboot? (very layman terms... Just thinking of it from a general IT perspective).  Is there anything I can do to try and isolate exactly what is running that might be causing the problem?  Or even if its just too many scripted mods going together?

 

Linked to the above my total active ESPs/ESM's is 242 which, while not at the 255 limit is fairly close.  As I say I've merged a few mods I think are safe to merge (choice is yours, ETaC following the guide and a couple of others).  Could my random crashes be caused by being so close to the 255 limit?  I've read before that some users can be hit earlier than this depending on their system specs?  If so should I be looking to merge more mods and can users advise what mods are mergable without too much work? (I've spent that long modding it already I just want to get on and PLAY the game... Perverse I know)

 

MY specs are below:

 

i7-2600 3.4ghz 

16gb RAM

GTX 970

 

Skyrim is also installed on an SSD

 

 

Share this post


Link to post

For the crashing, I think I know why.

Install memory blocks log and then after the crash happens share the last line.

Share this post


Link to post

For the crashing, I think I know why.

Install memory blocks log and then after the crash happens share the last line.

512.  which is strange as I've got DefaultHeapInitialAllocMB in SKSE.ini set to 768 as per Neo's guide?

Share this post


Link to post

512. which is strange as I've got DefaultHeapInitialAllocMB in SKSE.ini set to 768 as per Neo's guide?

512 + 256 = 768. Allocate more memory as your hitting the cap

Share this post


Link to post

512 + 256 = 768. Allocate more memory as your hitting the cap

Just tried that as per the Memory Log nexus page while I was waiting for a response. but If I increase the size by 128 as he recommends (to 896 say or 1024) then Skyrim crashes on startup before I even get to the menu screen.  If I put it back down to 768 then it works loads but obviously crashes again.  Is there a rule for how much to increase by which is safe?

 

EDIT: to say I've also tried increasing it by a smaller amount (changed 768 to 800) and still Crash on startup now.

Edited by rhodsey

Share this post


Link to post

Do you use an ENB or ENBoost? If so, is ExpandSystemMemoryX64 in enblocal.ini set to true or false?

 

Warning: It has been reported that this feature can conflict with "Sheson's Memory Patch 3.0" (now included with SKSE) by causing Skyrim to crash if the memory patch fix is used to increase Skyrim's initial heap allocation (Block 1 or DefaultHeapInitialAllocMB in skse.ini) higher than 512MB (or 768MB for some). Therefore, if using the Sheson Memory Patch fix (either standalone or with SKSE), it is recommended to set ExpandSystemMemoryX64 to false.

 

The same guide also warns against using EnableUnsafeMemoryHacks in conjunction with sheson's memory patch. My game consistently crashed on startup until I set ExpandSystemMemoryX64 to false.

Edited by Harpalus

Share this post


Link to post

Do you use an ENB or ENBoost? If so, is ExpandSystemMemoryX64 in enblocal.ini set to true or false?

 

 

The same guide also warns against using EnableUnsafeMemoryHacks in conjunction with sheson's memory patch. My game consistently crashed on startup until I set ExpandSystemMemoryX64 to false.

You sir (or madam) Get my Second born (since I have to give my First born to Sheson apparently...)!

 

Disabling that lets it boot with a higher memory and I managed to get much further than I normal do (I got a crash at pretty much the same area approaching whiterun).  I got an ILS going into whiterun proper so upping the SKSE to 1024 since I hit the cap again.

 

Many Many thanks all for the help I was pulling my hair out.  Is there a hard limit on how much I should allocate before I should stop and reduce modload instead?

Share this post


Link to post

Man REGS must hurt on memory, even with DynDOLOD on High my block 1 doesn't even get to 350...

Share this post


Link to post

Man REGS must hurt on memory, even with DynDOLOD on High my block 1 doesn't even get to 350...

Yup.  Think it's all the extra stuff ETAC puts in (unsure if scripts get added in there too but Perma might be part of that)  In the end I have it set to DefaultHeapInitialAllocMB=1280 (which might be too high.. It crashed at 1028 and I skipped 1152).  And it seems stable now.  Admittedly I just crashed but that was me being lazy and doing a quick load instead of restarting

 

Do you have any Idea on the interior torches giving off a red glow instead of the Yellow you get outside?  Or is that the way it's designed?

Share this post


Link to post

Infact further to my lighting question I've noticed that it's extremely dark underneath overhangs outside buildings (e.g. the shops in Whiterun).  even if there are braziers there they don't seem to give off any light. Also noticed the same with the Forge in Riverwood.  I didn't have Vividian 6 long enough to know if this is something with Beta 7 or if I've done something wrong?  Is this normal?

Share this post


Link to post

Can you provide a location and picture for me? I'm not at home until late in the evening to check things out.

Share this post


Link to post

Sorry Passed out last night only just seen your message.  Few screenshots below (hopefully this works!):

 

post-881-0-86852600-1430807128_thumb.jpg

 

This is outside Belefors in Whiterun at 2 in the afternoon.  As you can see its so dark under the awning you can't actually see an NPC's face if chatting there.  Brazier gives off a little light but doesn't have any effect ont he surroundings 

 

post-881-0-71648900-1430807203_thumb.jpg

 

Same spot at midnight.  You can see the brazier giving off a tiny bit of light but not a realistic amount for its location and size. (Indeed the entire of Whiterun is pretty much pitch black unless you are stood RIGHT next to a lightsource)

 

post-881-0-23732200-1430807323_thumb.jpg

 

The forge in riverwood.  as you can see there is zero light emitted from the Forge the entire area is pitch black (again if I'd turned around riverwood would also be completely pitch black unless RIGHT next to a lightsource.

 

One more to follow as too many attachments for one post apparently.

 


post-881-0-58293500-1430807577_thumb.jpg

 

And an example of the red light I was talking about.  this torch is in helgen keep (alternate start version if that helps) but I get a very reddy glow in general indoors most places.

Share this post


Link to post

that looks like the old Relight skyrim / ELE issues, where alot of lights give out a red light! Soemthing is defenitley wrong there.

Just for the testing sake, there is a ELE fallback in the installer and a relight skyim patch. Even if you do not use Relight skyrim please install those  (ELE Interiors) instead of ELE lite and see if that helps.

Share this post


Link to post

that looks like the old Relight skyrim / ELE issues, where alot of lights give out a red light! Soemthing is defenitley wrong there.

Just for the testing sake, there is a ELE fallback in the installer and a relight skyim patch. Even if you do not use Relight skyrim please install those  (ELE Interiors) instead of ELE lite and see if that helps.

OK just tried that.  No difference.

 

To confirm how I did it I remerged all the vividian ENB's again.  I also initially merged the two ELE ENB's and named them to ELE_Legendary_Fs_Wt_Lite.esp (just to help with masters on my existing patches... didn't want to spend hours remaking them just for a test).  And two screenshots taken on the profiles showed zero difference.  There was also no light being given off by forges etc still.

 

I also tried with the two ELE unmerged (having to disable various patches like SR conflict resolution etc) but again no difference.

Share this post


Link to post

Really odd, here is a screenshot from outside Arcadia's in my game at midnight for reference.

 

Arcadias.jpg

 

And here are two shots at Belethors... 2pm and Midnight.

Belethors2pm.jpgBelethorsMidnight.jpg

Share this post


Link to post
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.