Jump to content
  • 0
Sign in to follow this  
scissorhands

SKSE won't work with MO

Question

Hello,

 

I've been trying to get SKSE setup with MO. Everything's fine, except for one thing; when I try and run the SKSE_loader.exe through MO, I get a message saying "failed to create tweaked ini: The system cannot find the file specified." and the exe doesn't run. I've been unable to find anything mentioning a problem like this. Can anyone tell me what the problem might be?

 

Thanks in advance  ::):

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

well i finally Fixed it by deleting the %LOCAL%\Skyrim files dunno why but that did the trick. now i can run Skyrim through the loader and MO. sorry i just thought in the beginning that MO was like a better version of NMM(which it is) the thing i got used to was that NMM also changed the Vanilla Load order. anyway tnx for the help guys!

Share this post


Link to post
Share on other sites
  • 0

That doesn't sound like an error message generated by SKSE. Create a basic profile with no mods other than the vanilla plugins and start from there.

Share this post


Link to post
Share on other sites
  • 0

That doesn't sound like an error message generated by SKSE. Create a basic profile with no mods other than the vanilla plugins and start from there.

 

It definitely is SKSE. It starts fine when launching through the default skyrim launcher (though it does CTD shortly afterwards).

Check here.

 

I've looked at that page already, and I've done everything it says.

Edited by scissorhands

Share this post


Link to post
Share on other sites
  • 0

You ran Skyrim outside of MO to create your initial Skyrim.ini and SkyrimPrefs.ini? What operating system and anti-virus software are you using? If you have Trend Micro anti-virus, disable and trying running again. Where is MO installed? Are you running MO to "Run this program as administrator"? You made sure your SKSE.ini is not SKSE.ini.txt and is located in your 'MO\mods\Skyrim Script Extender\SKSE\' directory?

Share this post


Link to post
Share on other sites
  • 0

You ran Skyrim outside of MO to create your initial Skyrim.ini and SkyrimPrefs.ini? What operating system and anti-virus software are you using? If you have Trend Micro anti-virus, disable and trying running again. Where is MO installed? Are you running MO to "Run this program as administrator"? You made sure your SKSE.ini is not SKSE.ini.txt and is located in your 'MO\mods\Skyrim Script Extender\SKSE\' directory?

My operating system is windows 8.1, my anti-virus software is iobit malware fighter. How do I check where MO is installed? The file containing it is on my desktop. I tried running MO as admin, didn't make any difference. The SKSE.ini is .ini and not ini.txt, and is located in the right place. The initial Skyrim.ini and SkyrimPrefs.ini files were created long before I installed MO, unless they need to be re-created for MO to work? I don't know what else to tell you to be honest.

Share this post


Link to post
Share on other sites
  • 0

well its really annoying that i cant start SKSE through a direct shortcut. everytime i load a save or create a new one my game wil crash when he loading screen ends. this only happens when i launch through my direct SKSE shortcut. however launching through MO works fine. anyone knows how to fix this? otherwise im just gonna use NMM.

Share this post


Link to post
Share on other sites
  • 0

You're supposed to run it via MO. That's the idea. Running SKSE via a direct link to the SKSE Launcher wont run the MO virtual file system.

 

Make a shortcut to MO, load up MO via that and then run SKSE via MO.

Share this post


Link to post
Share on other sites
  • 0

well its really annoying that i cant start SKSE through a direct shortcut. everytime i load a save or create a new one my game wil crash when he loading screen ends. this only happens when i launch through my direct SKSE shortcut. however launching through MO works fine. anyone knows how to fix this? otherwise im just gonna use NMM.

With MO you have to start SKSE through MO. If you are starting without MO, your are not using SKSE support files or INIs if you installed SKSE correctly through MO and you are not using the Skyrim.ini or SkyrimPrefs.ini for your MO profile. Any of the mods you installed with MO are not visible outside MO's virtual file system (VFS). If your game is crashing on startup, more likely then not you have missing masters, but this is normal because your actual Skyrim directory should be clean of mods other then the 3 SKSE files (*.exe and *.dll) or ENB files. Vanilla Skyrim should start normally outside MO.

Share this post


Link to post
Share on other sites
  • 0

There is no message line in the SKSE code advising: "failed to create tweaked ini: The system cannot find the file specified."

 

That looks like it is a message from your OS telling you the file that is pointed to by either that shortcut or a parsed commandline switch for the specific program isn't where it is told to be.

Since you state you don't know where you installed MO, I'm assuming you haven't set the settings correctly either.

 

MO will, if you used the installer, most likely be found as a sub-directory of the game you are modding, in this case Skyrim.

Look in: C:\Program Files (x86)\Steam\SteamApps\common\skyrim\

You should see the MO folder there.

 

You will need to have extracted the executable from the archive and set it to run from a folder that is permanent, not a temporary one created when viewing the archive. I mention this because users have before posted here stating 'such and such' doesn't work when in fact they hadn't even installed MO!

Share this post


Link to post
Share on other sites
  • 0

well its really annoying that i cant start SKSE through a direct shortcut. everytime i load a save or create a new one my game wil crash when he loading screen ends. this only happens when i launch through my direct SKSE shortcut. however launching through MO works fine. anyone knows how to fix this? otherwise im just gonna use NMM.

MO has a command under the 'Run' button called: Create shortcut.

Select SKSE in the dropdown menu next to the 'Run button, click the 'Create shortcut' option and choose 'Desktop'.

This will create a desktop shortcut that runs MO with SKSE as the option and immediately starts the game without running the MO GUI.

Share this post


Link to post
Share on other sites
  • 0

well i tried that but it still crashed. i went ahead and deleted MO from my PC but it seems i just cant run skyrim outside of MO.

Share this post


Link to post
Share on other sites
  • 0

If you can't run the game from outside the MO environment then you have much deeper issues at work here.

Deleting the MO installation can have absolutely NO impact on how the base game will, or will not, run. You will need to fix those problems before trying to get MO to work for you.

 

If your game is not a legitimate and correctly installed game then we will not be able to assist you.

Uninstall it an start afresh. Make sure the vanilla game works properly then add SKSE. Likewise ensure the game works when started from the SKSE loader. IF that works then install MO according to the instructions in the wiki, follow the link at the top of the page, and then start the SKSE+game from MO.

Share this post


Link to post
Share on other sites
  • 0

Make sure the directory where MO is installed had been set up with Admin permissions. This is in the Skyrim Installation Guide. You can find that guide near the top of the STEP Guide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.