Jump to content
  • 0
Sign in to follow this  
kevkiev

Problem loading SKSE with MO

Question

I'm just switching to MO from NMM, and am following STEP as I've just reinstalled Skyrim after not having played for a couple years.  I'm at the start, and trying to install SKSE.  After copying the .exe and 2 .dlls into the game directory, I followed the instructions to install the scripts but when I click on "manual" (after clicking the archive button) I get the red message "No game data on top level", rather than the green "Looks good" as mentioned in the detailed instructions.  That happened when I choose the full 7z SKSE archive, and also afterwards when I just archived the "Data" folder after extracting the files from the full SKSE 7z.  (I thought maybe that error message meant that there was no folder called "data" on the top level.)  Can't figure out what's wrong.

Edited by kevkiev

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Inside the original SKSE archive the first folder is \skse_1_07_01, not Data\, so in the manual install dialog box you will need to expand the folder and set the data folder manually as in this image:

YTHx9Dv.png

Right click on the Data\ folder immediately below the skse_1_07_01\ folder and choose: Set Data Directory

 

This will install only the files under that folder, ie. the scripts, and nothing else. 

Name it whatever you want and activate it in the left-hand pane.

 

You are now set to go with SKSE.

Follow the links at the top of this page to the Mod Organizer wiki and have a read through, it will be necessary as MO does things a bit differently and many new users have some trouble coming to grips with it.

 

EDIT:

ninja'd, again.

Edited by GrantSP

Share this post


Link to post
Share on other sites
  • 0

You occasionally might have to set Data files more than once. If you're using the full archive, that may happen. 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply but, sorry, I'm not sure what you mean by setting a Data file.  The red message appeared when trying to install via the full archive, and when I tried installing a 7z archive that had only the "data" folder from the (extracted) SKSE download.

 

 edit: If you meant just try again a few times, I've done that.  A buncha times with both the archives I mentioned. :(

Edited by kevkiev

Share this post


Link to post
Share on other sites
  • 0

When you are at the point when you first open the archive you will see a top level folder called skse_1_07_01. Click the triangle to the left of it to reveal sub folder and files. You will see a Data folder. Click on the Data folder once, right click and select "Set data directory" and you will have the green looks good. Click OK and activate the new mod.

Share this post


Link to post
Share on other sites
  • 0

Aha!  Thanks GSDFan, and especially GrantSP for laying it out in such detail.  I didn't realize I was supposed to... well, never mind ... :P   Sounds like a readthrough of the wiki is indeed a good idea.

Share this post


Link to post
Share on other sites
  • 0

No, I meant right click on the archive, use 'Set Data Directory' option. As the little start up tutorial MO gives you suggests when this sort of situation occurs.

 

This is commonly called 'Setting A Data Directory'. You'll likely have to do it a few more times on your journey.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.