Jump to content
  • 0
Sign in to follow this  
Sarcasm

FNIS Animations Do Not Work When FNIS Launched Via ModOrganizer

Question

As the title says, no matter what I do, I simply cannot get anything generated by FNIS to work in game. I've tried every single thing I can think of and every thing I can find on Google searches or searches of this forum. I've run FNIS in many different ways through Mod Organizer but all of them have the same result: T-pose with all FNIS-specific animations.

 

- Tried adding FNIS to the Mod Organizer executable list via the Gears button on the left side. No matter what I did, it would not add it. It would add in the Gears window, but then once I closed to window it was not in the drop-down executable list on the right side. 

 

- Added FNIS directly by finding it in the Data tab /tools. It stayed in the right side executable drop down and I could launch it and run it. Turned its overwrite into a mod as instructed, and none of its animations work in game. T-pose for all FNIS animations.

 

- By adding GenerateFNISForUsers.exe directly to the executable list through the data tab, the shortcut's binary points to 'cmd.exe' (the command prompt) rather than 'GenerateFNISForUsers.exe ' as it does if added through the Gears executable button on the left side. I'm guessing these are functionally equivalent, but even after editing the binary to point to GenerateFNISForUsers.exe it still changed nothing. T-poses.

 

- Ran FNIS directly through Data tab by finding \tools\GenerateFNISForUsers\ and right clickong on GenerateFNISForUsers.exe and clicking Open/Execute to run it directly from Data. T Poses.

 

- I feel I should add, I'm not sure if it's significant, but it's something to point out. When FNIS is run through Mod Organizer it appears to "freeze up" for much of the process; clicking on the window while it's generating comes up with a Not Responding message. It's still responding, if I wait it finishes. But this does not happen when run outside Mod Organizer. Again I don't know if it's significant but Windows seems to think FNIS is not responding for much of the process while it has no such misconceptions when run outside Mod Organizer. It also takes several times longer to finish running through Mod Organizer, whereas outside in a custom directory it completes in only 2 or 3 seconds.

 

- I am using XP32 and a custom race. I have the top two check boxes (Gender Specific Animations & Arm Fix) checked and no others. I'm using the same XP32 skeleton on the custom race as the normal races, I just copy pasted it. I get T-poses for all races - custom and vanilla. I'm using sword sheath on back on XP32, if that matters at all.

 

I cannot find a way to fix this and make FNIS animations work when generated via Mod Organizer. A Google search turned up a "solution" - more of a workaround than a solution - on the Steam forums:

 

1. Extract FNIS to a custom folder outside Mod Organizer.

 

2. Extract all animation mods that require FNIS to that folder.

 

3. Run GenerateFNISForUsers, ignoring the obvious warning that no game directory was detected.

 

4. Once complete, zip the custom folder up that has all the data files in it.

 

5. Manually add the archive to Mod Organizer like any other mod and activate it.

 

This made the animations appear correctly. But I'm sure anyone can see why this is a workaround and not a solution. It requires all files to be put in a single folder, so some files may be overwritten if you have a lot of animations. That defeats the founding purpose of Mod Organizer, as it makes a permanent change.

 

So, is there any solution to this so I can get FNIS working in Mod Organizer? It worked on an NMM install just fine when I used it a week ago. And it works when used outside Mod Organizer. Somehow Mod Organizer just isn't communicating the files generated by FNIS to Skyrim.exe when it launches.

 

Thanks for any help, I'm at a loss here!

Edited by Sarcasm

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

It's an easy one to miss, but have you actually activated the FNIS mod in the left pane?

Share this post


Link to post
Share on other sites
  • 0

Sorry to have taken so long to get back, but this issue just kind of randomly fixed itself. After launching FNIS through MO many times and getting nothing in overwrite afterwards, I just started working right. No idea why. But thanks for your replies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.