Jump to content
  • 0
Bundy714

FPS have suddenly gotten awful

Question

Ok, I've been in heaven the past couple weeks playing Skyrim without CTD's because of ENBoost and the Memory Patch.  I have a HD 7950 and have a FPS counter in the top right corner of my screen at all times, and because I have Vsync enabled, it stays right at 58-60 almost all the time, with heavy intense battles dropping into the 40's occasionally.

 

So, I'm playing yesterday and my son comes in and asks why are your frame rates so low?  I hadn't noticed until he said something because they never vary much and I've gotten to where I don't even look at them much anymore.  But now I'm getting like 30 FPS avg. and sometimes dropping into the upper 20's and never going above the 40's.

 

I've tried loading saved games from way back, same low scores.   So I think, maybe somethings wrong with my graphics card and I start downloading several graphics card benchmarks and tests, and they run great, with scores just as expected with an I5 Cpu and a HD 7950.  Now I'm stumped as to why Skyrim is running so slow.  I didn't change anything.  When I first loaded ENBoost and the Memory Patch I paid a lot of attention to my FPS because it was a new configuration.  It never wavered much from what it was capped at (60fps), so I stopped noticing it after a while.  Now I'm at a loss to explain or fix my suddenly crappy FPS numbers.

 

Anyone got any ideas?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

30 FPS is fine, BTW ....

 

Are you using ENBoost vsync ONLY? Keep in mind that vsync will cut your frames in half unless you are getting at least 59 FPS (this is how vsync dances with your monitor refresh rate [assuming 60 Hz], and it is the way it works).

 

If you are running your vync from your graphics drivers (contrary to the guide recommendations), then you are likely not using D3D-compatible triple buffering (unless using RadeonPro or similar), which effectively means that you can only achieve frame rates

 

My big question (and you can help to answer) is whether or not ENBoost is behaving as if it also provides D3D-compatible triple buffering (graphics drivers' natives software does not). This will be evident if you are using ENBoost vsync (and ONLY this is active) and you notice relatively stable frame rates in the range of approx 35 to 55 FPS (rather than steps of 10/12/15/30/60). I see this in my game using only ENBoost vsync (I typically get between 30-60 FPS and several steps in between this range ... specs in my sig).

 

Your frames have likely dropped if you recently enabled vsync (via CCC) or disabled triple buffering (unlikely; your card only supports OpenGL tri buffering, so that does nothing, be in on or off). I suspect ENBoost provides the correct tri buffering though, so give that a shot (and turn of iPresentInterval ['0'] in skyrimprefs.ini as well as vsync in CCC).

 

It would be a great contribution if you could compare your frame rates between two similar runs using the same savegame with CCC-enabled vsync versus ENBoost-enabled vsync :yes:

Share this post


Link to post
Share on other sites
  • 0

Ok....here we go. I think my computer has gremlins or something. The issue started last night...and continued when I booted up this morning. Now it's gone. WTF....I don't even know why. This morning I ran Skyrim a couple times, loaded saved games from way back, still got anemic frame rates. Quit the game, downloaded and tested with several graphics tests.... Still the same in Skyrim. Quit again to do other things, now back in Skyrim and my frame rates are back to normal. I never changed anything. Who knows?

 

And you are correct in that with frame rates at 30, everything still looked fine. Without the FPS counter, I'd have never known any difference.

 

I do really appreciate the answer, and as for your suggestions, I am using RadeonPro and it has Vsync Control set to always on. I've never enabled Vsync in ENBoost, since it was handled by RadeonPro. It may be contrary to guidelines but it's been working for me without a glitch for a while now. I use RadeonPro to use SweetFX, which yeah, I know, Boris doesn't like....but it's working for me. To tell the truth, I was able to read and get everything to work, but I really and truly don't know how it all works. And once working, I don't change ANYTHING, for fear of screwing it up.

 

RadeonPro was a pain to get set up because of lack of documentation, but I've been using it for the longest time once I got it figured out. Long before ENBoost and the Memory Patch came out. Maybe my setup isn't recommended, but it's been working flawlessly since the Memory Patch. I've had a grand total of two CTD's since then, and I'm running more mods than most.

 

To sum up.....the problem fixed itself and disappeared as mysteriously as it appeared. Not sure why....just glad it's gone. Now I wonder if it will stay gone? All it's done is make my blood pressure go up, stress me out, and reinforce the fact that while I may be competent enough to follow directions, I really don't know what's going on under the hood. I suddenly feel very, very old. Perhaps early onset of Alzheimer's? Hmmm, when does Alzheimers start to set in? I can't recall.....ohhhh noooo

Share this post


Link to post
Share on other sites
  • 0

Glad you have that config working. It is viable, for sure, but not nearly as easy to set up as what we recommend. I understand you not wanting to change it ... however, you just need to tick the little box next to D3D triple buffering and watch your average frame rates increase a bit (unless you have already??)

 

If you don't like it, just uncheck the box ... simple!

Share this post


Link to post
Share on other sites
  • 0

Thanks, Z....I'm going to try that. And I really appreciate you taking the time to help me, I knew this wasn't a STEP issue, but the folks here are the most intelligent and helpful around, so this is where I turned.   My game did start out as STEP....but then I kind of added my own Bundy-Pack to it.  So, now it's STEP Plus.....which is what I imagine a lot of people do.

 

I was a bit in panic mode, I thought my graphics card was failing and I don't have $300 discretionary dollars right now, and it's only been in the last two weeks or so that Skyrim is finally running awesome too. Keeping fingers crossed it stays working that way. Now, to go try out that D3D triple buffering.

Share this post


Link to post
Share on other sites
  • 0

Make sure you do not enable the FPS limiter using a hotkey.... that has come to my attention can be an issue. It i easy enough to verify inside the GUI if it is the case.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.