Jump to content
  • 0
Sign in to follow this  
ElCapitan8866

DynDOLOD full 3d LOD trees foggy weather bug

Question

Hi all. I am having an odd visual bug with foggy weathers and ENB enabled in Skyrim SE, particularly with distant 3D LOD enhanced vanilla trees generated by DynDOLOD. Here is a picture showing the problem:

 


 

In short, under foggy weathers with ENB's subsurface scattering enabled, LOD trees do not have any fog effects applied to them. I have tried multiple ENBs and weather mods, though I suspect this is an issue with DynDOLOD LOD trees? If I disable SSS, using the skin toggle under prepass in ENB, fog is correctly applied to distant LOD tress, but then I lose all SSS effects.

 

Any ideas? Thanks!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

DynDOLOD does not change how the engine works.

 

DynDOLOD uses the meshes and textures that are installed in the load order. You are using a third party tree mod.

To test if there is an issue with the 3D LOD trees shipping with EVT, disable the mod and generate 3D tree LOD for the vanilla trees. 3D tree LOD models for the vanilla trees are included in DynDOLOD Resources.

 

If the same happens, then you already discovered the cause of the problem. Search the ENB forum or make a post there.

Share this post


Link to post
Share on other sites
  • 0

Thanks Sheson, I went and asked on the official ENB forums.

 

This is what I was told in case anyone else encounters this issue:

 

"I suspect you're using the prepass from the "Shader Addon" mod then. It has a few problems with things like 3D tree LODs that the ENB SSS itself doesn't normally have."

 

Boris himself said "according to my code no objects can have sss unless it do have sss itself in shader. So those trees are sss objects and i can't ignore them as it would mean to ignore something else too."

 

So it must be an issue with EVT, the solution is to simply disable the prepass shader that might be causing the problem, in my case, "skin", not to be confused with SSS.

Share this post


Link to post
Share on other sites
  • 0

The DynDOLOD log lists which NIF files are being used for the 3D tree LOD.

 

If you believe they have wrong shader type or settings update them with NifSkope.

 

You may want to check any of the tamriel.4.*.*.bto files first if trees use anything else but the default shader.

The LODGen_log should have a message if it encounters shader types other than the default or glow shader.

 

 

Also if Boris asks how to reproduce the issues, just zip and upload the meshes\terrain\tamriel\objects\tamriel.4.*.*.bto and Textures\DynDOLOD\LOD\*.dds

Edited by sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.