Jump to content
  • 0
nicktheduke

Dyndolod causes CTD on loading screen

Question

Hi all.

 

Discussing this over here on Reddit: https://www.reddit.com/r/skyrimmods/comments/7av8nu/help_dyndolod_consistent_ctd/

 

Basically, I've created a pretty massive LO with a lot of merges based on SRLE LOTD Req'd guide. I start a new game and everything seems to run fine but as soon as I add Dyndolod.esp, the game crashes on loading screen.

 

I've read the manual. I've got nothing missing when generating. I've got Crash Fixes custom memory block. I've looked at corrupt nifs, which I found a few in Beyond Bruma, but I'm not generating Dyndolod for that worldspace. I've turned on Papyrus and had nothing Dyndolod related when it CTD'd.

 

I've run out of ideas for what I can do to fix this, which is unfortunate since Dyndolod has been in my LO for many years.

 

Any ideas? Please help!

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Any CTD is either memory or nif related. With crash fixes UseOSAllocators=1 working you can usually rule out memory problems causing silent crashes.

 

If crash fixes is not reporting a corrupt nif andall missing nifs have been installed or ruled out, enable extra debug message in papyrus as explained in the DynDOLOD-README.txt. Have a good look at any and all nifs reported in the last same second. You could remove the mentioned references one by from DynDOLOD.esp until CTD stops to narrow down the culprit.

 

Also read this thread, which is a good example how to further troubleshoot CTD in a specific area by removing chunks of references in case all other methods fail (In hindsight the extra debug messages to papyrus log should have pointed us to the full model museum earlier)

 

Sometimes there can be otherwise valid nifs that cause problems when used with the IsFulLOD (neverfade flag)

 

Once you have found a model / mod I can try to verify myself and provide a general fix.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Sheson!

 

Thanks for the quick reply.

 

So I'm looking at my Papyrus log and I don't have anything related to nifs. 

 

See here: https://drive.google.com/file/d/135dSPGWABeiSsBJaD4E71zAF-AZTxTa6/view?usp=sharing

 

Will check out the thread you mentioned but I was hoping someone with knowledge like yourself can shine a better light on the situation.

 

Also, the crash occurs only on loading screen so it's not like Dyndolod even has a chance to kick in? I did check for errors in xedit and a few things popped up but I'm not sure why/how to correct.

Edited by nicktheduke

Share this post


Link to post
Share on other sites
  • 0

I suggest to do some simple but effective trouble shooting. Remove as much data as possible so in the end the only thing left is the cause of the error.

 

Start by hiding meshes/texture folder from output.

If it still crashes, hide the skse folder.

At this point only the esp should be left.

 

See if you can narrow down an area by using "coc" from main menu command prompt. For example, coc whiterun, coc solitudeexterior01, coc windhelmexterior01 etc.

 

The next steps you need to always need to keep at least the last two versions of the esp, the one that still crashes and the new modified one you are testing if it still crashes. If the new one doesn't crash, go back to the one that still crash and remove other data instead:

Use xEdit to remove all worldspaces other then Tamriel from the esp and see what happens.

If it still crashes remove all temporary cells. If it doesn't crash then go back to the one that crashes and start removing large chunks of temporary cells nowhere near the area first. Then try narrow it down to a single cell. Then remove 50% of the references in the last remaining cell. Test if it works. If it doesn't crash go back one copy and remove the other 50% so that you always have a esp that still crashes until you have the least amount of refereces/data as possible.

 

There is good chance you will able to remove all temporary cells and still have the problem. Then the problem is with a reference in the persistent cell.

Always keep the Tamriel_ShesonObject, Tamriel_Minion_* and Tamriel_FirstBorn_* references.

Remove chunks of the *_DynDOLOD_LOD and *_DynDOLOD_GLOWLOD references. Just remove 50%. Test if it works. If it doesn't crash go back one copy and remove the other 50% so that you always have a esp that still crashes until you have the least amount of refereces/data as possible.

 

This may sound complicated, but if just remove large chunks of data *not* causing the crash you should be able to narrow it down pretty quick to a single cell or even to a single record. Let me know what you find, or upload the "tiny" esp still having CTD for me to investigate if the cause is not apparent.

 

If you need more details how to use xEdit to remove records let me know.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Hi again.

 

So I deleted all worldspaces from everything but Tamriel. Only then does the game load. Will start deleting chunks at a time to see if I can narrow it down.

Share this post


Link to post
Share on other sites
  • 0

UPDATE: I figured it out. Or at least narrowed it down. Seems when I delete the worldspace DLC2SolstheimWorld from Dyndolod.esp, the game loads. I am not sure what happened because the game loaded last time w/ Dyndolod after I added anything Solstheim-related.

 

So I'm a bit stuck. @sheson I hit you up on Discord. Will post here if I figure out what's causing this.

Edited by nicktheduke

Share this post


Link to post
Share on other sites
  • 0

I have no idea why the game doesn't load with DLCSolstheimWorld loaded in Dyndolod... Any help? 

 

EDIT: Decided to try to play without DLCSolstheimWorld, but the game eventually freezes and crashes when MCM menu registers...

Edited by nicktheduke

Share this post


Link to post
Share on other sites
  • 0

This starts to sound like you have just too many mods adding to much stuff https://forums.nexusmods.com/index.php?/topic/4795065-ctd-on-any-save-load-or-new-game-when-over-modding-skyrim-aka-are-you-a-member-of-the-67e-bait-modders-club/

 

See if changing Temporary=1 in DynDOLOD_TES5.ini helps.

 

Our discussion about this starts around here https://forum.step-project.com/topic/11446-dynamic-distant-objects-lod-dyndolod-218/?p=182733

Share this post


Link to post
Share on other sites
  • 0

Temporary=1 didn't work. Everything loads including Dyndolod MCM but as soon as I enter a new cell, the game freezes. 

 

I will take a look at removing some things but everything was fine until I added some scripted mods (Religion, Cleric, DVA, Vampiric Thirst, etc)

 

I did add Beyond Bruma before that but it was loading fine with Dyndolod active (with Bruma deactivated in Dyndolod build)...

Share this post


Link to post
Share on other sites
  • 0

Sheson,

 

That link to Nexus discussion re: overmodding states "Of note, Sheson has already included an option in DynDOLOD to reduce the number of persistant references that it contributes to the game."

 

What option is this? Was it Temporary=1?

Share this post


Link to post
Share on other sites
  • 0

Yes that is the option to have fewer persistent references that we figured out in the related discussion seem to play a role in some kind of limit.

 

If that is not your issue, you should go back at looking closer at the Solstheim worldspace more thoroughly. Is the opposite true? Are there any problems when you keep only Solstheim in the esp, but remove the other worldspaces?

 

You could also try to remove one big mod and then generate everything again. Does it work then? If all you have to do is remove "some" data somewhere, it would indicate hitting some kind of limit - something else than the persistent references then. Maybe check memory usage with Skyrim Performance monitor.

 

If it is clear cut just a specific worldspace in the esp, then it is more likely some kind of copied data record or resource asset is the problem.

 

Check the load order for errors with xEdit, remove bashed patch when generating LOD. If you like you could upload the log, on the small chance I spot something - despite all the merge patches.

 

Problematic assets like meshes/texture usually only cause problems when they start to show / come into view once the worldspace is loaded, that is usually very reproducible.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Thanks for your timely assistance, sheson. I appreciate everything that you do.

 

Tonight first thing I did was build Dyndolod with just Solstheim. Did a speedmult 250 and ran around a bit outside of Riverwood. Didn't crash. 

 

And then something odd struck me:

 

Even when I don't click the checkbox for Beyond Bruma when generating Dyndolod worldspaces, I still get errors pertaining to missing meshes from Beyond Bruma at the bottom of the Dyndolod generation window. Thinking that might be the culprit, I deactivated Beyond Bruma and my Requiem patch when generating, but the game still crashed on loading save.

 

So I'm sitting here trying to think logically. It seems to be Tamriel related. Now I've deleted Tamriel worldspace from Dyndolod and the game loads. I ran around. No crash. Which at least solves the Solstheim issue. Taking a look again with xEdit, I noticed some records aren't being carried over. Things like XCLR - Region, MHDT - Max Height Data, XCWT - Water, Editor ID, and then there were some Record Flags from new USLEEP not being displayed in Dyndolod.

 

Since I'm grasping at straws right now, I decided to forward everything over as much as I could into Dyndolod.esp and mark as many entries as possible in green (except Max Height).... Then I checked Dyndolod.esp for errors. There were a few Moveable Statics with <Unknown: 6> in  the Record Flags, where I removed the Unknown entry.

 

And it still crashed. Which makes it seem you are correct in that there is some situation with meshes/texture? What are your thoughts? Which log should I provide if need be?

 

Also, these were the last few mods I added before things started crashing:

 

+ Vampiric Thirst + Requiem patch
+ Follower Commentary Overhaul
+ Religion
+ Cleric 
+ Spell Research
+ Spell Crafting
+ Windhelm Exterior Altered
+ Airship and Archaeology patches for Legacy of Dragonborn
+ Skyrim Is Windy
+ new update for Notice Board Updated
+ Vigilant Voiced Add-on
+ Heathfire Extended + Requiem patch
+ new update from USLEEP
+ new update from Cutting Room Floor
 
Going to take a look at all of these and see if I can find out if there's anything mesh/texture-related happening...
Edited by nicktheduke

Share this post


Link to post
Share on other sites
  • 0

I think I've narrowed it down further... 

 

Deleting temporary cells from Tamriel worldspace in Dyndolod allows the game to load and play. I'm now searching for which temporary cell might be causing the issue by using the method you stated above where I delete chunks at a time.

Share this post


Link to post
Share on other sites
  • 0

Sorry for so many posts. I wish I could edit my previous for updates...

 

Like I mentioned, the temporary cells are the cause of my CTD. I've narrowed it down between Block -2, 1 - Block 0, 0 

 

Unfortunately I wonder if there are crashes outside of those Blocks since I have not tested anything beyond Falkreath/Riverwood/Whiterun.

 

I stripped everything from the aforementioned Blocks except Tamriel_ShesonObject, Tamriel_Minion_* and Tamriel_FirstBorn_* references. 

 

The game loads the save now but will freeze/crash as soon as I enter a new cell unless I delete those blocks. No errors exist in the Dyndolod esp but who knows, there could be more issues out of the blocks I deleted.

Share this post


Link to post
Share on other sites
  • 0

Even when I don't click the checkbox for Beyond Bruma when generating Dyndolod worldspaces, I still get errors pertaining to missing meshes from Beyond Bruma at the bottom of the Dyndolod generation window. Thinking that might be the culprit, I deactivated Beyond Bruma and my Requiem patch when generating, but the game still crashed on loading save.

If the plugin of a mod is loaded when DynDOLOD starts, its base records and whatnot are still part of the process, regardless if you generate for its world spaces or not.

 

So I'm sitting here trying to think logically. It seems to be Tamriel related. Now I've deleted Tamriel worldspace from Dyndolod and the game loads. I ran around. No crash. Which at least solves the Solstheim issue.

Find a 100% reproducible case and concentrate on it and narrow it down. The goal is to end up with data causing crashes that has everything else removed.

 

Taking a look again with xEdit, I noticed some records aren't being carried over. Things like XCLR - Region, MHDT - Max Height Data, XCWT - Water, Editor ID, and then there were some Record Flags from new USLEEP not being displayed in Dyndolod.

What do you mean records are not carried over? When DynDOLOD creates an overwrite record, it uses the data from the last overwrite before it at the time.

 

Since I'm grasping at straws right now, I decided to forward everything over as much as I could into Dyndolod.esp and mark as many entries as possible in green (except Max Height).... Then I checked Dyndolod.esp for errors. There were a few Moveable Statics with in  the Record Flags, where I removed the Unknown entry. And it still crashed.

FAQ: Checking for errors for DynDOLOD.esp with xEdit

A: .. \ Record Flags -> are intentional and can be ignored.

 

Which makes it seem you are correct in that there is some situation with meshes/texture? What are your thoughts? Which log should I provide if need be?

Now it seems your tests and crash reports are all over the place. Does it crash before, while or after loading the game? Does it crash once you are in the world?

 

If it is all of the above, focus on one of the crashes. Again. If you removed something that eliminated the crash, go back one step and remove something else that does not eliminate the crash until nothing else is left.

 

The log ..DynDOLOD\Logs\DynDOLOD_TES5_log.txt just upload to paste bin or something.

 

Unfortunately I wonder if there are crashes outside of those Blocks since I have not tested anything beyond Falkreath/Riverwood/Whiterun.

Don't wonder, stick to that one crash you can reprodue 100%. If you there more areas, chances are high they are related and if we find the cause of one they all will be fixed.

 

I stripped everything from the aforementioned Blocks except Tamriel_ShesonObject, Tamriel_Minion_* and Tamriel_FirstBorn_* references.

 

The game loads the save now but will freeze/crash as soon as I enter a new cell unless I delete those blocks. No errors exist in the Dyndolod esp but who knows, there could be more issues out of the blocks I deleted.

Again then go back one step and remove something else that doesnt remove the crash. It will be quicker that way.

 

If you can load into the world and run around and it then crashes, check the papyrus log after setting "debug":"true" in DynDOLOD_Worlds.json

 

Upload the papyrus log as well if you like.

Edited by sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.