Jump to content
  • 0
Sign in to follow this  
FuzzRocket9

G-Sync help with modded Skyrim (2011)

Question

So I bought this monitor without even checking online and bummer, I thought it would work like clockwork after disabling V-Sync on the Inspector. I remember way back reading a thread about this issue and I searched as well, and nothing coming up, probably because of the dash symbol. If anyone has a good guide to get this troubleshooting over with. I just want to play with the best setup, which is why I forked out for this ROG monitor from Best Buy. Still on sale if anyone is looking for one. Asus ROG PG248Q 24" up to 180hz.

 

Anyways, help would be great!

 

Edit: I'm getting the ugly lines and also getting stutter which I'm sure cannot be avoided in heavy mod games.

Edited by FuzzRocket9

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Won't let me edit so I have to add some more details.

 

I disabled V-Sync within ENBlocal.ini/Skyrim.ini/SkyrimPrefs.ini/Nvidea Inspector. I also limited my FPS to 60,down to 40, and now 30, all through the Inspector. My PC is the PowerSpec 313 prebuilt with an i56600k OCed to 4.1 and a GTX 1070, no OC (Dunno how yet..). I should be fine for my modded Skyrim playthrough.

 

I don't want to return this, but I don't really play any other game beside Skyrim, at least until something else big pops up.

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

I managed to find an interesting piece of info on the forum searching with "Gsync", no dashes. Enabling "Maximum Pre-rendered Frames" to 1. That helped a lot! I still see tears, but not as bad! Thanks whoever posted it!

 

Now to fix my suttering. What do you all think I can do about that?

 

Edit: I'm going to 2 Pre-Rendered Frames to see if that removes all my lines. I'm also slowly increasing my ReservedMemorySizeMb and now I'm at 768. So far that's taken away most of my stuttering. Just dealing with the ugly lines or tearing that still comes up.

Edited by FuzzRocket9

Share this post


Link to post
Share on other sites
  • 0

I was in similar situation - bought G-Sync monitor primarily to help with TES games only to find out about the limits of the engine regarding framerates and stuttering and all that. I also had similar spec PC to yours at the time. After some tweaking I had no stutter (apart from the unavoidable occasional hiccup due to memory/engine) and no tearing.

 

What of course is hard to compare are modded Skyrim setups. Mine had about 30 mods, but nothing too heavy also no ENB/Reshade presets.

 

it`s important to note that "stutter" is a relative term and for somebody with an OCD like me a slightest hitch counts, while others can play at 30 fps and be  fine with that. So it`s impossible to say if your setup is okay without seeing all the configs, mods etc. 2 things are certain though: you should be easily playing with min fps=40-50 (and that`s populated areas), average of 60 fps and have no V-Sync related tearing at all. Stutter =/= tearing, looks and is a different  issue.

 

There`s a bazillion settings to mess with , but off top of my head:

-first of all, if you go over 85 fps, the engine will break and you will start seeing dead chickens, flying cows etc. Get the afterburner/Riva Tuner and set the fps limit to 85. Also unlock the other fps caps you set elsewhere, there`s no need with this hardware to go so low.

 

-I played with iPresentInterval=1 and GSYNC on, because  I was worried about engine breaking. However now in Special Edition I tried to play with 0 and it was all fine, tried briefly in Oldrim and it worked too. However you might try 1 if tearing persists. The most important thing is not going over 85 fps

 

-other crucial setting is Prefered Refresh Rate in Nvidia control panel. I have it set to highest available and it works this way, but you might try application controlled too (the control panel and drivers are atrocious in general and sometimes behave irrationally. For example I have to reset the machine occasionally because the driver/settings get corrupted and tearing appears)

 

-make sure that all the settings across various configs/panels are synced, meaning that if for example you want to try vsync off, then it has to be off in all the configs, from enb to skyrim.inis and control panel.

 

-Pre-Rendered Frames have nothing to do with tearing, stick with 1, it helps with stutter

 

It took me several afternoons to sort out but it can be done. With this rig you should have stutter and tear - less gameplay with fps from 50 (lots of actors) to steady 85 in less populated areas. Good luck!

 

Also: Special Edition is much better in this respect: the x64 engine works much smoother and performance is better. Recommend switching.

Share this post


Link to post
Share on other sites
  • 0

EDIT: I can`t edit my own posts? What`s up with that?

 

couple more things:

 

-your monitor`s refresh rate should be set to either highest available (in Change Resolution section of Control Panel) or 85Hz

 

-possible nasty surprise: Mod Organiser (and maybe others) stores Skyrim`s configs in it`s own directory. So you need to edit those, and not the usual ones. This once drove me nearly mad when  I forgot about it and tried to change stuff to no effect.

Share this post


Link to post
Share on other sites
  • 0

Thanks so much! I installed Riva and notice a difference. The issue is the stutter, but i think I can live with it. I'm gonna see if increasing "ReservedMemorySizeMb" to the max helps. I have 8gb of VRAM, so I'm sure this can be an option to run.

 

I don't think I have a choice to switch to SE as I'd most likely have to change my whole mod setup and time is limited. I can see why most adults stick to a console, plug and play. I couldn't. I just ended up getting used to troubleshooting games all the time

Share this post


Link to post
Share on other sites
  • 0

Thanks so much! I installed Riva and notice a difference. The issue is the stutter, but i think I can live with it. I'm gonna see if increasing "ReservedMemorySizeMb" to the max helps. I have 8gb of VRAM, so I'm sure this can be an option to run.

 

I don't think I have a choice to switch to SE as I'd most likely have to change my whole mod setup and time is limited. I can see why most adults stick to a console, plug and play. I couldn't. I just ended up getting used to troubleshooting games all the time

I think too high ReservedMemorySizeMb can cause stutter as well. Try low number first like 128. You have 1070. I think using only ENB V-Sync may give you the best result. G-Sync is probably not worth using in Skyrim. Have you try new memory allocation with Crash fixes? https://www.nexusmods.com/skyrim/mods/72725/?

Crash fixes' new memory allocation fixed the most annoying stutters for my setup.

Share this post


Link to post
Share on other sites
  • 0

G-Sync works just fine, so if you have it, use it. What`s the point of spending heaps of cash on hardware otherwise?

 

It requires a bit of work - well, nothing new when it comes to aiming for best-in-class Skyrim setup. And benefits of G-Sync vs V-Sync are well-known - it frees lots of fps and gets rid of the awful lag induced by V-Sync.

 

To reiterate the most important factors to get it working properly:

 

-set fps cap to 85

-iPresentInterval=0 and other V-Sync settings elsewhere (Control Panel, other inis) set to off/0

-iFPSClamp=0

-in Control Panel: Prefered Refresh Rate set to Highest Available and monitor refresh rate set to the highest native one

(if you still get tearing  then try Application Controlled setting and lower refresh rate to 85Hz - one of these two should work, mine works with the Highest Available)

-umm...enable G-Sync in CP....you did that, right? :D

 

Regarding stutter, like I said, I have none - and that`s without going into arcane settings like ReservedMemorySize. My suggestion would be to start with clean STEP install without any mods (apart from the obvious initial cleaning and patches). This should be a stutter-free situation, there`s no other way about it on your hardware. After you get to this state, start adding mods and see which introduces stutter - if any does - then deciding if you prefer the mod or smooth gameplay.

 

(One thing: I play with gamepad, possible stutter caused by mouse settings is another set of headaches)

  • Upvote 2

Share this post


Link to post
Share on other sites
  • 0

Thanks. I got it working. Just that stutter, but I can live with it. The stutter only bothers me after playing a different game with no stutter. Oh well. I also don't know after getting my hundreds of mods to run on SE. So I'll take this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.