Jump to content
  • 0

Merge Plugins weird UI behavior


Octopuss
 Share

Question

So I blindly started MP for the first time (from MO of course), just to get an idea what it looks like. I've got a few questions and/or problems.

 

1) What's the point of the first window where I select plugins? The next step displays everything again, only in different window.

 

2) Clicking on the dictionary icon freezes the entire program and I have to kill the process. It might be doing something in the background, because it eats 10+% CPU, but there's no indication of anything anywhere. And I got tired after 10 minutes.

 

3) Detect integrations button seemingly freezes the program as well. After a I while I accidentally realized I had to alt tab elsewhere to make the information popup window (saying it couldn't find MO) appear.

 

4) The help is empty, and I mean literally. There's absolutely no text whatsover in any category (I see the tree but no text for any of the items).

 

 

Thinking about 2) again, I've now tried the same thing I did in 3) and after alt tabbing, lo and behold, an error message! It says that 4.0 is not a valid floating point value. Also, whatever is the program doing after clicking on the button cannot be aborted, so I have to kill the process anyway.

Edited by Octopuss
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

1) What's the point of the first window where I select plugins? The next step displays everything again, only in different window.

The first window is where you select which plugins you want to load into memory. It's the same as the xEdit plugin selection window, it just has a bit more information.

The second window shows the load order of plugins loaded into the program, and allows you to view details on those plugins (by selecting them) add them to merges, etc. See the documentation.

 

2) Clicking on the dictionary icon freezes the entire program and I have to kill the process. It might be doing something in the background, because it eats 10+% CPU, but there's no indication of anything anywhere. And I got tired after 10 minutes.

Are you using a translation or have your system set to have different decimal separator than .? There are ongoing issues in both of this areas. The other possible reasons for this would be you don't have a dictionary file or Merge Plugins is having issues accessing your file system.

 

 

3) Detect integrations button seemingly freezes the program as well. After a I while I accidentally realized I had to alt tab elsewhere to make the information popup window (saying it couldn't find MO) appear.

Transient issue on some systems with Windows not keeping windows on top of each other. Detect integrations won't find anything if you have file system permission issues or if you don't have any integrations set up in locations Merge Plugins knows to look for them.

 

4) The help is empty, and I mean literally. There's absolutely no text whatsover in any category (I see the tree but no text for any of the items).

That's a system issue. Open the PDF help file to access information on how you can fix that. There's a reason I provide the help/documentation in two formats!

 

 

Thinking about 2) again, I've now tried the same thing I did in 3) and after alt tabbing, lo and behold, an error message! It says that 4.0 is not a valid floating point value. Also, whatever is the program doing after clicking on the button cannot be aborted, so I have to kill the process anyway.

Ah, yeah, that's the issue with the decimal separator. When parsing floating point numbers the default behavior is to use the system format settings. The dictionary is formatted as: 1,234.567890 (. is decimal separator). Unfortunately by fixing one issue with format settings I created this issue instead. It'll be fixed in the next version. Until then you can change your region & language settings to use , for thousands separator and . for decimal separator, and it will work.

Edited by Mator
Link to comment
Share on other sites

  • 0

Allright, thanks. I was just curiously messing with the program for the first time, sort of randomly clicking around, seeing how things work.

 

As for some of the questions: no translation (I literally only downloaded MP and ran it through MO), but I might be using "," as a decimal separator considering my system locale is czech (yes, seems like it's the case).

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.