Jump to content
  • 0
agentmith

Hadvar won't enter Riverwood during the initial quests

Question

I posted twice on reddit and have a general idea of what the problem MIGHT be, but unsure how to proceed. Here's the body of both posts. Let me know if there is any additional information I may have missed that might be useful please.

 

posts on reddit, as some comments were helpful

https://www.reddit.com/r/skyrimmods/comments/3m16rr/help_90_of_the_time_hadvar_wont_go_into_riverwood/

https://www.reddit.com/r/skyrimmods/comments/3m9ri1/help_follow_up_to_hadvar_problem/

 

 

First post:

 

This has been an intermittent problem for months. During the intial quest, I pick Hadvar and we escape Helgen (or random Live Another Life start). I walk with Hadvar all the way to Riverwood. When we get there, Hadvar hangs out at the entrance to Riverwood for a second, goes past the gate, takes off at a sprint for a brief moment, turns around and runs back out, waits, then repeats the process. Back and forth, in and out of Riverwood indefinitely with little sprinty bursts. Or sometimes he just stops by the entrance, usually after I've loaded the game once this has already started happening.
 
I can't for the life of me figure out what's causing this to happen. It's weird, sometimes it doesn't happen at all but I can't figure out the correlation to anything. It might be due to my tinkering with load orders in an attempt to troubleshoot, enabling/disabling different mods, cleaning them in TES5Edit, doing stuff in WryeBash, etc, all to see if I can fix it. 
 
I've done STEP Extended 2.2.9.1 except for the DynDOLOD stuff (I kept the Skyrim Distance Overhaul and Skyrim Distant Detail, as I couldn't get DynDOLOD to work and it was extremely time consuming to keep redoing), plus a bunch of weather, combat, and assorted other tweaks so it's hard to tell what the source is. A lot of the extraneous mods outside of STEP I've either had enabled or disabled at various points, but this problem seems to persist, which makes it even harder to pin down based on mod list or order.
 
From the console I've messed around with disable/enable, moving him around, moving me around, and some [stump the dog fix which may or may not be peripherally related](https://forums.nexusmods.com/index.php?/topic/514336-hadvarralof-is-bugged/) but it didn't seem to make a difference. The best I can do is get him to take off at a sprint until he hits an obstacle while he continues running in place.
 
[Here's my load order](https://pastebin.com/aYuPwLvn).  I've gone over the instructions for STEP many times, as well as mod order placement from the relevant STEP packs (LOOT modifications, etc), and pretty much have it down solidly. 
 
I THINK it's part of the main quest that he actually gets to where he is needing to go, so I'm kind of stuck until I can figure this out. I'd settle for a way to respawn him where he needs to be, then trigger the relevant part of the quest manually to see if that works (if that's even possible).
 
My first suspect was Live Another Life, but I've tried both with and without it running and experience the issue. I leave it on because it takes too long to get to this point in the game when it isn't.
 
 
 
I'm using Vividian ENB if that matters. SKSE and everything else you can think of are updated to current, but I had this happening last year too before several key updates.
 
[Looks like someone else was experiencing the same issue a while ago](https://steamcommunity.com/app/72850/discussions/0/522728268728416232/?insideModal=1) but never found a resolution, and he had a vanilla install. Not sure if it's related, but it sure sounds like the same problem.  
 
 
 
Edits for clarity, and as I find relevant info.
 
----
 
second post:
 
Hadvar won't go talk to his uncle. He stops at the entrance to Riverwood and runs in, then runs back out, back in ad nauseum. Has been going on for months.
 
I'm looking at things in the Creation Kit and TES5Edit. I'm not 100% what I'm looking for, but as far as I can tell it's in FormID 001098B5 according to CK. The only mod that touches the triangles and such here is the Unofficial Skyrim Patch.
 
I pulled up Hadvar in TES5Edit and he is only modified by ASIS (as I would expect, it touches all NPCs). He has 20 references on the Referenced By tab, but the only 2 references to the Unbound quest are the Unofficial Patch and Live Another Life. I don't think this is the quest in question, I think it's Before the Storm which I don't see mentioned at all. Hell, this may not even be directly in correlation to a quest, I don't know how the background scripting works globally. I know he's supposed to go somewhere later in the game if you join the Imperials, and this problem keeps him from accomplishing that objective. 
 
Anyway, at this point I took a step back and am posting here as I'm unsure how to proceed.
 
I don't know what I should look for next.  It's hard to tell if I'm even on the right track, as nothing stands out as being a problem. I don't see any deleted navmesh records, or any other glaring issues.
 
Is there a way to sort of trace route his quest progression to see what part he gets stuck on, or which spot on the ground is supposed to set the next part of the quest in motion? 
 
EDIT: I found a couple redundant mods that I disabled, thanks to Wonders of Weather rolling everything into 1 mod and the STEP guide using some of older constituent parts separately. I also started with the Stormcloak start this time, and it worked as intended. I can't help but feel dirty picking Stormcloaks though, so I'm not giving up on this just yet.
Edited by agentmith

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

 

 I leave it on because it takes too long to get to this point in the game when it isn't.

 

When troubleshooting mods, this is exactly the wrong thing to do, unfortunately. Because portions of mods get 'baked' into save games on occassion, using a save where they were all on means that, even after they are turned off, they may have lasting effects on the testing. A better way to do this would be to run completely vanilla until exiting the Helgen cave, then turning everything on in portions... say five to ten at a time. Run to Riverwood, see what happens. If it works fine, add in another ten. If not, take the mods you added and remove half of them and try again, etc. It's time consuming, but it's still the best way to troubleshoot the problem.

 

Personally, I've never seen anything like this in my games. From the sound of it (not having done ANY research, understand), it looks like a script isn't firing as it should when Hadvar hits the Riverwood waypoint. So he keeps trying to get to the waypoint after getting to it (which would explain the in and out running behaviour). If this was happening in a vanilla game as well, I'd suggest re-downloading the Skyrim files, re-cleaning them, then checking to see if it was a corrupted set of files.

 

All I have at the moment... hope this helps out some.

Share this post


Link to post
Share on other sites
  • 0

Thats the same way I go about mod troubleshooting. You can't be lazy when it comes to finding out what is causing your problem. 

Share this post


Link to post
Share on other sites
  • 0

Sorry I should clarify. Every time I test I start a brand new game over. Since I ran into the issue without Live Another Life on, I leave it on since it takes far too long to get to the point where the issue occurs. At no point am I changing any mods around with an existing save game. I always recreate the bash patch and run all the reproccers every time I change anything as well.

Share this post


Link to post
Share on other sites
  • 0

Good to know - as we mentioned, that would have been HORRIBLE T/S methodology.

 

That said, I reference my second suggestion - verify the steam cache and try it pure vanilla to see if the problem recurs unmodded. If it does, the mods are not at fault... there's something wrong with the base files. If not, then it's five at a time, reinstalling, until you find the culprit.

Share this post


Link to post
Share on other sites
  • 0

That's what I was hoping to avoid since I have around 300 mods or so, and why I started digging into the CK and TES5Edit to see if there was any way to identify things more precisely, like a decision tree or quest index or something like that. It's just been the damnedest thing, and has been going on intermittently since I started playing over a year ago, going through several STEP versions and extra mods in the process. I'm positive it's not the install itself, since I had reinstalled it completely at one point, but I suppose some of these things are worth revisiting. Thanks for the replies.

Share this post


Link to post
Share on other sites
  • 0

The first step I would take is to edit Skyrim.ini and disable these Papyrus settings. These settings kill script performance and are mostly useless unless you are actively debugging a script you are writing or modifying.
 


[Papyrus]
bEnableLogging=0
bEnableTrace=0
bLoadDebugInformation=0

 

Share this post


Link to post
Share on other sites
  • 0

Here is a troobleshooting procedure that could help regarding this issue :

 

1) Launch TES5Edit.

2) Click OK so it will launch your whole load order as seen by the game.

3) Once you get background loader : finished, right click in the left pane and select "Apply Filter" (NOT Apply Filter For Cleaning, but the one that let you configure the filter).

4) Uncheck everything in the filter, and only check the "by record signature", and under this section, only "NAVM - Navigation Mesh Map".

5) Wait. Once it's done, every mod still visible in the left pane is a potential suspect.

6) Expand the Worldpsace section of each, the subsection named Tamriel, then "Block 0, -1". If it exist of course. A mod having this entry here after aplying this filter will most likely be the cause of your issue, safe the USKP.

 

Edit :

Here is a screenshot of what your filter settings should look like : 

566637filternavm.png

 

 

P.S. : In regard of OP post, you can't check only for 001098B5, as this is just one of the numerous navmeshes in this area.

Edited by Kesta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.