Jump to content
  • 0
Riverwolf

CTD When Pressing "Print Screen" to take screenshot

Question

So, I just got STEP Extended set up and going, and everything seems to be working pretty well.  

  • I'm running all options except the 101 bugs mod and the Dual Sheath mod.  
  • I selected the HD option whenever it was available.
  • I have no errors or conflicts on Mod Organizer.
  • Game experiences no stuttering, and frame rate has never dropped below 60 fps.
  • I am using NVIDIA GeForce Experience to watch frame rate if it matters.
  • I have confirmed all drivers are up to date.

 

As soon as I got to Whiterun, I was so impressed by the look of the town I decided to take a screenshot, as soon as I press print screen, the game crashes.  I don't know if this is a STEP issue, a Mod Organizer Issue, or something else entirely.  This is a much more complicated mod setup than I've ever used, so I am honestly slightly out of my element here.

 

Any help would be appreciated, and please let me know if there is additional information I neglected to include that could be helpful.

 

Load Order (From loadorder.txt in Mod Organizer):

 

 

Skyrim.esm
Update.esm
Unofficial Skyrim Patch.esp
Dawnguard.esm
Unofficial Dawnguard Patch.esp
HearthFires.esm
Unofficial Hearthfire Patch.esp
Dragonborn.esm
Unofficial Dragonborn Patch.esp
Skyrim Project Optimization - Full Version.esm
Lanterns Of Skyrim - All In One - Main.esm
HighResTexturePack01.esp
HighResTexturePack02.esp
HighResTexturePack03.esp
Unofficial High Resolution Patch.esp
Cutting Room Floor.esp
Traps Make Noise.esp
Soul Gems Differ - NW.esp
ORM-Arvak.esp
Auto Unequip Ammo.esp
Brawl Bugs CE.esp
Moss Rocks.esp
ClamsDropPearls.esp
SMIM-DragonbornTernFix.esp
Dual Wield Parrying_SKSE.esp
DragonShoutVoice.esp
ExplosiveBoltsVisualized.esp
ViewableFactionRanksBothDLC.esp
Footprints.esp
GQJ_DG_vampireamuletfix.esp
Guard Dialogue Overhaul.esp
Convenient Horses.esp
Brows.esp
Lock Overhaul.esp
Nausicaa's Tweaker.esp
RaceMenuPlugin.esp
Weapons & Armor Fixes_Remade.esp
Clothing & Clutter Fixes.esp
Radiant and Unique Potions Poisons and BOOZE.esp
SkyrimCoinReplacerRedux.esp
RaceMenu.esp
SMDropLitTorch.esp
SMIM-FarmhouseFlickeringFix.esp
SMIM-FurnitureChestSnowFix.esp
Elemental Staves.esp
Moss Rocks_DB.esp
SMIM-DungeonsCliffsIceSkirts.esp
ShootingStars.esp
SkyFalls + SkyMills + DG + DB.esp
SkyUI.esp
TradeBarter.esp
DawnguardRuneWeaponsFXSReplacer.esp
Appropriately Attired Jarls Redux.esp
Bring Out Your Dead.esp
Oblivion Gates v3 without Markers - Skyrim + Dawnguard DLC.esp
BirdsHFclean.esp
BetterQuestObjectives.esp
Better Stealth AI for Followers.esp
Thieves Guild Requirements.esp
NonEssentialChildren.esp
TheChoiceIsYours.esp
Point The Way.esp
Book Covers Skyrim.esp
Dead Body Collision.esp
RealisticWaterTwo.esp
SPTConsistentOlderPeople.esp
Rainbows.esp
Beards.esp
WM Trap Fixes.esp
Weapons & Armor_TrueOrcishWeapons.esp
ADS.esp
Weapons & Armor_TrueWeaponsLvlLists.esp
WetandCold.esp
AOS.esp
Animated Weapon Enchants.esp
Paralyze.esp
dD - Enhanced Blood Main.esp
Improved Combat Sounds v2.2.esp
Invisibility Eyes Fix.esp
IHSS.esp
DeadlySpellImpacts.esp
WetandCold - Ashes.esp
When Vampires Attack.esp
aMidianBorn_ContentAddon.esp
aMidianborn_Skyforge_Weapons.esp
Complete Crafting Overhaul_Remade.esp
RealisticWaterTwo - Legendary.esp
SFO - Dragonborn.esp
Run For Your Lives.esp
SkyrimImprovedPuddles-DG-HF-DB.esp
SMIM-ShackRoofFixes.esp
SMIM-ShackRoofFixesDragonborn.esp
HearthfireChimneys.esp
Skyrim Flora Overhaul.esp
PilgrimsDelight.esp
The Paarthurnax Dilemma.esp
BlockSparkles.esp
Gildergreen Regrown.esp
TheChoiceIsYours_Dawnguard.esp
Chesko_Step418_SN.esp
RelightingSkyrim_Legendary.esp
ELE_Legendary_Lite.esp
Complete Crafting_TrueWeaponsLvlLists.esp
dD-Dragonborn-Dawnguard-EBT Patch.esp
iHUD.esp
imp_helm_legend.esp
mintylightningmod.esp
randomthunder.esp
STEP Extended Patch.esp
DynDOLOD.esp
Bashed Patch, 0.esp

 
System Specs in Signature.
Edited by Riverwolf

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Everything in the ini files seems to be correct.
 
When you use PrtScrn without any overriding settings, the screenshots are saved directly in the Skyrim directory (C:/Program Files (x86)/Steam/SteamApps/common/Skyrim) and this can result in a lot of potential issues with permissions, security, etc. If you have a any screenshots in this folder already, move them all to another folder to get them out of Skyrim's executable folder.
 
Check your Skyrim.ini and I recommend settings like this for the screenshots:
 

[Display]
bAlllowScreenshot=1
sScreenShotBaseName=C:\Users\Greg\Pictures\Skyrim\Screenshots\ScreenShot

bAllowScreenshot just allows PtrScrn to take a screenshot so you likely don't need to worry about this one.

 

sScreenShotBaseeName is used to override the default path and prefix used for the screenshots. In the setting above, I redirect the screen shots to my personal Pictures folder so I don't have to muck with the permissions in Program Files. If you set up an override path like this, make sure the entire path is correct and that all the folders already exist. The easiest way to to do this use to use Explorer to create the folders, then click the address bar, and copy the entire path into the clipboard. Finally, open Mod Organizer's INI Editor, and paste this path right after sScreenShotBaseName=.

 

Note that normally when you press PrtScrn you'll see a message like "Saved ScreenShot2.bmp" If you set sScreenShotBaseName, you'll see "Saved C:\Users\Greg\Pictures\Skyrim\Screenshots\Screenshot2.bmp" (with the full path) instead of just the file name.

 

In SkyrimPrefs.ini, check this setting:
 

[Display]
iScreenShotIndex=1

I don't know how Skyrim handles iScreenshotIndex when it reaches the "maximum", so you might consider resetting it back to 1 to see if this makes any difference.

 

Finally, have you installed any third-party screen capture software recently that might be trying to take over when you press PrtScrn?

Share this post


Link to post
Share on other sites
  • 0

Are you using F12 (Steam screenshot) or PrtScrn (Skyrim's screenshot)?

 

Also, have you checked the memory settings in skse.ini and enblocal.ini to verify these are correct?

Share this post


Link to post
Share on other sites
  • 0

I am using PrtScrn.

 

I believe I have the ini files set up correctly, but it's possible I misunderstood something.   I have SKSE.ini in .\steamapps\common\skyrim\data\SKSE and it contains only the following lines:

 

 

[General]
ClearInvalidRegistrations=1
 
[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

 
As for enblocal.ini, I have it located in .\steamapps\common\skyrim\ 

[PROXY]
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=other_d3d9.dll
 
[GLOBAL]
UsePatchSpeedhackWithoutGraphics=true
UseDefferedRendering=false
IgnoreCreationKit=true
 
[PERFORMANCE]
SpeedHack=true
EnableOcclusionCulling=true
 
[MULTIHEAD]
ForceVideoAdapterIndex=false
VideoAdapterIndex=0
 
[MEMORY]
ExpandSystemMemoryX64=false
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=512
VideoMemorySizeMb=3746
EnableCompression=true
AutodetectVideoMemorySize=false
 
[WINDOW]
ForceBorderless=false
ForceBorderlessFullscreen=false
 
[ENGINE]
ForceAnisotropicFiltering=true
MaxAnisotropy=16
ForceLodBias=false
LodBias=0.0
AddDisplaySuperSamplingResolutions=false
EnableVSync=true
VSyncSkipNumFrames=0
 
[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=10.0
 
[iNPUT]
//shift
KeyCombination=16
//f12
KeyUseEffect=123
//home
KeyFPSLimit=36
//num /       106
KeyShowFPS=106
//print screen
KeyScreenshot=44
//enter
KeyEditor=13
//f4
KeyFreeVRAM=115
 
[ADAPTIVEQUALITY]
Enable=false
Quality=1
DesiredFPS=20.0
 
[ANTIALIASING]
EnableEdgeAA=false
EnableTemporalAA=false
EnableSubPixelAA=false
 
[FIX]
FixGameBugs=true
FixParallaxBugs=true
FixParallaxTerrain=false
FixAliasedTextures=true
IgnoreInventory=true
FixTintGamma=true
RemoveBlur=false
FixSubSurfaceScattering=true
FixSkyReflection=true
FixCursorVisibility=true
FixLag=false
 
[LONGEXPOSURE]
EnableLongExposureMode=false
Time=1.0
BlendMax=0.0

 
I would appreciate a more experienced eye on these to make sure I set them up properly.

Share this post


Link to post
Share on other sites
  • 0

Changing the path for screenshots fixed it!  Thanks a ton, I was worried it was a symptom of something much more serious.  Thanks a ton for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.