Jump to content
  • 0
Sign in to follow this  
Enchanteur33

Solved a Strange CTD issue, What happens ?

Question

Hello,

 

Many people post here because they need help in order to solve a CTD.

Here, I solved it by myself, but I need to know why and how.

 

I'm currently installing STEP and I have installed all until aMidianBorn - Content Addon.

Then I suffer a lot of CTD. Best way to find something wrong is to go in whiterun, and go in Jorrvaskr, then go out.

Always something happen here. You can't go in (CTD), and sometimes you can go in, but can't go out (CTD).

- I get problems when installing XCE, partialy solved.

- I removed Complete Crafting Overhaul Remade and Unknown Enchants because these mods do to much messages on high-left corner of the screen, and I'm not sure the game is stable if they didn't finish to load all.

- I removed Consistent Older People because the mod need another one I didn't install yet.

 

Most of the textures I installed are HD.

But I rollback some, like "Superior Lore-Friendly Hair". Was HD, but STEP guide says "Use the "SLF Hair - Rough Hair - Lite 1K" main file." So I have Insttaled the right one. 

 

 

So, now, main problem about aMidianBorn - Content Addon.

- I remove most of the mods in a testing profile, and then, aMidianBorn - Content Addon didn't cause CTD. So I tryed to find what other mod conflict.

Many hours later... I have tested all others mods, and the only one that make crash my install was... "BROWS" ?!

 

BROWS : this is not the Mod I was expecting to make some CTD. The Mod don't seem complex, but netherless, it install a .esp. I've installed HD version.

 

So what I did : I've uninstall the BROWS mod HD, and install the lite version. And then, the game didn't cause CTD at Jorrvaskr !

 

Now I need to know why.

My PC is a good one (i7, GTX 970, 16go ram), and .ini files are the default ones.

 

- What's going wrong ? Is there a problem of RAM overload because to much HD content ?

- SKSE memory fix is really working right ? 

- I didn't have this sort of problem with my others mod's installations (and a lot of HD).

- Is there something special about HD mods than change caracters (hair, face, brows) ?

 

For information : I have installed Skse in the main game (not in MO), all scripts are in C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data

So SKSE don't appear in the Mod list of MO.

 

How to be sure SKSE.ini is launch ?

 

My SKSE ini is :

 

[Display]
iTintTextureResolution=2048
[General]
ClearInvalidRegistration=1
[Memory]
DefaultHeapInitialAllocMB=768 
ScrapHeapSizeMB=256
 
Thank to anyone replying. Have a good day.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Sure, now I can install next contents of the guide.

I test the install with regularity, because if something goes wrong, it's more easy to find the problem with only 3-4 mods installed at one time.

Installing STEP take me long time, and now with IRL/work, I can't spendt more than 1-2 h by day at instaling that.

For now, I will examine how memory is, if Skse memory patch work well.

 

I don't use ENB, but I read somewhere that there is an Enb memory patch/boost.

Skyrim use 3.1 go (no more than 4go) at maximum.

What does the memory patch ? Skse memory is able to use more than this amout of memory for skyrim ?

And ENB boost is able to do so ?

Maybe it can be a solution to use an ENB if this is real.

 

EDIT : Memory blog is installed.

 

It show this :

logging of blocks enabled
logging max values only
Timer disabled
Block1 Block2
512MB 256MB
85 8
.... until ...
225 98
225 99
225 100
225 101
237 101
 
After, CTD. I volontary reinstaled brows HD to see what happens.
But even with brows lite, It's not really stable, I tested it many times, the whole is Ok, but a random CTD occured.
So there is something unstable, maybe it's not Brown the real reason.
 
SKSE.ini is :
[Memory]
DefaultHeapInitialAllocMB=768 
ScrapHeapSizeMB=256
 
So why memory blog show :
Block1 Block2
512MB 256MB
 
instead of
Block1 Block2
768MB 256MB
 
?
Edited by Enchanteur33

Share this post


Link to post
Share on other sites
  • 0

You should use ENBoost at minimum. It'll make the game more forgiving so you'll crash less if you're using a lot of textures, scripts, etc. The memory patch included in SKSE is separate from the ENBoost Memory patch.

 

Think of ENBoost as Memory Patch 2 and the one in SKSE as Memory Patch 3 they're both good but together they're amazing. Here's a little snippet from Sheson's post on ENBdev forums.

 

Time for Skyrim Memory Patch 3.0

It has been a while since the first memory patch that fixed 4GB LAA that made it into the official game. Thanks to Boris we have the second memory patch ENBoost taking care of textures not wasting main memory anymore. In this naming tradition this third memory patch will allow Skyrim to use that available space right from the start to fix ILS (infinite loading screen) without side effects and other memory related CTD (crashes to desktop) or freezes. After many hours of peeking and poking it turns out there is a simple fix and one has to wonder why this is not something that is implemented as an option or parameter for the PC version of the game.

How it works

When tesv.exe is started it allocates two 256MB blocks of memory. When the first block gets full, the engine will allocate more blocks. This can cause the known troubles. Thankfully, by telling the engine to request a bigger block from the start it magically makes use of it without any further ado. This isn't the case with the second block. Thankfully again, the second block does not fill up as quickly and once it is full the engine does not trip over itself when allocating more blocks.

To make the engine allocate a larger block of memory it needs to be patched. This needs to happen very early in the process. This can not be done by a SKSE plugin because they are executed much later. However, SKSE loader already patches tesv.exe before the game starts and since SKSE sources are provided adding the patch is straight forward.

Because of the nature of this patch I will only provide instructions how to do this.
I contacted Boris about this and he is doing his own tests and investigations. If this can be part of ENB I do not know. Best not to waste his time with silly questions icon_e_smile.gif

Will this help your ILS, CTD or freezing?

You have a 64bit OS and lots of main memory. You have decent hardware. You already use ENBoost and do not run out of VRAM. You went through all your mods, used tes5edit to clean them and use BOSS and what not. You searched and read lots of discussions and guides and spend hours over hours fixing and optimizing everything.

If you use safety load this fix will most likely help you to replace it and not have any side effects.

You can get VMMap and check if the first memory block is fully used. It is a yellow private data block that at first has 2 childs. Once all its memory is commited it only has one child and both the size and committed column showing the same number 262,144K.
This is not problematic in itself, but this condition raises the chance for ILS, CTD and freezing and this fix will most likely help avoiding any of that.

 

 

Share this post


Link to post
Share on other sites
  • 0

Ok, I will take a look at ENBoost, but ENB is not really compatible with 3d vision, so, there will be a lot of testing here again. And I don't need to really use ENB for other thing that ENBoost. Sweetfx is enough.

 

I solved the unstability. I have checked STEP mod list, but didn't think about do so with "unmanaged" list. And there was a problem here. Now game don't make CTD, even with brows HD, all is ok.  

Share this post


Link to post
Share on other sites
  • 0

Bad news, nothing is really Solved.

 

I switch from MO 1.2.15 to MO 1.2.17, because MO 1.2.15 have problems with unmanaged mods.

 

Then CTD at Jorrvaskr come back. This time, my unmanaged mods list is clean and in the good priority order.

I suppose it worked a little for a while because this list was in wrong order with MO 1.2.15.

 

I made CTD disapear with amidiaborn-addon out, and brows out, and better males (face and underwear).

If I just come back Genox face, or underwear, CTD occur when enter Jorrvaskr or exit (it depends of the mods). But I read information and there is only textures in one of these mods, and other textures and meshs (I saw a strange subfolder "m" inside one, but maybe it's normal).

I can use brows and better males if I put out all amidiaborns mods (weapons , armors, etc..).

 

With Enboost, only one game do that : instead of CTD, I entered Jorrvaskr, but all screen become white and stay white after exit Jorrvaskr.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.