Jump to content
  • 0
Sign in to follow this  
Southman

FPS-limit, best setting for 75hz?

Question

Hi!

 

I've searched and searched, but couldn't find a good solution.

 

I have a 75hz monitor, and i'm not using vsync (for many reasons). I'm currently using nvidia inspector to limit the fps.

 

I recently tested to limit it to 73 fps, with no inputlag what so ever. But the lines on the screen are terrible. I read somewhere that 2 fps above your 'hz' is a good thing to try.

 

But i'm not sure, does anyone here have a good suggestion?

 

Note: The strange thing is, when setting the limit to 58 fps my game froze more then ever before, no clue why. And the reason why i'm not using enb or hardware vsync is that my game gets 'clogged' up and everything goes into slowmotion if loading a big area with many items. That don't happen with vsync off, strangely.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Look turning off the game vsync in your Skyrim INIs is NOT recommended at all. And any FPS above 60 will cause you issue with physics and timed events.

 

Skyrim is designed to be played at 30-60 FPS period, the engine becomes unstable and will cause issues.

Share this post


Link to post
Share on other sites
  • 0

But if you disable vsync and have a fps-limit then what's so bad about turning off vsync?

 

Anyway, then what do you guys here recommend? ENB vsync or hardware vsync? And should i have any fps-limit if using vsync? Thx!

 

 

Edit: And if using ENB vsync, then ipresentinterval in skyrimprefs.ini should be at 0 right?

Share this post


Link to post
Share on other sites
  • 0

Using vsync is more for screen tearing and physics that FPS limit. Yes it will limit at 60 FPS, but that is the highest that the engine should ever run anyways.

 

We actually don't recommend turning off Skyrim's vsync, our outlook with INIs is that less is more. In my experience ENB vsync caused other bugs, so I stopped using it, but that was a while ago. I never tried hardware vsync, I usually just set it to Adaptive in Nvidia Inspector.

Share this post


Link to post
Share on other sites
  • 0

Okay, i will give skyrims 'own' vsync a go and with triple buffering set to 'on' in nvidia inspector.


"V-sync is entirely the user's choice. Enabling can create smoother game-play, but can also create mouse lag. Disabling v-sync is generally recommended and can improve performance. The recommended setting here is "Use the 3D application setting". "

 

You recommend to disable it in a way... This is confusing......... :D

Share this post


Link to post
Share on other sites
  • 0

It can improve performance, but the cost of that performance is screen tearing. Also, you will get massive FPS spikes will in caves and dungeons which will send stuff flying around the room the second you touch it.

 

I guess that part of the guide may a bit old, as we get more info on things sometimes pages on our wiki don't get the attention they deserve.

Share this post


Link to post
Share on other sites
  • 0

Yeah, okay. Anyway i found a good solution for me. I disabled enb vsync and set ipresentinterval=0 and finally forced vsync in nvidia inspector + triple buffering on. Works great so far, less inputlag then with only ipresentinterval=1.

 

I read nvidias vsync has a fps-cap like skyrims own vsync. So physics shouldn't be a problem now. :)

Share this post


Link to post
Share on other sites
  • 0

Southman, you might find this post helpful: https://forum.step-project.com/showthread.php?tid=3327&pid=49845#pid49845

 

You can turn vsync off so long as you use a frame rate limiter to keep your fps <=60. https://www.gameskyrim.com/not-disable-vsync-t210795-200.html

 

Disabling vsync isn't the cause of the wonky physics. vsync itself can't affect physics. The whole do not disable vsync thing initially started because people would disable that without an fps limiter. They would see the physics go crazy and consider that the cause.  When in fact, the cause of the physics going crazy was a result of the frame rate exceeding the expected values.

Share this post


Link to post
Share on other sites
  • 0

Yes. And in your very second post this is what you wrote. I directly answered your questions.

 

But if you disable vsync and have a fps-limit then what's so bad about turning off vsync?

 

Anyway, then what do you guys here recommend? ENB vsync or hardware vsync? And should i have any fps-limit if using vsync? Thx!

 

 

Edit: And if using ENB vsync, then ipresentinterval in skyrimprefs.ini should be at 0 right?

 

So, I was just trying to clear things up by providing concrete information about how vsync, frame-rate, and physics work together and interact. A lot of people just throw things out there as tweaks and fixes and things you should try without really knowing the reasons why. It's just something they heard. With my links, I provided you the info on why things work the way they do. It's up to you if you find it useful or not.

Share this post


Link to post
Share on other sites
  • 0

Okay, i think i just solved that in my head and thaught i had written that i understood all that.. But i see now that maybe i did not. :)

 

Thanks for the links, good info!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.