Jump to content
  • 0

FPS rate into hundred plus ! ????


Quahogs

Question

I have FRAPS loaded up and when I enter Skyrim thru SKSE or steam launcher FPS goes from 30 to approx 2000 when the fog rolls in.  Launching a new game thru MO SKSE (alternate start) brings me to character creation in the dungeon and FPS SITS at 230 without the character even moving.   Launching a new game thru Steam gets me on the cart which is flipping all over the place with the FPS about 150

 

This is not good.  I noticed the animals flipping out, defying physics walking jumping into the air and I know a high FPS is the cause.  But what is creating this abnormally high FPS issue ?  

 

History:

 - I'm following SR Legendary (yes I'm aware of the warnings but I really want the best possible game - graphics and performance I can get).  I'm willing to take it slow, troubleshoot and adjust.  I have no immediate visions of granduer

 - I'm up to the face/body section.  I've been monitoring gameplay just to check issues after each section.  

 - Up to this point I've made the SR LE tweaks for eventual ENB use - MSAA and AF set to off.  

 - I had enbseries 2.06 working with realcinema and had no crazy FPS spike.  It maxed to 60 (as shown by enb fps monitor) but the FPS would drop to single digits when I panned around - sputtering and     stuttering (ANOTHER issue but can't even address THAT monster yet)

 - At this point I decided to abandon ENB - deleted it from ENB manager and removed enb files from skyrim\ dir.  

 - I changed back any ENB adjustments to skyrimpref.ini and changed the launcher options back to MSAA 8x and AF 4x and made sure Nvidia's Inspector profile is back to original Elder Scrolls Skyrim

 

Questions:

1. I have modified launcher's Options, modified Nvidia's Inspector, GEforce Optimizer and tweaked skyrimpref.ini.   What overides what?  I don't understand what skyrim launcher reads or SKSE launcher reads upon startup.   I had set a frame rate limiter in Nvidia's Inspector (40) but FPS still went through the roof.  

2. Nvidia Inspector.  Do the profiles I adjust/create even help run Skyrim ?  Every time I go back into Inspector the profile that comes up is the Global Driver profile.  

3.  Crazy high FPS rate.  I have googled this issue but no one seems to have any issues over 60 FPS.  Is FRAPS not working correctly?  Is there another FPS monitor out there beside enbseries which I don't have installed 

4.  Crazy LOW FPS causing severe stuttering during panning.  This was my initial problem with the ENB installed and now without ENB.   I know this can be anything.  v-sync enabled or disabled for this?  I have also set MSAA and AF to disbled and still have issues.  I know this one is going to take some time 

 

If this is in the wrong forum or site I apologize.  I know that are a lot of sharp folks here.  I'm just hoping someone can steer me in the right direction or forum.  I really tried reading and working through this but I seem more confused than before I started.  

 

I included my current skyrimpref.ini, maybe something's obviously off there.  

 

Thank you

skyrimpref ini.txt

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

It is a known fact that skyrims physics engine goes totally nuts when the FPS increases way past 60.

This is mainly because the game is optimized to be run at 30 FPS which is what the consoles do.

 

The game should be vsync limited at 60 FPS if it is just with standard settings. Your gfx card should most likely not be able to push the game much beyond 60 at any rate.

You should never start the game through the skyrim menu expect the very first time to create the very first ini files. After that you should always start through your mod manager. Otherwise weird things can also happen.

 

Sounds like you got some conflicting settings all around... try to delete inspector settings, and just force through global and see if that fixes it.

If it still acts up try to roll back to a 314 version instead of a 320.

Link to comment
Share on other sites

  • 0

It has to be vsync turned off in skyrim.ini, look for iPresentInterval and set it to 1.

 

You could also try deleting both INI files and then letting new ones regenerate at the default settings. Then just make new adjustments accordingly.

deleted and added.  Still no change


It is a known fact that skyrims physics engine goes totally nuts when the FPS increases way past 60.

This is mainly because the game is optimized to be run at 30 FPS which is what the consoles do.

 

The game should be vsync limited at 60 FPS if it is just with standard settings. Your gfx card should most likely not be able to push the game much beyond 60 at any rate.

You should never start the game through the skyrim menu expect the very first time to create the very first ini files. After that you should always start through your mod manager. Otherwise weird things can also happen.

 

Sounds like you got some conflicting settings all around... try to delete inspector settings, and just force through global and see if that fixes it.

If it still acts up try to roll back to a 314 version instead of a 320.

deleted all the added inspector profiles.  Reverted the Skyrim profile to original and changed the global profile to vsyncmode_forceoff   Rolled back driver to 3.11.   Absolutely no change.  No more low FPS or stuttering though !   Game moves smooth.  Except for the flying animals :-(    

 

As soon as the fog rolls into the Skyrim screen the FPS shoot into the 1000's from 30.   Starting a new character using alternate start puts me in the dungeon standing still at 280 FPS.   What in the world is going on with this system ????   

Link to comment
Share on other sites

  • 0

Do you have vsync disabled in Nvidia Inspector, check both the global profile and TESV profile. I believe you need to look for Vsync Tear Control and set to Adaptive, and the Vertical Sync line to Use the 3D Application Setting. Also, look in any other profiles you created for Skyrim to see if something is up.

 

Oh and make sure you click apply so the changes stick, I forget to do that all the time.

Link to comment
Share on other sites

  • 0

Do you have vsync disabled in Nvidia Inspector, check both the global profile and TESV profile. I believe you need to look for Vsync Tear Control and set to Adaptive, and the Vertical Sync line to Use the 3D Application Setting. Also, look in any other profiles you created for Skyrim to see if something is up.

 

Oh and make sure you click apply so the changes stick, I forget to do that all the time.

Yes I have vertical sync for both set to vsyncmode_forceoff (there is no 3d application setting) in both profiles.  I have vertical tear control set to _disable (there is no adaptive setting).  I also set the Frame rate limiter to to   PS_framerate_limiter_FPS_40.  NO change whatsoever.   Saved closed clicked back in and settings took

 

I found the 3.14 driver and re-installed that.   video inspector is v 1.9.7.2 - could that be a factor ?

Link to comment
Share on other sites

  • 0

I thought reinstalling the driver would reset the nvidia inspector profiles to default? Is forceoff the same as disabling vsync with hardware settings? Maybe change that to something else and see what happens, otherwise try something that Aiyen suggested because I'm about out of ideas.

Link to comment
Share on other sites

  • 0

Oh baby! The latest video inspector was screwing it all up ! I looked at the wiki nvidia skyrim guide and noticed the v. there 1.9.6.8. I was wondering why the insrtructions/settings didn't match up. Didn't think that much of it. NOw the guide is per rote and I made the appropriate choices choosing an FPS cap of 60 too and 60 it shows :-) I think my low FPS stuttering had to do with the VGA splitter I was using between pcs. When I plugged the monitor right to my Skyrim PC I think that was the trick. At least I hope it wasnt a coincidence. Game looks beautiful ! :-) Thanks, you people are the best !

Link to comment
Share on other sites

  • 0

You only ever need to enter the steam launcher one time!

After that default ini´s are created. Those are then copied over to MO´s profiles and you can alter them there to your hearts content, while knowing that the default ones are safe and sound in their usual documents spot.

 

SMAA is done by external injection, not by any .ini file. So not entirely sure what you mean.

Link to comment
Share on other sites

  • 0

You only ever need to enter the steam launcher one time!

After that default ini´s are created. Those are then copied over to MO´s profiles and you can alter them there to your hearts content, while knowing that the default ones are safe and sound in their usual documents spot.

 

SMAA is done by external injection, not by any .ini file. So not entirely sure what you mean.

Well for example I was going to forgo using an ENB and had SMAA at 8 and AF at 4 under the Launcher's Option section.  I change my mind and want to run an ENB so I turn both those to off.  Under my documents I see the new ini's.  However under MO I see older v. modified by me sometime earlier today.   Since I made an adjustment like that do I have to delete those INI's from mod again ?  What I don't know is if the INI's in MO instruct Skyrim to have both SMAA and AF off.  

 

Also does the nvidia injector driver settings trump what the INI's say in MO at startup ?  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.