Jump to content

Z-fighting ini tweaks


Recommended Posts

If you are not familiar with the term Z-fighting it refers to the flickering of textures in the mid - distant terrain, often most pronounced and visible in distant mountain textures during camera movement both in first and third-person view.


Not everyone seems to suffer this effect, although it is graphics card independant (can affect scenes rendered by nVidia or ATi GPUs) and appears to be worsened by certain combinations of game/graphics driver version.


Thanks to some investigation and persistant testing by one of our members - torminater - we may be able to offer some .ini tweaks that will significantly reduce this intrusive effect :)


------------** The work offered below belongs to Torminater and we thank him for his determination to research this topic **------------


How to reduce Z-fighting in Skyrim significantly


What is z-fighting?

Z-fighting describes a very complex problem which spreads across many games and many graphic cards including the two big companies nVidia and ATI. In game it shows as a very fast flickering texture. This is because the texture itself consists of different layers. If those layers cannot be strictly separated from another as it is with z-fighting you see the flickering. If your interested what it is exactly, have a look at this article:https://en.wikipedia.org/wiki/Z-fighting'> https://en.wikipedia.org/wiki/Z-fighting


Do you have z-fighting?

Before you follow the tweaks you should be sure, that your Skyrim actually has z-fighting. Before testing, copy your skyrim.ini and skyrimprefs.ini located in your Documents/My Games/skyrim folder to a separate folder and delete the originals. Now open your game via the Steam Skyrim Launcher. Choose Ultra settings. If your rig can't handle that use either the settings you used so far or pick the High/Medium/Low-setting. Preferably the maximum setting your rig can handle. Now click on Options>Advanced>View Distance>Distant Object Detail>Ultra. For testing purposes only increase Specularity Fade and Light Fade to max. Check that Object Detail Fade is unchecked. Now run Skyrim.


There are two spots where you will be able to see z-fighting definitely if it is there at all.

One is when you come out of Helgen Keep (the dungeon you first go through when you start a new game. Straight ahead is a mountain range. If it is foggy or bad weather you might not recognize the z-fighting. The second spot is when you leave Dragonsreach through the main portal. Stop at the beginning of the stairs and look at the mountain side straigth ahead. It is very important that the weather condition is the following: daylight, clear, sunny. So in other words: no clouds, no fog, no precipitation. At both spots move your character and camera slowly and look out for a flicker in the mountains. If you see something like this https://www.youtube.com/watch?v=orcXIA3gnBg, you belong to the pretty large group of players who have the same problem.

If you don't have ANY z-fighting, then I kindly ask you to post your

1: OS

2: Exact Video card model

3: Driver version

4: Video card control panel settings

5: In-game settings

6: ini tweaks

7: mods

8: dxdiag


The Skyrim community will thank you!

Why do you have z-fighting and others don't?

There are systems that have really big problems with z-fighting and others that have little to no problems. Why it is that way nobody can really say. There are certain hypotheses but nothing certain which is in some way due to people who don't have z-fighting but don't reveal the details of their set-up, so others cannot find out why they have'nt got it but others have. Most certainly z-fighting has nothing to do with the power or performance of a system. The only reason why so many people with low-end rigs don't notice any z-fighting is because they have low-medium-high Distant Object Detail settings. This can eliminate z-fighting on distant objects. The down-side is that very distant mountains look very ugly. Especially for high-end rigs and players who want to improve their Skyrim experience to the absolute maximum of graphics quality that remains a big problem. If you don't belong to this group set your Distant Object Detail to whatever eliminates z-fighting at the spots mentioned above and be happy about it. If you want to minimize z-fighting and keep Skyrim's beautiful mountains you are welcome to read on.

How can I get rid of z-fighting?

Unfortunately there is no known solution which eliminates all of the z-fighting so far. It can only be reduced so much, that you barely notice it if at all.

There are two ways of trying to get rid of z-fighting. The hard way and the easy way. The hard way would be figuring out what constellation of drivers, forceware options, general Skyrim settings, mods and ini-tweaks presents you with the the best result concerning your specific interests. Please share your results in these threads https://forums.bethsoft.com/topic/1336456...-fighting/



The easy way: benefit from my work on this matter. I have done it the hard way, and it was indeed hard. Especially as I found out, that 99% of my work was so far was useless and luck eventually stumbled me on a very good fix.

What did you do to solve the z-fighting issue so far?

First of all I did a complete reinstall of Skyrim 1.5.26 and didn't include a single mod in my testing. Not even the HD-DLC-pack from Bethesda itself. I will do this in the near future to find out, what can help reducing z-fighting additionally. Then I followed my own guideline to systematically reduce z-fighting with every step I took.

STEP 1: Testing many different nVidia-drivers

No driver fixed z-fighting. There were some that had less z-fighting than others but even the "best" driver was still really bad. My general rule of thumb: use the newest driver available for your graphic card model. You can test the official and inofficial beta-drivers, too. If they present you with similar z-fighting, better performance and don't cause any glitches you didn't have before, stick to them. They are usually safe for use even if they aren't WHQL-certified.

STEP 2: Testing nearly all of the different settings in NVidia Control Panel and nVidia-Inspector

Certain settings like enable stereoscopic 3D and deactivating the effecty when a game starts (Skyrim SLI Water Bug Fix) seemed to worsen z-fighting, but since I was the only one evaluating about 40 videos which all had about the same amount of z-fighting, I cannot prove that any changes made there altered the amount or strength of z-fighting for me.

STEP 3: Checking the different Skyrim Launcher profiles

I found out, that at High-setting I don't have any distant mountain flicker. Instead I had flickering on closer mountains. On Ultra settings only the distant mountains have flickering. I found the setting which caused this z-fighting and found out what it does in SkyrimPrefs.ini. The bad guy is "Distant Object Detail". Set on lower values moves the z-fighting closer to the player. On Ultra it is the furthest away. For obvious reasons I sticked to Ultra-settings.

STEP 4: Extensive ini-tweaking

I have tried out many many many ini-tweaks and have found a tweak combination that drastically reduced z-fighting for me. Here you can find the proof of this:


I am very happy about my discovery and hope that many of you will be able to enjoy their skyrim a lot more.

What is your fix?

The thing is, not everybody gets the same z-fighting or the same results when applying my fix. You can post your own rig, drivers, skyrim version and the results of my fix for you personally. I'll have a look at it and try to make an educated guess as to what you could still improve.

Important for you will be, that this fix costs you some FPS. In wide-open locations like the plains of Whiterun you might experience a severe drop of FPS depending on what other mods or ini-tweaks you use. If you cannot live with that you got 3 choices:

-take the fix and cut down on other mods or tweaks

-forget the fix and live with z-fighting

-go to your skyrim Launcher - Options - Advanced - View Distance - Distant Object Detail and set it to Medium or High and live with fugly mountains.


IMPORTANT: This fix is only approved for Skyrim Ultra-Settings from the original Skyrim Launcher. Whatever tweaks you made personally might cause problems. If you have a doubt copy your ini files to a separate folder. Then delete them from the Skyrim folder and open the Steam Skyrim Launcher. Pick Ultra-settings. Then start the game to create new .ini's. Now apply the fix(-es). After saving your ini-files make them "read-only" so your skyrim launcher cannot change any of the new values.


FIX Part 1:

Open your SkyrimPrefs.ini. Usually it should be found under Documents/My Games/Skyrim

Scroll down until you reach the [TerrainManager] section of the file.

Change all the values so they look like this:








Now search for "fSkyCellRefFadeDistance" and change it's value to 500000.0000

Save and exit


Open your Skyrim.ini. You can find it in the same folder you found your SkyrimPrefs.ini

Under [Display] add the following line:


Save and Exit.

The normal setting is 15.0000 (even though it's not there, the game calculates with this value). 25.0000 is the maximum approved value. everything above can cause severe graphic glitches. So try out values between 15.0000 and 25.0000 to find your own sweet spot. (Thanks to hlvr for this information. check out his thread here: https://forums.bethsoft.com/topic/1336456...-fighting/)


FIX Part 2 (optional and only for very good rigs):

Please do look at this thread to weigh the benefits against the problems of doing this tweak:


Open your Skyrim.ini. You can find it in the same folder you found your SkyrimPrefs.ini

under [General] add the following line:


change uExterior Cell Buffer=36 to uExterior Cell Buffer=64

Save and exit.

You may try setting uGrids to 9, too. It's just supposed to reduce the z-fighting whilst closing in on structures, e.g. running from Whiterun Watch tower (where your first dragon attacks) to Whiterun. The walls start flashing at some point. High uGrids help against that, but you should know what you're doing before you mess everything up.

"This fix costs me too much performance! What can I do instead?"

First of all: do NOT apply the second part (uGridsToLoad) of the fix. Skip it entirely.

You can try the fix on a clean Skyrim install without any mods and see if it's still too costly performance-wise.

If you run a stable Skyrim config at Ultra-settings (>35 FPS recommended) you can try to change only the value of fSplitDistanceMult to something in between 2.0000 and 3.0000. You find this value in your SkyrimPrefs.ini. It makes the z-fighting less prominent. What you can try, too, is applying my fix in small steps. So instead of copy and paste, do some testing yourself. If you find a good setup please post it here https://forum.step-project.com/showthread.php?tid=154 and if possible your:

1: OS

2: Exact Video card model

3: Driver version

4: Video card control panel settings

5: In-game settings

6: ini tweaks

7: mods

8: dxdiag


This would be very much appreciated by the Skyrim Community in general and the STEP community in particular!

Do you want to contribute to the research work done on z-fighting in Skyrim?

Everybody who wants to help is welcome to do so. Try to build on the work already done on the topic of z-fighting and expand on it. Do your own research and post your interesting findings in this thread here please https://forum.step-project.com/showthread.php?tid=154


Is this it? Will there be a continuation on this work?

As long as there is z-fighting in Skyrim and I am playing video games I'll work on this matter. Anything new will be added to this guide and mentioned in the Update-Section. Feel free to join the STEP community and contribute to our project!


Thanks to hlvr for his dedicated work on z-fighting (his own thread can be found here: https://forums.bethsoft.com/topic/1336456...-fighting/) and his own fNearDistance-tweak that helps a lot against z-fighting

Thanks to the STEP community for testing a whole lot of different settings and thus providing me with a wider range of experiences

Thanks to anybody who is working on the z-fighting issue

Link to comment
Share on other sites

have been looking into this topic even more after talking with you and finding more articles etc about it. Very excited in going further with this. Looking over the relationships between as the articles call it: ZNear ZFar Floating Point Render Targets, the prepasses....etc. Seems no one of them on their own fully gets rid of this phenomena but who knows if some combination of them can't eliminate it for people. I do know and the reason I suspect the relationship between all of them is that we both have similar FBlock ini settings, only difference between our settings is you have the FNear tweak where as I do not and I have FloatPointRenderTarget set to 1 whereas you do not. I haven't seen Z-fighting in any jarringly perceptible way since leaving BF3 lol. This is fun.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.