Jump to content
  • 0
Sign in to follow this  
KamisantaLolz

DynDOLOD Solstheim Initialization

Question

Posted (edited)

Yo. Whenever I come to Solstheim by taking the Northern Maiden in Windhelm, I wouldn't see a message "DynDOLOD successfully initialized" upon arriving like I usually would when visiting another "world". The "DynDOLOD is active" box in the MCM menu is unchecked and greyed out. I have to enter an interior location, save and relaunch the game, then go outside for it to pop up with the box in the MCM menu to be activated. I'm not sure if this is an intended behaviour. I'm aware of dynamic LOD, but if I keep travelling around Solstheim, DynDOLOD will never initialize and I will notice little issues with distant waterfalls and trees. Was tested out with DynDOLOD v2.98 and matching resources. DynDOLOD 3 Alpha 87 has the exact same behaviour.

Skyrim SE v1.5.97. PapyrusUtil SE - Scripting Utility Functions v3.9. SKSE v0.2.0.20.

I also have a report about trees disappearing in Solstheim when using Enhanced Vanilla Trees v2.2.1 and DynDOLOD 3 Alpha 87 with DynDOLOD Resources vAlpha-24, but that's another story. I reported the issue on EVT page on Nexus and the author said that it might be a problem with DynDOLOD. I don't have this issue with DynDOLOD v2.98 and the previous version of EVT.

Edited by KamisantaLolz

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

Yes speedmult is related. Anything greater than 500 turns off dynamic LOD switching. It is mentioned in the readme.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

No generation logs or papyrus logs were provided.

Make sure absolutely nothing from the tools generated output folder is being overwritten by anything.

Test with a new game. DynDOLOD initializes as soon as the boat ride fades from black. DynDOLOD initializes only once per world-space  after a new game/cleaned save. Properly follow the clean save routine when updating existing saves.

If that does not happen, pay attention to any other messages, last message reported in the MCM, message from the DynDOLOD scripts in the papyrus log.

Pay attention to log message at generation time. If participating in the DynDOLOD 3 alpha test, pay attention to the summary as well. Read the first post https://stepmodifications.org/forum/topic/16796-dyndolod-3-alpha-87/ where to post, which log files to upload when making posts.

It is unclear what "trees disappearing in Solstheim" is supposed to mean. DynDOLOD generates LOD. It does not change full model trees. If trees do not have LOD it typically means no LOD assets (billboards, maybe 3D LOD models) are installed for it. If there is LOD for trees that do not exist anymore because a mod removed them, generate LOD for the current load order. LOD is only generated for references that exist, are not deleted or permanently disabled. Any problem with full models not showing has nothing to do with LOD generation.

Share this post


Link to post
Share on other sites
  • 0

Yeah, sorry. Here's DynDOLOD and TexGen log files. Papyrus logging isn't enabled, so I can't provide it unfortunately. If it's really needed, I'll enable it and post the log. The thing about trees I'm unsure about, need to do more tests. I think it's EVT honestly, because without it it's all right. The previous version of EVT for DynDOLOD 2.xx works well.

It's Solstheim that bothers me. I always test out DynDOLOD on a new game: no coc, no tcl, not even tgm. I take a boat to go there. Nothing overwrites generated by xLODGen, TexGen and DynDOLOD output archives in MO, they're placed last in the load order. DynDOLOD.esm comes as the last ESM after USSEP. DynDOLOD.esp is the last ESP plugin. Only Occlusion.esp overwrites it. In the MCM it just says that DynDOLOD has no data for this location. I mean, it's not really an issue to go to any interior cell in Raven Rock, save and relaunch the game for DynDOLOD to work properly on Solstheim, but if it shouldn't be like that, I'm concerned.

DynDOLOD_SSE_log.txt TexGen_SSE_log.txt

Share this post


Link to post
Share on other sites
  • 0

Enable papyrus logging. use cow DLC2SolstheimWorld 8 8 (or whatever coordinates put you right onto the island)  from main menu see what happens

If you are using PapyrusUtil test with DynDOLOD DLL or vice versa.

Share this post


Link to post
Share on other sites
  • 0

Using cow DLC2SolstheimWorld 8 8 makes DynDOLOD initialize successfully. I've also tried coc DLC2RavenRock01. Same successful initialization. Both with PapyrusUtil and DynDOLOD DLL. However, when I take the boat it still doesn't initialize neither with PapyrusUtil nor with DynDOLOD DLL. There's no initialization In Markarth too btw as soon as I enter the city. Weird.

Update: OK I'm not sure what's going on. I've just rebuilt xLODGen, TexGen and DynDOLOD once more. The load order remains the same. This time I was testing it out without any console commands. Ran tests like 4 times. Everything is working well now. DynDOLOD initializes successfully in all worlds as well is in Solstheim. Previously I used player.setav health 5000, player.setav stamina 5000 and player.setav speedmult 700 to go much faster. Not sure if that's related.

I guess this can be closed now. Thanks sheson.

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, sheson said:

Yes speedmult is related. Anything greater than 500 turns off dynamic LOD switching. It is mentioned in the readme.

Reading is hard. I feel so stupid LOL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.