Jump to content
  • 0
Sign in to follow this  
PierreAngelique

xLODgen question, regarding snow

Question

Hi, I have spent all day trying to figure out this issue without finding a solution so I figured I would ask here in hopes of getting some input. I have been running xLODgen to generate LODS for my texture packs and overall the results have been quite positive, the Whiterun area lod's finally match more or less and look good. But my snow LODs are coming out very poorly and much too dark. What is strange to me is that the snow actually looks quite good before running xlodgen. Here is what I mean: 

 

Before running xLODgen:

 

https://imgur.com/0zFUBVn

 

After runnign xLODgen:

 

https://imgur.com/5lErbGb

 

After running x lod gen the snow lod doesn't match at all and is much darker. I am wondering if anyone has any suggestions or ideas why the snow would look so off, especially since it looked pretty good before running xlodgen. Also, as a secondary option, is there some way to just remove the snow lod that xlodgen adds, so that I can keep all of the other lod's it adds and which otherwise look quite good? I have tried placing Nordic snow last, after xlodgen output, but that doesn't seem to do anything.

 

For reference, i have been using the settings suggested by the TUCO guide and I am on Skyrim SE. 

 

Also, here is my texture pack load order, in case I am doing something glaringly wrong: 

 

Noble Skyrim

HD LOD's (for noble Skyrim / Dyndolod)

Tamrielic Textures 

Ineed (nordic snow snowdrifts option)

Better dynamic snow

Majestic Mountains

Better Dynamic Majestic Mountains

Nordic Snow

xLODgen output (i have moved this around to various positions to see if it would make a difference)

 

 

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

This is addressed on the first post and discussed in the xLODGen thread.

 

 

If brightness/contrast/gamma are left alone, then the LOD textures match the full textures in the loaded cells as long as the "improved" snow shader from Skyrim Special Editon is disabled. That awful shader does not apply to LOD.

 

Use a "neutral" noise.dds that does not darken or brighten the LOD textures.

 

Moving around xLODGen output does not solve anything. Either you use the generated LOD textures or you don't. 

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Hi Sheshon, thanks for the quick response. I only just got around to addressing this issue, but I wanted to provide an update in case others stumble on this post with a similar issue.

 

-The advanced snow shaders are /were definitely turned off when I ran xlodgen, I double checked both my bethini and skyrimprefs.ini as well as the SE launcher just to be sure, so I don't think that was the issue.

 

-I also played around with different noise textures including the one linked in the first post of the xlodgen main thread, and it didn't really make a fundamental difference.

 

-Currently I have mitigated the issue however by running xlodgen with a brightness of 3 and contrast set to 50. Its not perfect and I might experiment with different settings, but adjusting the brightness and contrast in this case has helped to significantly mitigate the issue and create better matching lods. Perhaps there is some kind of mod / texture conflict on my end, bc when brightness / contrast are set to 0, the LODs generated definitely do not match the close up textures in the foreground. 

 

Thanks again for the response, and for developing these utilities as well. 

Share this post


Link to post
Share on other sites
  • 0

The "improved" snow shader has nothing to do with LOD generation. It is applied to what the game things is snow in the loaded cells.

 

If darker/brighter noise.dds has no effect on terrain LOD textures, then the noise.dds is being overwritten by another mod. 

 

Applying any brightness/contrast/gamma means that the terrain LOD textures will not match the full terrain textures in the loaded cells. xLODGen uses the currently installed full landscape textures to do the exact same terrain splatting as in the loaded cells.

It is either noise.dds and/or INI settings causing discrepancies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.