Jump to content
  • 0
Sign in to follow this  
rageouss

LODGEN stuck for hours

Question

everything goes smoothly until dyndolod open lodgenx64, after that my ram shoots up to 100% usage and my computer turns into a snail, if I check task manager it shows lodgen using almost all my ram + barely using the cpu ( 0.2% at best ).. what should I do? i got it to finish once by waiting for like 6 hours but i cant do this every single time,

 

https://drive.google.com/open?id=1WjeWVdoCrRjN0THE4FK3-t3wHh4l9wUF ( my DynDOLOD_SSE.ini )

 

I have a 9900k@5ghz + 16gb of ram, and yes the CPU oc is stable

Edited by rageouss

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

FAQ: LODGen.exe: Runs a long time / The LOD files generated are several GB in size

 
A: The selected configuration options require a lot of work. Do not manually close LODGen.exe. Wait for all processes to complete before closing DynDOLOD.
 
A: If there are more objects with LOD, it takes longer and creates larger files. If there are more triangles in the models used for LOD, it takes longer and creates larger files. If there are more triangles in the terrain meshes, it takes longer. 
 
A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 
 
Leave Windows page file settings default.
Make sure all drivers are up to date.

Share this post


Link to post
Share on other sites
  • 0

all drivers are up to date, i've just started troubleshooting and removed noble skyrim + smim + blended roads, with those it finishes in 30~ minutes, i've run dyndolod before with much bigger textures so something must be up with my windows or the mods and no, i didnt use treefullfallback nor did i mess with windows page file settings

Share this post


Link to post
Share on other sites
  • 0

LODGen generates object LOD meshes from models it finds in the load order.

 

Disabling mods that change textures will not influence that.

 

Obviously test generating object LOD without ultra tree LOD.

Share this post


Link to post
Share on other sites
  • 0

i figured out why it happened, its because of cathedral landscapes, it has terrain lod included. removed the terrain lod from it and everything returned back to normal. double checked everything to make sure I wasn't crazy  :confusion:

Edited by rageouss

Share this post


Link to post
Share on other sites
  • 0

I suppose that means that FAQ answer "If there are more triangles in the terrain meshes, it takes longer." applied.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

I'm having a similar problem except this is on a vanilla load order. Dyndolod runs fine but LODGen is taking ages to finish. I'm completely at a loss as to why this is happening as I've been using Dyndolod forever and have never had this happen. After doing some searching on google I've seen that the TreeFullFallBack=0 is one of the causes for this but I've never touched that setting and it's still at 1. At the time of this post, LODGen is working but it's been running for 4 hours when before the entire process took 20 to 30 minutes for a full load order. I've noticed in task manager that LODGen isn't using more than a gig of memory and about 15% of my CPU. I have 16 gb of ram and a 4790k non-overclocked. Any help is appreciated.

Share this post


Link to post
Share on other sites
  • 0
FAQ: LODGen.exe: Runs a long time / The LOD files generated are several GB in size

 

A: The selected configuration options require a lot of work. Do not manually close LODGen.exe. Wait for all processes to complete before closing DynDOLOD.

 

A: If there are more objects with LOD, it takes longer and creates larger files. If there are more triangles in the models used for LOD, it takes longer and creates larger files. If there are more triangles in the terrain meshes, it takes longer. 

 

A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 

 

Leave Windows page file settings default.

Make sure all drivers are up to date.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.